LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Updated FC3, can't see WAN (http://www.linuxquestions.org/questions/fedora-35/updated-fc3-cant-see-wan-297386/)

mamorrow 03-03-2005 10:15 PM

Updated FC3, can't see WAN
 
A very strange thing happened to me tonight. I checked up2date and found about five things to download and install, including an update to the kernel. After everything was installed, I restarted the machine and now I can no longer see the WAN. I can see all the other machines on my LAN just fine. I rebooted under the old kernel and it still doesn't work. I rebooted under Win2K and that works fine, so there is no hardware problem.

I can ping any address on my LAN (192.168.1.x) and I get a response. When I try to ping an internet address I get a "network unreachable" message. It was working perfectly before I did the up2date update.

What could have happened?

mamorrow 03-04-2005 07:46 AM

I forgot to mention also that I've verified that my firewall is not turned on.

I don't remember which modules other than the kernel were downloaded. Does anybody know where I can find the log that will tell me that? Maybe I can just start undoing the changes and see what works.

I'm kind of surprised that nobody else has experienced this problem in the last few days. I guess I'm the only one whose system was hosed by these updates.

tiger3 03-25-2005 07:47 PM

I experienced the same problem recently. I could ssh into my newly updated FC3 2.6.10. I could ping inside my network, but not out. I noticed 2 problems one was that my [B}default route[/B] was gone. So I added it back:

Destination Gateway Genmask Flags MSS Window irtt Iface
default 192.168.1.1 255.255.255.255 UGH 0 0 0 eth0
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0

Still did not fix the problem, then I noticed that I still had an old static route in my /etc/sysconfig/network-scripts file. (I recently got a new router and never had to make any changes)

***OLD***
DEVICE=eth0
BOOTPROTO=dhcp
onBOOT=yes
USERCTL=no
PEERDNS=yes
TYPE=Ethernet
IPADDR=192.168.1.10
NETMASK=255.255.255.0
GATEWAY=192.168..1.1
NETWORK=192.168.1.0
BROADCAST=192.168.1.255

I edited my /etc/sysconfig/network-scripts like below:
DEVICE=eth0
BOOTPROTO=dhcp
onBOOT=yes
TYPE=Ethernet
NETMASK=255.255.255.0
USERCTL=no
PEERDNS=yes
IPV6INIT=no

Then I restarted my network /etc/init.d/network restart and now I can surf and ssh from the updated kernel.
Hope this helps.....

mamorrow 04-03-2005 06:03 PM

Thanks very much. It was a relatively new installation, so I just reinstalled the system and reapplied all the updates. It now works great. Wish I'd gotten your post before I took the nuclear option, though!


All times are GMT -5. The time now is 03:31 PM.