LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Update fails, lirc, centos5 (http://www.linuxquestions.org/questions/fedora-35/update-fails-lirc-centos5-662085/)

MonsterMaxx 08-11-2008 05:20 PM

Update fails, lirc, centos5
 
Update fails on lirc with this message
file /usr/lib/liblirc_client.so.0 conflicts between attempted installs of lirc-lib-0.8.2-68.el5 and liblirc_client0-0.8.4-80_cvs20080528.el5

Also can't get the library to install because of this error so lirc is not working.

Any suggestions would be greatly appreciated.

[code]
# yum -y update lirc
Loading "fastestmirror" plugin
Loading "priorities" plugin
Loading "protectbase" plugin
Loading mirror speeds from cached hostfile
* atrpms: dl.atrpms.net
* atrpms-testing: dl.atrpms.net
* rpmforge: apt.sw.be
* base: centos.mirror.nac.net
* updates: mirror.newnanutilities.org
* addons: mirror.newnanutilities.org
* extras: mirror.newnanutilities.org
atrpms 100% |=========================| 951 B 00:00
primary.xml.gz 100% |=========================| 393 kB 00:02
atrpms : ################################################## 2027/2027
atrpms-testing 100% |=========================| 951 B 00:00
primary.xml.gz 100% |=========================| 50 kB 00:00
atrpms-tes: ################################################## 237/237
rpmforge 100% |=========================| 1.1 kB 00:00
primary.xml.gz 100% |=========================| 2.6 MB 00:07
rpmforge : ################################################## 7447/7447
base 100% |=========================| 1.1 kB 00:00
updates 100% |=========================| 951 B 00:00
primary.xml.gz 100% |=========================| 162 kB 00:00
updates : ################################################## 369/369
addons 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
primary.xml.gz 100% |=========================| 78 kB 00:00
extras : ################################################## 270/270
Excluding Packages in global exclude list
Finished
0 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: liblirc_client.so.0 for package: mplayer
--> Processing Dependency: liblirc_client.so.0 for package: lirc
--> Processing Dependency: liblirc_client.so.0 for package: libmyth-0.21_0
---> Package lirc.i386 0:0.8.4-80_cvs20080528.el5 set to be updated
--> Processing Dependency: libportaudio.so for package: lirc
--> Processing Dependency: liblirc_client0 = 0.8.4-80_cvs20080528.el5 for package: lirc
--> Running transaction check
---> Package portaudio.i386 0:18_1-3.0.el5 set to be updated
---> Package lirc-lib.i386 0:0.8.2-68.el5 set to be updated
---> Package liblirc_client0.i386 0:0.8.4-80_cvs20080528.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Updating:
lirc i386 0.8.4-80_cvs20080528.el5 atrpms 557 k
Installing for dependencies:
liblirc_client0 i386 0.8.4-80_cvs20080528.el5 atrpms 17 k
lirc-lib i386 0.8.2-68.el5 atrpms 16 k
portaudio i386 18_1-3.0.el5 atrpms 19 k

Transaction Summary
=============================================================================
Install 3 Package(s)
Update 1 Package(s)
Remove 0 Package(s)

Total download size: 609 k
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
file /usr/lib/liblirc_client.so.0 conflicts between attempted installs of liblirc_client0-0.8.4-80_cvs20080528.el5 and lirc-lib-0.8.2-68.el5

Error Summary
-------------
/code]

unSpawn 08-11-2008 06:31 PM

Quote:

Originally Posted by MonsterMaxx (Post 3244091)
file /usr/lib/liblirc_client.so.0 conflicts between attempted installs of liblirc_client0-0.8.4-80_cvs20080528.el5 and lirc-lib-0.8.2-68.el5

You could --downloadonly, install components manyally, backup /usr/lib/liblirc_client.so.0 outside the linker path and then try --force liblirc_client0-0.8.4-80_cvs20080528.el5 afterwards? For all the grief it's given me in the past I don't miss using ATrpms at all.

MonsterMaxx 08-11-2008 07:49 PM

I'm really sorry to bother you, but I'm afraid I didn't understand any of that other than backup the /usr/lib/liblirc_client.so.0

Are these switches I use on Yum?

unSpawn 08-14-2008 04:59 PM

Quote:

Originally Posted by MonsterMaxx (Post 3244183)
Are these switches I use on Yum?

Soz for late reply. --downloadonly is. --force is for RPM. In general you should only use --force if you know what you're doing or are willing to suffer consequences anyway (should not be fatal in this case).


All times are GMT -5. The time now is 05:43 AM.