LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 12-20-2006, 01:39 PM   #1
narendra.pant
Member
 
Registered: Mar 2006
Posts: 86

Rep: Reputation: 15
unknown filesystem type smbfs


when i m trying to mount the shares on my network

mount -t smbfs ...

then it is showing the err -- unknown filesystem type smbfs.
it is the problem in fedora core 5 and 6
it was working fine in the earlier distros . ie FC 3,4 etc ..
it's not eiter working with cifs .
i hav installed all the samba rpms
 
Old 12-20-2006, 01:54 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
afaik smbfs is now officially deprecated, so forget about that and try with cifs instead. under fc6 there is no smbfa.ko module at all, so it's a non starter really.

btw, smbfs / cifs are not really related to samba at all. samba is the server side, not the file system drivers.
 
Old 12-20-2006, 02:17 PM   #3
narendra.pant
Member
 
Registered: Mar 2006
Posts: 86

Original Poster
Rep: Reputation: 15
i tried with cifs but it didn't worked ...


can yu tel me how to mount the files sahred by other user on the lan on my pc
 
Old 12-20-2006, 03:43 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
well it sounds like you kinda already know how to do that... what are you actually running when trying to mount using cifs? try "modprobe cifs" if the module is somehow not being automatically loaded for you, but either way show us the full commands you're runnign and the full output from them.
 
Old 02-23-2007, 03:30 AM   #5
narendra.pant
Member
 
Registered: Mar 2006
Posts: 86

Original Poster
Rep: Reputation: 15
plz write the commands here

Quote:
Originally Posted by acid_kewpie
well it sounds like you kinda already know how to do that... what are you actually running when trying to mount using cifs? try "modprobe cifs" if the module is somehow not being automatically loaded for you, but either way show us the full commands you're runnign and the full output from them.

mighti be doing something wrong ..
u plz paste all what i hav to do .. here ,
and i wll reply u .. thnkx


wise i tried

mount -t cifs [to b mounted] [where to mount ]
 
Old 10-17-2009, 07:27 AM   #6
R03L
Member
 
Registered: Feb 2008
Distribution: mepis, ubuntu server ed. Debian. Redhat. Fedora, centos, LFS
Posts: 211

Rep: Reputation: 31
Red face mount -t smbfs unknown filesystem type smbfs

i tried
Code:
mount -t smbfs //**/fileserver/ /home/**/server_fileserver/
like much documents say.
in fedora core 11..

i get output
Code:
 unknown filesystem type smbfs
Code:
 in dutch: mount: onbekende bestandssysteemsoort 'smbfs'
also when i put in in fstab rule.
mount -a it spits out the same output..

can anyone help..
thanks in advanced
 
Old 10-17-2009, 07:33 AM   #7
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,511

Rep: Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884
are samba and smbfs installed?
 
Old 10-19-2009, 09:41 AM   #8
R03L
Member
 
Registered: Feb 2008
Distribution: mepis, ubuntu server ed. Debian. Redhat. Fedora, centos, LFS
Posts: 211

Rep: Reputation: 31
i have samba installed. but were can i find a tarball of smbfs?

itś not in yum repo so.
 
Old 10-19-2009, 10:10 AM   #9
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware 14.1 (multilib) with kernel 3.15.5
Posts: 1,549
Blog Entries: 12

Rep: Reputation: 177Reputation: 177
What was the output when you tried:
mount -t cifs //**/fileserver/ /home/**/server_fileserver/
 
Old 10-19-2009, 10:29 AM   #10
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 18, 19, RHL 5.2
Posts: 546

Rep: Reputation: 43
Not sure if you saw this, it is from the mount man page.

Mount options for cifs
See the options section of the mount.cifs(8) man page (cifs-mount pack-
age must be installed).

The thing you are most likely missing in your command is an account and password for the share. Look over the options on the mount.cifs man page to see how to add those to your command line. There are other options as well.

Drop the idea of smbfs, that is old news. You can also take a look at man smbclient just to get started. It is sort of like ftp for shares.
 
Old 10-19-2009, 12:35 PM   #11
R03L
Member
 
Registered: Feb 2008
Distribution: mepis, ubuntu server ed. Debian. Redhat. Fedora, centos, LFS
Posts: 211

Rep: Reputation: 31
su#
mount -t cifs //**/fileserver /home/**/server_fileserver
password: correct samba password
mount error(5): Input/output error
 
Old 10-19-2009, 12:36 PM   #12
R03L
Member
 
Registered: Feb 2008
Distribution: mepis, ubuntu server ed. Debian. Redhat. Fedora, centos, LFS
Posts: 211

Rep: Reputation: 31
su#
mount -t cifs //**/fileserver /home/**/server_fileserver
password: correct samba password
mount error(5): Input/output error
 
Old 10-19-2009, 01:47 PM   #13
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware 14.1 (multilib) with kernel 3.15.5
Posts: 1,549
Blog Entries: 12

Rep: Reputation: 177Reputation: 177
Don't know what the default is for your smb.conf; you probably need to edit it. Can you navigate to //**/fileserver in any other way to check whether the fileserver is visible on your network?
 
Old 10-21-2009, 10:49 AM   #14
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 18, 19, RHL 5.2
Posts: 546

Rep: Reputation: 43
Quote:
Originally Posted by wmakowski View Post
You can also take a look at man smbclient just to get started. It is sort of like ftp for shares.
smbclient is a good tool to use for debugging. Use smbclient -U userxyz -L hostname to list the shares on your host. It will prompt you for a password. Once you determine that your share is actually listed. Then you should be able to connect with it using smbclient -U userxyz //hostname/sharename.

After getting things sorted out with smbclient you can make adjustments to your mount command.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: unknown filesystem type 'devfs' error kushalkoolwal Debian 22 03-14-2006 04:14 AM
mount: unknown filesystem type 'NTFS' jnorcal Slackware 8 09-07-2005 06:18 PM
mount: unknown filesystem type 'ntfs' lowrida Linux - Newbie 3 08-01-2005 04:02 PM
Debian-sid: filesystem unknown parition type solferino Debian 1 09-03-2004 09:09 AM
root (hd 0,0)Filesystem type unknown, partition type 0x7chainloader +1 ece30675 Linux - Distributions 5 07-20-2004 09:04 AM


All times are GMT -5. The time now is 04:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration