LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 05-20-2004, 03:35 PM   #1
meonkeys
Member
 
Registered: Apr 2004
Location: Minneapolis
Distribution: Ubuntu
Posts: 45

Rep: Reputation: 15
unable to mount USB camera: "No medium found" in Fedora Core 2


I'm unable to mount my digital camera in order to copy pictures from the camera to the computer. I see the following error:
Code:
[root@chunk root]# mount -t vfat /dev/sda1 /mnt/cam/
mount: No medium found
camera: Leica Digilux 1
USB mass storage compliant?: yes
operating system: Fedora Core 2 (with custom 2.6.6 kernel)

The camera worked fine in Fedora Core 1. I'm using Fedora Core 2, but I've compiled a custom 2.6.6 kernel. However, the only difference between /boot/config-2.6.5-1.358 and my kernel (besides being a newer kernel version) is that I enabled ACPI software suspend.

Using these instructions on autoconfiguring USB mass storage devices in Fedora, I am able to see the device ("Camera") when I click on "Computer" on the desktop since the device has then been added to /etc/fstab. However, trying to click on the "Camera" icon gives the same error that a command-line mount gives, "No medium found".

Here's what I see in /var/log/messages after the camera has been plugged in:
Code:
May 20 12:12:56 localhost kernel: usb 1-1: new full speed USB device using address 5
May 20 12:12:57 localhost kernel: Initializing USB Mass Storage driver...
May 20 12:12:57 localhost kernel: scsi3 : SCSI emulation for USB Mass Storage devices
May 20 12:12:57 localhost kernel:   Vendor: LEICA     Model: Digilux 1         Rev: 0050
May 20 12:12:57 localhost kernel:   Type:   Direct-Access                      ANSI SCSI revision: 02
May 20 12:12:57 localhost kernel: SCSI device sda: 250881 512-byte hdwr sectors (128 MB)
May 20 12:12:57 localhost kernel: sda: assuming Write Enabled
May 20 12:12:57 localhost kernel: sda: assuming drive cache: write through
May 20 12:13:07 localhost scsi.agent[4678]: Attribute /sys/devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1:1.0/host3/3:0:0:0/type does not exist
May 20 12:13:44 localhost kernel:  sda:SCSI error : <3 0 0 0> return code = 0x70000
May 20 12:13:44 localhost kernel: end_request: I/O error, dev sda, sector 250880
May 20 12:13:44 localhost kernel: Buffer I/O error on device sda, logical block 250880
May 20 12:14:31 localhost kernel: SCSI error : <3 0 0 0> return code = 0x70000
May 20 12:14:31 localhost kernel: end_request: I/O error, dev sda, sector 250880
May 20 12:14:31 localhost kernel: Buffer I/O error on device sda, logical block 250880
May 20 12:14:31 localhost kernel:  sda1
May 20 12:14:31 localhost kernel: Attached scsi removable disk sda at scsi3, channel 0, id 0, lun 0
May 20 12:14:31 localhost kernel: Attached scsi generic sg0 at scsi3, channel 0, id 0, lun 0,  type 0
May 20 12:14:31 localhost kernel: usbcore: registered new driver usb-storage
May 20 12:14:31 localhost kernel: USB Mass Storage support registered.
Here's some other possibly helpful info:
Code:
[root@chunk root]# uname -a
Linux chunk 2.6.6 #1 Wed May 19 11:03:41 PDT 2004 i686 i686 i386 GNU/Linux
[root@chunk root]# cat /etc/fedora-release 
Fedora Core release 2 (Tettnang)
Any ideas?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"No medium Found" when mounting a DVD ROM that only contains data Gnarg Linux - Software 3 04-19-2006 01:18 PM
burning, ide-cd and "mount: No medium found" Creak Debian 3 09-18-2004 06:38 AM
Cannot install fedora core 1 or core 2: Initial setup crashes: "Unable to mount root" ovelasco Linux - Newbie 10 07-15-2004 08:19 PM
Unable to Mount," Bogus File System Found" nav_Lin Linux - Newbie 1 04-16-2004 10:27 PM
CD ROM mount error: "no medium found"????? RonRussell Linux - Hardware 8 07-01-2002 01:34 PM


All times are GMT -5. The time now is 07:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration