LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 07-18-2005, 06:43 AM   #1
ashwin_cse
Member
 
Registered: Jul 2004
Distribution: arch, rhel
Posts: 132

Rep: Reputation: 21
unable to connect to internet


Hi,
I have recently upgraded to FC4. I lost my internet connection ever since. Maybe it was just coincidence, that a problem was about to happen and i upgraded to FC4 ...I am able to connect from windows side of the same machine. I am using a ADSL connection with Huawei's SmartAX MT800 modem. The connection is like this:

A telephone line goes to a ADSL Splitter & a telephone line from adsl side goes to modem & another line goes to the telephone. A cat5 cable from modem goes to ethernet port of computer. During boot up the line says

Bringing up ppp0 [ok]

but there is also a another message which says (which i don't think is usefull but i include it anyway):

Bringing up eth0 [failed] Check cabel?

but this is the message i used to get even during FC3. I was able to connect then. The system-config-network says ppp0 as active.

But when i enter
Code:
$ lynx http://www.google.co.in/
Looking up www.google.co.in
Unable to connect to remote host www.google.co.in
Alert!: Unable to connect to remote host
Lynx:Can't access start file http://www.google.co.in/
$
I heard SELinux is causing lots of problem, so i ran dmesg. The result is

Code:
$ dmesg
.....
SELinux:Initialising
SELinux:Sarting in permissive mode
selinux_register_securrity:Registering secondary module
...
SELinux: Registering net filter hooks
...
SELinux: Disable at runtime
SELinux:Unregistering netfiler hooks
...
i checked if audit contains any usefull message (b'cos of message from FC4 Release notes)
Code:
#ls -l /var/log/audit/
total 0
#
I tried disabling seliinux from affeccting dhcp by:
Code:
#setsebool dhcp_disable_trans=1
setsebool:SELinux is disabled
I got this command through google search. I haven't configured my system to use its own dhcp.

How do i connect to the internet.

thank you,

with regards
ashwin
 
Old 07-18-2005, 09:13 AM   #2
cdhgee
Member
 
Registered: Oct 2003
Location: St Paul, MN
Distribution: Fedora 8, Fedora 9
Posts: 513

Rep: Reputation: 30
Can you ping an IP address? For example does this work:

Code:
ping 68.142.226.37
(The IP address is an address of www.yahoo.com which does respond to ping)

If so, then it's probably a DNS problem, in which case you should check to see what servers you have set up in /etc/resolv.conf.
 
Old 07-18-2005, 07:33 PM   #3
willcox
Member
 
Registered: May 2003
Location: Mexico
Distribution: FC 4
Posts: 36

Rep: Reputation: 15
Hi there!
ashwin_cse, do you have one or two ethernet cards in your machine?
 
Old 07-19-2005, 12:49 PM   #4
ashwin_cse
Member
 
Registered: Jul 2004
Distribution: arch, rhel
Posts: 132

Original Poster
Rep: Reputation: 21
Hi,
I am not able to ping 68.142.226.37 . It says destination host unreachable.
This the following of my /etc/resolve.conf
Code:
;genereated by NetworkManager, do not edit!
;use a local caching name server controlled by Network Manager

nameserver 127.0.0.1
Quote:
Hi there!
ashwin_cse, do you have one or two ethernet cards in your machine?
I hav one ethernet card in my machine.

What should i do to connect to the internet?

Thank you,

with regards,
ashwin
 
Old 07-20-2005, 01:27 AM   #5
cdhgee
Member
 
Registered: Oct 2003
Location: St Paul, MN
Distribution: Fedora 8, Fedora 9
Posts: 513

Rep: Reputation: 30
Can you post the results of the commands (run as root):

Code:
ifconfig
Code:
route
 
Old 07-21-2005, 01:34 AM   #6
ashwin_cse
Member
 
Registered: Jul 2004
Distribution: arch, rhel
Posts: 132

Original Poster
Rep: Reputation: 21
HI,
This is the o/p of config
Code:
eth0:Link encap:Ethernet HW addr:00:40:95:89:06:4F
UP BROADCAST NOTRAILER RUNNING
MULTICAST MTU:1500 Metric:1
RX packets:51 error:0 dropped:0 overruns:0 frame:0
TX packets:59 error:0 dropped:0 overruns:0 frame:0
Collision:0 txqueuelen:1000
RX bytes:4700 TX bytes:7621(7.4Kib)
Interrupt:10 Base address:0xd000

lo: (I don't think this would be usefull)

ppp0:Link encap:Point-to-point Protocol
inet addr:59.92.37  p-t-p:59.92.37  Mask:255.255.255.255
UP POINT-TO-POINT RUNNING NOARP MULTICAST MTU:1492
RX packets:31 error:0 Metric:1 dropped:0 overruns:0 frame:0
TX packets:17 error:0 dropped:5 overruns:0 frame:0
Collision:0 txqueuelen:3
RX bytes:2758(2.6KiB) TX bytes:1245(1.2Kib)
o/p of route:
Code:
# route
Kernel IP routing table
Destination  Gateway      Genmask                Flag    Metric    Ref   Use   Iface
59.92.32.1      *         255.255.255.255         UTT      0       0      0      ppp0
169.92.32.1    *           255.255.0.0              U        0      0      0     lo
default           *           0.0.0.0             V        0        0      0     eht0
Any suggestions,


thank you,

with regards,
ashwin
 
Old 07-21-2005, 03:32 AM   #7
cdhgee
Member
 
Registered: Oct 2003
Location: St Paul, MN
Distribution: Fedora 8, Fedora 9
Posts: 513

Rep: Reputation: 30
ifconfig shows that the ppp0 connection is established, so it's not that that's causing the problem. However, route shows that the default gateway of the machine is on the eth0 - so pretty much everything is being sent out through the eth0 interface, which explains why you can't get to anything on the internet.

The solution to this is to tell pppd to use the defaultroute option, and you can do this in three ways:
[list=1][*]Specify defaultroute on the commandline to pppd[*]Add the defaultroute option to /etc/ppp/options[*]Add the defaultroute option to ~/.ppprc[/list=1]

When you've done that, re-establish the ppp connection, run route again and you should see something like this:

Code:
# route
Kernel IP routing table
Destination  Gateway      Genmask                Flag    Metric    Ref   Use   Iface
59.92.32.1      *         255.255.255.255         UTT      0       0      0      ppp0
169.92.32.1    *           255.255.0.0              U        0      0      0     lo
default        59.92.32.1    0.0.0.0             V        0        0      0     ppp0
 
Old 07-21-2005, 06:54 AM   #8
ashwin_cse
Member
 
Registered: Jul 2004
Distribution: arch, rhel
Posts: 132

Original Poster
Rep: Reputation: 21
Hi,
i logged in as root and issued the following commands:
Code:
#pppd defaultroute
#
#route
Kernel IP routing table
Destination  Gateway      Genmask                Flag    Metric    Ref   Use   Iface
59.92.32.1      *         255.255.255.255         UTT      0       0      0      ppp0
169.92.32.1    *           255.255.0.0              U        0      0      0     lo
default           *           0.0.0.0              U        0        0      0     eth0
Then i tried
Code:
#cat /etc/ppp/option
lock
#
should i add defualtroute to this file.

Then there wasn't a file in ~/.ppprc

I think it will be usefull to know that its using pppoe interface.

I am not able to ping 68.142.226.37

Any suggestions,

with regards,
ashwin
 
Old 07-21-2005, 08:04 AM   #9
cdhgee
Member
 
Registered: Oct 2003
Location: St Paul, MN
Distribution: Fedora 8, Fedora 9
Posts: 513

Rep: Reputation: 30
Yeah, add it to /ppp/option and see if that helps.
 
Old 07-30-2007, 09:39 AM   #10
neothephoenix
Member
 
Registered: Oct 2006
Location: India
Distribution: Fedora Core 6, Archlinux Duke
Posts: 52

Rep: Reputation: 15
Hi LQ,
I,ve recently installed FC6 on my Compaq Presario 1720IL, and was facing the same problems as posted above. I twaked all those said config files but to no avail.
Then, i reinstalled the system, and after a few reconfigs and restarts, my pppoe is up and running. Though not very clear as to what had happened then and what went right now.

Can anyone help???
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to connect to internet symb0lism Suse/Novell 8 06-17-2006 06:24 AM
Unable to connect to the Internet Melanieb Linux - Newbie 1 08-15-2005 05:52 PM
Unable to connect to the internet bear2x Linux - Networking 6 07-22-2005 08:42 AM
unable to connect to internet cedar Linux - Networking 2 11-20-2004 03:20 PM
Unable to connect to the internet xxvm1 Mandriva 24 09-22-2004 08:59 PM


All times are GMT -5. The time now is 09:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration