LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 12-04-2010, 09:28 AM   #1
Neyzan
Member
 
Registered: Jul 2010
Location: Thessaloniki, Greece
Distribution: Slackware, Arch, Bodhi.
Posts: 75

Rep: Reputation: 1
Unable to activate nvidia-173xx driver after upgrading to Fedora 14


I was running Fedora 13 on my old computer with a nvidia Geforce FX 5200 graphics card using the nvidia-173xx driver from fusion. After upgrading to Fedora 14 (the first day of its release) the X server wasn't working anymore, the screen just froze up after the progress bar. With Alt+F4 I "moved" to text mode and gave the startx command, but I got the fatal error message that there was no usable configuration detected. I deleted the xorg.conf file and afterwards I was able to start X again. I use the nouveau driver now, but it doesn't nearly work as good as the nvidia-173xx driver. I have it installed, but when I try to activate it (by running nvidia-xconfig as root) the X server doesn't work again after restart, and I have to do the same thing all over again.
Does anyone know how to solve this problem?
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 12-04-2010, 09:54 PM   #2
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Hi,
Quote:
I have it installed, but when I try to activate it (by running nvidia-xconfig as root) the X server doesn't work again after restart,
I wonder, did you re-install the nvidia-173xxx package after the upgrade to fedora14?

To save my self some time I use the vesa driver untill I have the kernel ready for the nvidia module is installed.

Then after I install the nvidia package I edit /etc/X11/xorg.conf.

Changing just the one line, vesa to nvidia.

I also install the nvidia package from cli, type init 3

to shutdown the gui.

does the command glxinfo give you anything?

Code:
glxinfo | grep render
I also have trouble using the nouveau module.

Have you thought of installing the nVidia *.run ?

Regards Glenn
 
1 members found this post helpful.
Old 12-05-2010, 08:26 PM   #3
north49er
Member
 
Registered: Apr 2003
Location: 60.47'N lat
Distribution: fedora 15 x86_64
Posts: 156

Rep: Reputation: 18
Fedora 14 x86_64. I followed the procedure here:
http://www.downloadatoz.com/driver/a...fedora-14.html

Google how to blacklist nouveau and how to go to init 3 to install the driver.
 
1 members found this post helpful.
Old 12-05-2010, 11:37 PM   #4
John VV
Guru
 
Registered: Aug 2005
Posts: 13,481

Rep: Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803Reputation: 1803
why google
how about pointing the OP to the fedorafourm nvidia sticky that "leigh123linux" keeps updated
http://forums.fedoraforum.org/showthread.php?t=204752
 
2 members found this post helpful.
Old 12-07-2010, 08:15 AM   #5
nocountryman
Member
 
Registered: Dec 2009
Location: Bulgaria for now :)
Distribution: Fedora 14
Posts: 60

Rep: Reputation: 3
http://www.if-not-true-then-false.co...ouveau-driver/

This very nice blog..

Found it when was having problems installing ATI drivers onto F13.

Anywho.. check it out has some other very nice articles as well

Cheerio
 
1 members found this post helpful.
Old 12-07-2010, 09:05 PM   #6
falcom
Member
 
Registered: May 2009
Posts: 102

Rep: Reputation: 13
over here i post the manual and work
http://www.ecualug.org/2010/11/05/co...a_en_fedora_14
 
1 members found this post helpful.
Old 12-11-2010, 11:50 AM   #7
Neyzan
Member
 
Registered: Jul 2010
Location: Thessaloniki, Greece
Distribution: Slackware, Arch, Bodhi.
Posts: 75

Original Poster
Rep: Reputation: 1
Thank you all very much. It seems that the only mistake I had made was not to blacklist nouveau. I combined your advice, so I gave the command "sed -i '/root=/s|$| rdblacklist=nouveau|' /boot/grub/grub.conf" as root, checked that the nouveau was blacklisted in the grub configuration file ("cat /boot/grub/grub.conf" -it should read rdblacklist=nouveau nouveau.modeset=0), activated the nvidia driver ("nvidia-xconfig"), exited root and rebooted...
 
  


Reply

Tags
fedora 14, nvidia drivers, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to Activate Ethernet cards in Fedora 10 myasir_genious Linux - Software 2 11-05-2009 12:50 AM
Fedora Core 2 Unable to activate Network device eth0 Wolfy Linux - Networking 21 10-29-2008 12:44 PM
Can't Activate nVidia network driver.(FEDORA) works in VISTA dual boot invisable mouse Linux - Networking 2 03-19-2008 07:13 AM
nvidia driver issues after upgrading kernel darklordzim Slackware 19 12-29-2004 08:24 AM
upgrading NVIDIA driver...troubles! lord_clarence Mandriva 10 10-29-2003 07:45 AM


All times are GMT -5. The time now is 02:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration