LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 02-19-2004, 06:52 PM   #1
xtree
LQ Newbie
 
Registered: Feb 2004
Location: Romania
Distribution: Fedora
Posts: 15

Rep: Reputation: 0
Trouble installing mplayer


Now,

I am a beginner with Linux&Fedora so please bear with me on this.
I am trying to install mplayer (mplayer-1.0-0.5.pre2.20031107.fr.i386.rpm) using rpms and its turning to be rather tricky. I have installed a whole bunch of codecs (a52, alsalib, aalib, faad2, flac, imlib2, lame, ffmpeg, klidv, libdvdcss, libdvdread, libpostproc, lirc, lzo, speex) as well as xvidcore-1.0.0-0.rc2.1.fr.i386.rpm and the mplayer fonts.
After all these when I try to install the mplayer I get an error message saying: "the following package could not be found on your system: libxvidcore.so.2". Ive tried reinstalling xvidcore but it says that I already have it. Any input is appreciated.

Thanks
 
Old 02-19-2004, 07:00 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Look in your /libs and /usr/libs directories for a libxvidcore.so.x file. Sometimes there is a link from a *.so.x file to a *.so.x.x file. If there is something like libxvidcore.so.2.2 present, you need to produce a symbolic link from libxvidcore.so.2 to this file and rerun ldconfig as root. Hope this helps. I'm not at my computer and can't check what version I'm using.
 
Old 02-19-2004, 07:05 PM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
you would do so so so much better by just compiling it from source, none of this dependency junk then....
 
Old 02-19-2004, 07:11 PM   #4
xtree
LQ Newbie
 
Registered: Feb 2004
Location: Romania
Distribution: Fedora
Posts: 15

Original Poster
Rep: Reputation: 0
I ve searched my whole system for 'libxvidcore' and indeed it didnt find any files. (so it looks like mplayer is right in not finding it
 
Old 02-19-2004, 07:22 PM   #5
xtree
LQ Newbie
 
Registered: Feb 2004
Location: Romania
Distribution: Fedora
Posts: 15

Original Poster
Rep: Reputation: 0
I think you re most probably right acid, however this being my second day with linux Im not too confident I can do it right. I'll give that a try though, not much to lose anyway .
 
Old 02-20-2004, 07:38 PM   #6
xtree
LQ Newbie
 
Registered: Feb 2004
Location: Romania
Distribution: Fedora
Posts: 15

Original Poster
Rep: Reputation: 0
Fixed it

Thought i'd post this here maybe it helps somebody else too. I have tried both the install from source...which failed because it said that I do not have the right gcc package installed (I have 2.96, and apparently they do not support it). In the end I've installed apt and with a simple command ('apt-get install mplayer') it dowloaded the missing libraries (which I could swear to have already installed myself) as well as mplayer 0.90 and that was it.
Oh...and you start it with run command: gmplayer.
 
Old 02-21-2004, 05:14 AM   #7
jon-do
Member
 
Registered: Feb 2004
Distribution: Red 9, FC 2 Test 3
Posts: 98

Rep: Reputation: 16
Welcome to the debian packager, now go ahead and grap the gui interface for apt

Synaptic
 
Old 02-25-2004, 06:14 AM   #8
buzzbiker
Member
 
Registered: Jul 2002
Location: Oregon
Distribution: Fedora Core 7 - vista
Posts: 38

Rep: Reputation: 15
I just don't get it. I have apt and mine says that cannot find mplayer and it can't find xine. went to synaptic can't find it there, ypdated packages and still not there?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble installing mplayer,loads then noting robgue Fedora 3 04-03-2004 03:46 PM
trouble installing mplayer pasalacqua128 Linux - Software 3 03-22-2004 12:03 AM
Trouble installing MPlayer 1.0pre2 snatale1 Linux - Software 2 11-30-2003 05:26 PM
trouble ahead, trouble behind....trouble with mplayer Goonie Linux - Software 3 07-02-2003 03:29 AM
trouble installing mplayer adam_boz Linux - Software 1 07-22-2002 05:27 AM


All times are GMT -5. The time now is 07:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration