LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 02-08-2007, 05:37 PM   #1
fr3@k0
LQ Newbie
 
Registered: Feb 2007
Distribution: Fedora Core 6
Posts: 8

Rep: Reputation: 0
talk not working


hello all,

I am new to linux and this is the first time i am using talk, and i am getting the following error:

[Error on read from talk daemon: Connection refused. Press any key...]

And when i press any key the following msg pops up:

[Checking for invitation on caller's machine]

I have gone thru all of the threads in here but still i get the same error. My talk and ntalk files in /etc/xinetd/ looks like following:

service talk
{
flags = IPv4
disable = no
socket_type = dgram
wait = yes
user =
group = tty
server = /usr/sbin/in.talkd
}

service ntalk
{
flags = IPv4
disable = no
socket_type = dgram
wait = yes
user =
group = tty
server = /usr/sbin/in.ntalkd
}

After making these changes i did restart xinetd:

/etc/init.d/xinetd restart
Stopping xinetd: [ OK ]
Starting xinetd: [ OK ]

And my xinetd.conf in /etc/ looks like this:

Earlier:

defaults
{
# The next two items are intended to be a quick access place to
# temporarily enable or disable services.
#
# enabled =
# disabled =

Now:

defaults
{
# The next two items are intended to be a quick access place to
# temporarily enable or disable services.
#
enabled = yes
disabled = no

Please let me know if i am missing smthing
 
Old 02-08-2007, 05:41 PM   #2
wjevans_7d1@yahoo.co
Member
 
Registered: Jun 2006
Location: Mariposa
Distribution: Slackware 9.1
Posts: 938

Rep: Reputation: 30
When you do this:

Code:
grep talk /etc/inetd.conf
what output do you get?
 
Old 02-08-2007, 06:09 PM   #3
fr3@k0
LQ Newbie
 
Registered: Feb 2007
Distribution: Fedora Core 6
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by wjevans_7d1@yahoo.co
When you do this:

Code:
grep talk /etc/inetd.conf
what output do you get?
grep talk /etc/inetd.conf
grep: /etc/inetd.conf: No such file or directory

So i thought i will install it and got loads of errors, which are following:

rpm -ivf /root/Desktop/inetd-0.17-9.i386.rpm
error: Failed dependencies:
rc-scripts is needed by inetd-0.17-9.i386
rc-inetd >= 0.8.1 is needed by inetd-0.17-9.i386
/etc/rc.d/init.d/rc-inetd is needed by inetd-0.17-9.i386

and while installing rc-scripts:

rpm -ivf /root/Desktop/rc-scripts-0.4.0-2.i386.rpm
error: Failed dependencies:
iproute2 is needed by rc-scripts-0.4.0-2.i386
initscripts <= 5.30-1 conflicts with chkconfig-1.3.30-1.i386
initscripts < 7.23 conflicts with kernel-2.6.18-1.2798.fc6.i686
initscripts < 7.84 conflicts with udev-095-17.fc6.i386
initscripts < 8.40-1 conflicts with kudzu-1.2.57.6-1.i386
initscripts < 7.23 conflicts with kernel-2.6.19-1.2895.fc6.i686
initscripts < 6.55 conflicts with psacct-6.3.2-42.fc6.i386
initscripts < 4.26 conflicts with setup-2.6.1.1-1.fc6.noarch

Please advice !!!

Last edited by fr3@k0; 02-08-2007 at 06:57 PM.
 
Old 02-08-2007, 07:25 PM   #4
wjevans_7d1@yahoo.co
Member
 
Registered: Jun 2006
Location: Mariposa
Distribution: Slackware 9.1
Posts: 938

Rep: Reputation: 30
My mistake, sorry.

/etc/inetd.conf is the standard place to put that file; apparently Fedora and siblings place it at /etc/xinetd.conf.

In your original post, did you list your entire /etc/xinetd.conf, or just a part of it?

Try this:

Code:
grep talk /etc/xinetd.conf
If you find a "talk" line in there which has been commented out by putting a # at the beginning of the line, remove that #. Reboot and see if that fixes things.

If you do not find a "talk" line in /etc/xinetd.conf, maybe you can post your whole /etc/xinetd.conf here.
 
Old 02-09-2007, 12:31 PM   #5
fr3@k0
LQ Newbie
 
Registered: Feb 2007
Distribution: Fedora Core 6
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by wjevans_7d1@yahoo.co
My mistake, sorry.

/etc/inetd.conf is the standard place to put that file; apparently Fedora and siblings place it at /etc/xinetd.conf.

In your original post, did you list your entire /etc/xinetd.conf, or just a part of it?

Try this:

Code:
grep talk /etc/xinetd.conf
If you find a "talk" line in there which has been commented out by putting a # at the beginning of the line, remove that #. Reboot and see if that fixes things.

If you do not find a "talk" line in /etc/xinetd.conf, maybe you can post your whole /etc/xinetd.conf here.
I do not have talk line in /etc/xinetd.conf, and here is the complete /etc/xinetd.conf:

#
# This is the master xinetd configuration file. Settings in the
# default section will be inherited by all service configurations
# unless explicitly overridden in the service configuration. See
# xinetd.conf in the man pages for a more detailed explanation of
# these attributes.

defaults
{
# The next two items are intended to be a quick access place to
# temporarily enable or disable services.
#
enabled = yes
disabled = no

# Define general logging characteristics.
log_type = SYSLOG daemon info
log_on_failure = HOST
log_on_success = PID HOST DURATION EXIT

# Define access restriction defaults
#
# no_access =
# only_from =
# max_load = 0
cps = 50 10
instances = 50
per_source = 10

# Address and networking defaults
#
# bind =
# mdns = yes
v6only = no

# setup environmental attributes
#
# passenv =
groups = yes
umask = 002

# Generally, banners are not used. This sets up their global defaults
#
# banner =
# banner_fail =
# banner_success =
}

includedir /etc/xinetd.d
 
Old 02-09-2007, 02:20 PM   #6
wjevans_7d1@yahoo.co
Member
 
Registered: Jun 2006
Location: Mariposa
Distribution: Slackware 9.1
Posts: 938

Rep: Reputation: 30
Now I know why they have xinetd.conf instead of inetd.conf: the file is of entirely different format. Since it's a fedora/red hat thing, I don't know much about it. And since it's been almost a day since this thread has been up and no fedora/red hat person has come forward to help, try asking the question again on the Fedora forum:

http://www.linuxquestions.org/questi...splay.php?f=35

When you do, you should stress near the beginning of your question that you asked it on the "Linux - General" forum and didn't get much luck there. That way, when a moderator reads the question, he won't take action on a question which seems (to him) to be cross-posted.

If that doesn't work, try:

http://www.fedoraforum.org/

I found that on google. I have no idea how useful it is, but try there. If that doesn't work, google for:

Code:
fedora help
and follow some of the other links.

Sorry I couldn't be of more help.

Last edited by wjevans_7d1@yahoo.co; 02-09-2007 at 02:25 PM.
 
Old 02-09-2007, 05:30 PM   #7
fr3@k0
LQ Newbie
 
Registered: Feb 2007
Distribution: Fedora Core 6
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by wjevans_7d1@yahoo.co
Now I know why they have xinetd.conf instead of inetd.conf: the file is of entirely different format. Since it's a fedora/red hat thing, I don't know much about it. And since it's been almost a day since this thread has been up and no fedora/red hat person has come forward to help, try asking the question again on the Fedora forum:

http://www.linuxquestions.org/questi...splay.php?f=35

When you do, you should stress near the beginning of your question that you asked it on the "Linux - General" forum and didn't get much luck there. That way, when a moderator reads the question, he won't take action on a question which seems (to him) to be cross-posted.

If that doesn't work, try:

http://www.fedoraforum.org/

I found that on google. I have no idea how useful it is, but try there. If that doesn't work, google for:

Code:
fedora help
and follow some of the other links.

Sorry I couldn't be of more help.
Hey, thankz though for pointing me the rite direction... appreciated...
 
Old 02-10-2007, 05:33 AM   #8
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,765
Blog Entries: 54

Rep: Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976Reputation: 2976
Now I know why they have xinetd.conf instead of inetd.conf: the file is of entirely different format.
Xinetd allows for more fine-grained control and has more features, see for instance Xinetd vs inetd.



rpm -ivf /root/Desktop/inetd-0.17-9.i386.rpm
You shouldn't just do that unless you know what you're doing: better use Yum or equivalent. *If* you're forced to install RPM's with rpm at least first test them with "rpm --test -i thisapplication.rpm" to see if there are conflicts.


In RHEL/FC/CentOS the daemon side RPM is called "talk-server" (as in "yum search talk-server").
 
Old 02-10-2007, 07:10 AM   #9
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
As requested, moved to Fedora
 
Old 02-10-2007, 11:30 AM   #10
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 18, 19, RHL 5.2
Posts: 546

Rep: Reputation: 43
Don't install inetd, xinetd is an extended version of inetd. They have the same purpose which is to launch services on demand rather than have the daemon running all the time.

It has been a while since I've used talk, brings back some memories of the good old days. Somewhere along the line they split talk into two packages. You need to have talk and talk-server installed. talk comes installed, but to make it work you need both parts.

yum install talk-server will install the following files.
Code:
/etc/xinetd.d/ntalk
/etc/xinetd.d/talk
/usr/sbin/in.ntalkd
/usr/sbin/in.talkd
/usr/share/man/man8/in.ntalkd.8.gz
/usr/share/man/man8/in.talkd.8.gz
/usr/share/man/man8/ntalkd.8.gz
/usr/share/man/man8/talkd.8.gz
Notice the xinetd configuration files for ntalk and talk. You should remove the ones you made. If you install with your files present it will create talk.rpmnew and ntalk.rpmnew. Replace talk and ntalk with these files. More importantly the installation adds the talk daemon which is the heart of your problem.

Once installed you will need to enable the talk and ntalk entries in xinetd.d. Use chkconfig talk on and chkconfig ntalk on from the command line or use the gui by following the menu path System -> Administration -> Server Settings -> Services. Once there go to the On Demand Services tab and turn them on.

If you will be getting talk requests from other hosts you will need to open ports 517-518 on your firewall.

Bill

Last edited by wmakowski; 02-10-2007 at 11:34 AM.
 
Old 02-15-2007, 01:06 PM   #11
fr3@k0
LQ Newbie
 
Registered: Feb 2007
Distribution: Fedora Core 6
Posts: 8

Original Poster
Rep: Reputation: 0
i tried "yum install talk-server" but nothing got installed, I got the following result:

yum install talk-server
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Nothing to do

Any suggestions?
 
Old 02-15-2007, 02:46 PM   #12
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 18, 19, RHL 5.2
Posts: 546

Rep: Reputation: 43
Chances are good it is already installed. Try rpm -qi talk-server at the command line. It will give you information on the package if it is installed or tell you it is not installed. If it is installed keep following the steps I outlined above.

Bill
 
Old 02-15-2007, 03:28 PM   #13
fr3@k0
LQ Newbie
 
Registered: Feb 2007
Distribution: Fedora Core 6
Posts: 8

Original Poster
Rep: Reputation: 0
the talk-server is installed. And all the files are in there correct places. Even the talk and ntalk service is also enabled in xinetd.d but still i can't get it working.

I guess m missing something but m not sure wut. Please advice.
 
Old 02-15-2007, 11:11 PM   #14
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 18, 19, RHL 5.2
Posts: 546

Rep: Reputation: 43
Is it still giving the same messages or does something different happen when you try using talk? If you are going between two different hosts ports 517-518 must be open on your firewall. Is xinetd running? You can check it using the command service xinetd status. If you are trying to talk with root you must have mesg = y. See man mesg for details.

Bill

Last edited by wmakowski; 02-16-2007 at 12:10 AM.
 
Old 02-16-2007, 12:01 PM   #15
fr3@k0
LQ Newbie
 
Registered: Feb 2007
Distribution: Fedora Core 6
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by wmakowski
Is it still giving the same messages or does something different happen when you try using talk? If you are going between two different hosts ports 517-518 must be open on your firewall. Is xinetd running? You can check it using the command service xinetd status. If you are trying to talk with root you must have mesg = y. See man mesg for details.

Bill
Yes, it is still giving the same error. Ports 517-518 are open. xinetd is running:

/sbin/service xinetd status
xinetd (pid 2233) is running...

mesg equals 'y'.

Please advice and thanks for all your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Google Talk Im is now working craigevil General 4 08-23-2005 11:56 PM
talk talk daemon configuration ananthkrk Red Hat 1 10-16-2004 12:45 PM
Mandrake 6.5, Modem Working but linux wont talk to it SilverRock Mandriva 1 08-30-2004 09:38 PM
talk command not working Longinus Linux - Newbie 6 07-12-2004 05:28 PM
why cannot "talk" to others,since mesg is yes and disable = no(in /etc/xinetd.c/talk) whepin Linux - Newbie 0 12-31-2001 03:04 AM


All times are GMT -5. The time now is 03:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration