LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 06-14-2005, 11:35 AM   #1
hkl8324
Member
 
Registered: Aug 2003
Location: Hong Kong, China
Distribution: Ubuntu 10.04
Posts: 234

Rep: Reputation: 30
Synaptic problem....


i installed synaptic on FC4
(i grabed synaptic here, http://download.fedora.redhat.com/pu...extras/4/i386/)

but when i fire synaptic....

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


(synaptic:1081): Gtk-WARNING **: cannot open display:

what is wrong?
 
Old 06-14-2005, 11:47 AM   #2
solusrex
Member
 
Registered: May 2005
Posts: 35

Rep: Reputation: 15
have you tried typing 'xhost + computer_name' (as normal user I think) in a console
 
Old 06-14-2005, 04:28 PM   #3
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
If you start synaptic from the Desktop -> System menu, it will ask you for roots password and doesn't produce the error that you are experiencing when starting it from a terminal emulator.
 
Old 06-15-2005, 04:09 AM   #4
hkl8324
Member
 
Registered: Aug 2003
Location: Hong Kong, China
Distribution: Ubuntu 10.04
Posts: 234

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by reddazz
If you start synaptic from the Desktop -> System menu, it will ask you for roots password and doesn't produce the error that you are experiencing when starting it from a terminal emulator.
i have no entry in there.....

how to add that?

Edit: i encounter the same error whenever i lauch a GUI apps from terminal emulator........how to solve it.....?

thanks again..
 
Old 06-15-2005, 04:55 AM   #5
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
Desktop -> System Settings -> More System Settings -> Synaptic. If you launch GUI apps from the terminal as root or any other user who did not start the xsession, you will keep getting that error because most dstros do not allow a user who did not start the xsession to run gui apps for security reasons. You can use the "xhost +" command as mentioned above, to work around this.
 
Old 06-15-2005, 04:57 AM   #6
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 46
you could try typing in the terminal:

sudo synaptic

OR

kdesu synaptic

NOTE : you have to have your user in the /etc/sudoers file of course
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Synaptic Sendmail problem h4z Yoper 0 11-28-2004 05:20 AM
synaptic problem geekrockstud Debian 1 09-11-2004 07:20 PM
Synaptic problem The_Real_BooDa Linux - Newbie 6 07-16-2004 01:49 PM
problem with synaptic Zerodark Conectiva 1 07-07-2003 02:48 PM
Synaptic problem element Linux - Software 9 01-30-2003 06:45 PM


All times are GMT -5. The time now is 12:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration