LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 08-01-2012, 06:53 AM   #1
sims2801
LQ Newbie
 
Registered: Aug 2012
Posts: 12

Rep: Reputation: Disabled
sumo installation on fedora 16


dear all

i want sumo 0.12.3 to be intstalled on fedora16.
there is no binary file available on repository for sumo 01.12.3 .
therefore i am trying to make it.
for that purpose i downloaded the follwoing packages

fox-1.6.36.tar.gz
gdal-1.5.1.tar.gz
proj-4.6.0.tar.gz
xerces-c-current.tar.gz

but when i tried to install the first one i.e. fox-1.6.36.tar.gz by
using the follwing commands

tar xzf fox-1.6.36.tar.gz
cd fox-1.6.36
./configure --with-opengl=yes --prefix=$HOME && make install

i get the following errors
......................
-W -Woverloaded-virtual -Wformat -DHAVE_GLU_H=1 -DHAVE_GL_H=1 -o
.libs/ControlPanel ControlPanel.o ../src/.libs/libFOX-1.6.so -ldl
-lpthread -lrt -ljpeg -lpng -ltiff -lz -lbz2 -lm -lGLU -lGL
/usr/bin/ld: ControlPanel.o: undefined reference to symbol 'XGetDefault'
/usr/bin/ld: note: 'XGetDefault' is defined in DSO
/usr/lib/libX11.so.6 so try adding it to the linker command line
/usr/lib/libX11.so.6: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[1]: *** [ControlPanel] Error 1
make[1]: Leaving directory `/home/kavita/fox-1.6.36/tests'
make: *** [install-recursive] Error 1
........................

please tell me how i correct this error.
As well as what specific packages ( version) has to be used to install
sumo 0.12.3

kindly tell me

regards
sims
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] why sumo 0.9.8 does not installed in fedora 15? nadia_kh Linux - Newbie 17 06-04-2012 03:59 AM
Sumo installation in Ubuntu yashu Linux - Networking 4 04-04-2012 03:53 AM
SUMO Installation in Fedora 15 mrnikunjdoshi Linux - Software 13 11-16-2011 02:35 AM
SUMO installation for TraNS on Fedora 12 Pranav Singh Linux - Newbie 3 11-01-2010 11:19 AM


All times are GMT -5. The time now is 11:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration