LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   sudoer can not install applications from desktop (http://www.linuxquestions.org/questions/fedora-35/sudoer-can-not-install-applications-from-desktop-4175466831/)

guyver000 06-21-2013 01:03 AM

sudoer can not install applications from desktop
 
Sorry if this is the wrong forum but, I have a new install of fedora 18
user 1 installed the os and set up users root, and then user 1 as a super user. Then added user 2 and added user 2 to the sudoers list.

When user 2 logs in they can run anything from terminal using sudo but if they try anything from the gui that takes super user permissions, it asks for user 1 credentials not user 2 or root.

John VV 06-21-2013 01:16 AM

the gnome3 desktop on fedora is mostly decoration
you are not supposed to install software from it

use the already created "bin" folder in your home folder
or even "Downloads"

Also how did you set up " sudo" fedora dose not use it by default
Fedora uses " su " and " su -"

Quote:

user 1 installed the os and set up users root, and then user 1 as a super user. Then added user 2 and added user 2 to the sudoers list.
????
What ?
you have TWO root users ?

that is not good
your FIRST normal user is not supposed to have root authority
that will royally mess up SELinux

You might want to read the fedora documentation
http://docs.fedoraproject.org/en-US/...ide/index.html
and see the links on the left window

running the GUI as root is mostly disabled in fedora AND in Gnome
fedora will not even let you log in to gnome as root .

guyver000 06-21-2013 01:30 AM

Thank you for the quick response

I did not install this instance of fedora, I am user 2. I have the root password and my credentials. I am logging in as user 2. I could fix the issue by resetting user1 credentials but I would rather find out why the gui is asking for user1 credentials at all.

as for adding the user to sudo this is the sudoers file in /etc/sudoers

root ALL=(ALL) ALL
user1 ALL=(ALL) ALL
user2 ALL=(ALL) NOPASSWD:ALL

As far as I know there is 1 root user and 2 additional superusers.

John VV 06-21-2013 02:27 AM

the pop up should NOT be asking for "user1"
it should be asking for the root password
"user1" should not be in the root group

that will cause all kinds of problems

guyver000 06-21-2013 03:13 AM

Hi John
Again thanks for the quick response.
I resolved the issue

user1 was in the wheel group

I tried removing the user, adding user2, removing all users and adding root to the wheele group none of this allowed me to use the root password

I added user3, made it the only user in the wheel group and now the gui asks for user 3.

I still have not found a way to just have it ask for the root password.

guyver000 06-21-2013 03:44 AM

Now the issue is resolved. It appears I had the root password wrong

removed all users from wheel group
reset root password
now gui prompts for administrator credentials, which is root and works as expected.


All times are GMT -5. The time now is 09:58 PM.