LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 04-14-2005, 12:11 PM   #1
Graham_UK
LQ Newbie
 
Registered: Apr 2005
Posts: 5

Rep: Reputation: 0
Stopping X server from starting up


Hello,

Can anyone help me please?
How can I stop an X server from loading up so i can install an Nvidia graphics driver and then how do i ge tthe X server to run again.

Also what is the command to edit text files, like in Windows its EDIT, what is the Linux name.

Im running FC4 test 2

Thanks in advance
Graham
 
Old 04-14-2005, 12:56 PM   #2
azucaro
Member
 
Registered: Jan 2005
Location: Washington, D.C.
Distribution: Arch (Custom), CentOS
Posts: 239

Rep: Reputation: 30
You will need to edit your inittab file: /etc/inittab.

What you have to do is open up the file and change the line that looks like init:5:default. Comment out that line by placing a # at the beginning of it, or just change the 5 to a 3. This tells your computer to boot to a command prompt. Do your nVidia stuff (you may need to query this forum for help on that too...plenty of info), and then change your /etc/inittab file back so that it says '5' again. Reboot and you'll be back up with X. You'll know if all went well - you'll see the nVidia logo show up on the screen shortly before X starts up (or just after? I can't remember).

Hope that helps.
 
Old 04-14-2005, 09:02 PM   #3
mjmwired
Member
 
Registered: Apr 2004
Distribution: CentOS6, CentOS5, F16, F15, Ubuntu, OpenSuse
Posts: 620

Rep: Reputation: 39
You don't need to edit /etc/inittab, if you all you want to do is install the Nvidia drivers. Simply hit <ctrl><alt><f2> (or f3, f4) and login as root and run 'init 3'.
Once all the messages stop, just hit enter and do whatever you need to in the console mode. Install the driver, etc.

Once done run 'init 5'. No reboots are needed.

There are different editors depending what you are doing. If you are using console you can try 'nano', 'vim' or 'emacs'. If you are in gui there are many more. Try 'gedit', 'kate', 'nedit', or any text editor you see in the menu. All should work.
 
Old 04-17-2005, 08:14 AM   #4
Graham_UK
LQ Newbie
 
Registered: Apr 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks

Thanks very much for your help!
 
Old 04-19-2005, 02:39 PM   #5
snarkout
Member
 
Registered: Apr 2005
Location: The Land Of Entrapment
Posts: 77

Rep: Reputation: 15
FWIW, you can also just add a 3 to the end of your grub options when booting.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
stopping and starting net Tinku Linux - Networking 1 08-04-2004 08:58 AM
stopping xserver from starting up? Zaskar Debian 17 03-20-2004 06:59 PM
Stopping X from starting KennyK Linux - Software 4 06-03-2003 08:12 PM
stopping and starting services nero64 Linux - Newbie 3 11-13-2002 01:10 AM
Starting/stopping httpd bughunter Linux - Newbie 3 10-20-2001 10:02 AM


All times are GMT -5. The time now is 11:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration