LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 03-20-2009, 10:46 PM   #1
ddc441
LQ Newbie
 
Registered: Aug 2008
Posts: 24

Rep: Reputation: 0
Stop syslogd from sending messages to root terminal


I don't know how I did it, but somehow I configured syslogd to send any log events to the open root terminal, and I can't seem to turn it off. I assumed it was in the syslogd config file, but I'm not having much luck.

Any suggestions?

Fedora 10 x64

Thanks!

Last edited by ddc441; 03-20-2009 at 10:47 PM. Reason: add fedora version
 
Old 03-21-2009, 03:43 AM   #2
asymptote
Member
 
Registered: Mar 2008
Posts: 236

Rep: Reputation: 37
Did you try closing the root terminal and opening a new one?
 
Old 03-21-2009, 05:16 AM   #3
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,273
Blog Entries: 54

Rep: Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852
See 'man dmesg' (-n level)?
 
Old 03-21-2009, 10:39 AM   #4
ddc441
LQ Newbie
 
Registered: Aug 2008
Posts: 24

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by asymptote View Post
Did you try closing the root terminal and opening a new one?
Yes... it's persistent. It does it even after reboots.

Last edited by ddc441; 03-21-2009 at 11:08 AM. Reason: spelling
 
Old 03-21-2009, 11:08 AM   #5
ddc441
LQ Newbie
 
Registered: Aug 2008
Posts: 24

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by unSpawn View Post
See 'man dmesg' (-n level)?
Thanks for the info! As I understand it, all I have to do is get to a command prompt as root and enter:

dmesg -n 1

Is that correct? Does that change it permanently, or just for the current session?

Thanks again!
 
Old 03-21-2009, 11:20 AM   #6
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,273
Blog Entries: 54

Rep: Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852Reputation: 2852
Just the current session. Add it to the .bash_profile to make it permanent.
 
Old 03-21-2009, 03:02 PM   #7
asymptote
Member
 
Registered: Mar 2008
Posts: 236

Rep: Reputation: 37
What was the series of events that lead to this happening - do you remember?
 
Old 03-22-2009, 02:04 PM   #8
ddc441
LQ Newbie
 
Registered: Aug 2008
Posts: 24

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by asymptote View Post
What was the series of events that lead to this happening - do you remember?
Yes. I was trying to install Alfresco but was running into problems. I couldn't find a log being updated, so I tried to make some changes to syslogd, sshd, etc. using Webmin. I'm sure one of Webmin's scripts overwrote a config file somewhere activating this feature, but I can't find it.

The suggestion above about man dmesg -n 1 doesn't seem to affect it.
 
Old 03-26-2009, 05:15 PM   #9
ddc441
LQ Newbie
 
Registered: Aug 2008
Posts: 24

Original Poster
Rep: Reputation: 0
Well, I couldn't find the problem, but I found a solution. I installed syslog-ng and disabled rsyslog. It may not be pretty, but it worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stop sending error messages matt1982 Debian 4 08-28-2007 07:20 AM
Sending messages tired Linux - Newbie 2 08-11-2004 02:37 AM
Sending messages over SSH jeucken Linux - Networking 1 12-15-2003 01:54 PM
Sending messages across a network... kierl Linux - General 3 04-07-2003 01:11 PM
logging external messages with syslogd slawomir Linux - Networking 3 09-04-2002 04:26 AM


All times are GMT -5. The time now is 05:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration