LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-30-2008, 09:03 PM   #1
LloydM
LQ Newbie
 
Registered: May 2005
Posts: 29

Rep: Reputation: 15
stop automount of XP partition in Fedora 9/GNOME


How do I stop Fedora 9 from automounting my dual-boot system's Windows XP partition? The partition doesn't seem to be in /etc/fstab or in GNOME's Applications > System Tools > Disk Management.

-Thanks, LloydM
 
Old 12-01-2008, 12:35 AM   #2
htnakirs
Member
 
Registered: Mar 2007
Posts: 239

Rep: Reputation: 34
Can you confirm that the partition is automounted? Did you try the mount command to check this? In my experience, internal drives that are not in fstab are not automounted.

You can setup fstab to prevent automounting, google for "disable fstab automount" to find out how.
 
Old 12-01-2008, 01:40 AM   #3
John VV
Guru
 
Registered: Aug 2005
Posts: 12,894

Rep: Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713
in fedora 9 partitions and drives are auto mounted
In my exp. most of the time when this question is asked it really means " HOW do i get ride of that annoying icon on my gnome desktop"
is this what you mean ?
-- or --
do you want to ( by hand) type
Code:
su -
root password
mkdir /mnt/windows
mount -t ntfs-3g /dev/sda1 /mnt/windows
every time you want to access that drive
-----
if it is the icon
then add the windows drive to fstab
Code:
/dev/sda1    /mnt/windows     ntfs-3g   defaults       0 0
and reboot
installing "autofs" may also be required.
------------ and/or --------
install " gconf-editor"
yum install gconf-editor
and uncheck
apps/nautilus/desktop/"volumes_visible"

---------------
or add " noauto " to the fstab to stpo auto mount
see
Code:
man fstab
 
Old 12-01-2008, 11:52 AM   #4
LloydM
LQ Newbie
 
Registered: May 2005
Posts: 29

Original Poster
Rep: Reputation: 15
make WinXP parition completely inaccessible, everything else "automounts"

I want the WinXP partition to be completely invisible and inaccessible from Linux, while leaving everything else as-is:

- vfat shared partition automounted as /vfat (no desktop icon)
- external USB device icon on desktop when connected
- CD/DVD icon on desktop when disk inserted

BTW what is the correect term for "mounting" a drive without putting it in /etc/fstab or making it a mount point?

-Thanks, LloydM
 
Old 12-01-2008, 03:46 PM   #5
John VV
Guru
 
Registered: Aug 2005
Posts: 12,894

Rep: Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713
well use the noauto in fstab ,or shut down autofs or hal and be forced to mount by hand any usb device .
or you could uninstall ntfs-3g
 
Old 12-01-2008, 04:02 PM   #6
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 171Reputation: 171
Assuming you want to block it from everyone except root, you could mount the FS to a mount point(in fstab) that only root has read permissions on. That would prevent all users (excluding root) from having access to the FS.

Edit: Just as a general rule in Linux: if something is being particularly hard to prevent, take a step back. Usually it is easier to control HOW something is being done, than to prevent it from being done.

Last edited by lazlow; 12-01-2008 at 04:18 PM.
 
Old 12-12-2008, 02:08 PM   #7
Tylerious
Member
 
Registered: Feb 2005
Location: USA
Distribution: Gentoo
Posts: 72

Rep: Reputation: 15
I'm having the same problem. I have several partitions (Windows, Shared NTFS, Ubuntu, Fedora 10).

The Windows and Ubuntu should not auto-mount. They should mount and show up on the desktop when I choose to mount them.

The Shared partition I have successfully set up to auto-mount without showing up on the desktop by adding it to /etc/fstab.

How do I get the other partitions to stop mounting at boot, though? This just works in Ubuntu.
 
Old 12-12-2008, 02:26 PM   #8
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 171Reputation: 171
Same advice as in #6.
 
Old 05-10-2009, 07:08 AM   #9
rickhg12hs
LQ Newbie
 
Registered: Apr 2008
Distribution: RHEL, Fedora, Ubuntu
Posts: 13

Rep: Reputation: 1
Controlling gnome

Okay, now the automounting that gnome does (launches? instigates?) is bugging me too. I'm using Fedora 9 and nothing was automounted until after I used gnome-volume-properties (I'm pretty sure). Other accounts that login with gnome do _not_ automount these partitions ... what changed and how can I change it back?

What _gnome_ config item needs to be set/changed so that partitions on a fixed hard drive are _not_ automounted? [Yes, I'll mount them manually if I need them.]

There must be a gnome control (or should be) since these other partitions are not mounted at boot and are not mounted when logging in with other window managers. [And no, I do not want to modify fstab. Gnome should be controllable, yes?]

Thanks for your consideration.
 
Old 06-10-2009, 07:10 PM   #10
rickhg12hs
LQ Newbie
 
Registered: Apr 2008
Distribution: RHEL, Fedora, Ubuntu
Posts: 13

Rep: Reputation: 1
Fedora 9/gnome solution

Quote:
Originally Posted by rickhg12hs View Post
What _gnome_ config item needs to be set/changed so that partitions on a fixed hard drive are _not_ automounted? [Yes, I'll mount them manually if I need them.]

There must be a gnome control (or should be) since these other partitions are not mounted at boot and are not mounted when logging in with other window managers. [And no, I do not want to modify fstab. Gnome should be controllable, yes?]
Okay, if you just want to prevent gnome from mounting specific partitions, you can issue commands like this (as a normal user).

$ gnome-mount --write-settings --mount-options noauto --device /dev/sda1
$ gnome-mount --write-settings --mount-options noauto --device /dev/sda3

[These are the original NTFS partitions that came with my laptop.]

The above commands will write some files under ~/.gconf that will essentially block HAL from automounting the partitions.
 
  


Reply

Tags
automount, fedora, gnome, gnomemount, solution


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gnome automount not working BCarey Linux - Desktop 4 05-25-2007 03:49 PM
How to stop automount coldsalmon Linux - Hardware 3 05-04-2006 11:28 PM
Automount CD's in gnome? PeaceTank Linux - Software 1 03-10-2005 05:58 AM
automount cd and usb memory in gnome 2.8 testing sarge with gnome-volume-manager gvm pevelius Debian 0 12-20-2004 02:15 AM
automount partition has problem timsch75 Linux - General 3 12-15-2004 05:06 PM


All times are GMT -5. The time now is 11:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration