LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 10-29-2007, 07:36 AM   #1
martinr
Member
 
Registered: Mar 2006
Location: Stockholm, Sweden
Distribution: FC10 x86_64, RHEL4/5 x86_64
Posts: 87

Rep: Reputation: 15
Question Startup screen not showing. booting into runlevel 3


Hello everyone,

I recently installed fedora 7 and most things are working perfectly. One unresolved issue though.

Since anaconda can't properly detect my monitor I did the installation in text mode. After installation is complete and I update the graphics drivers (NVIDIA) with yum I can access graphics (runlevel 5). The thing is that everytime the computer boots it does so from an ugly text cosole, and when it finishes you end up with a text based runlevel 3 login. After logging in as root and typing "init 5" you see the nvidia logo and the proper login screen shows up.

So you have to log in twice. Once as root, then as yourself, and it takes a lot of time.

What to do? Just writing "init 5" in grub doesn't work.

thankful for any help,
 
Old 10-29-2007, 08:54 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
As root using your choice of text editor, change one line in the /etc/inittab file to; id:5:initdefault:

FYI: add a space followed by the number 5 instead of using init 5 next time.
 
Old 10-29-2007, 08:57 AM   #3
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,990

Rep: Reputation: 67
The initial runlevel isn't normally set by grub, but in a configuration file called /etc/inittab.

Open this file in a text editor (I use emacs):
Code:
sudo emacs /etc/inittab
There should be a line in the file that reads:
Code:
id:3:initdefault:
Change this to read:
Code:
id:5:initdefault:
and save /etc/inittab (in emacs, press ctrl+x then press ctrl+s, then to exit ctrl+x then ctrl+c).

Once done, you should be able to reboot into runlevel 5.

It is possible to set the runlevel in the grub command-line; edit the boot command that you are interested in and add 5 to the end of the command-line. But that will not normally get saved between reboots.
 
Old 10-29-2007, 09:27 AM   #4
ArcLinux
Member
 
Registered: Apr 2005
Location: Fargo, ND
Distribution: Slackware, CentOS
Posts: 87

Rep: Reputation: 20
what they said...
 
Old 10-29-2007, 04:47 PM   #5
martinr
Member
 
Registered: Mar 2006
Location: Stockholm, Sweden
Distribution: FC10 x86_64, RHEL4/5 x86_64
Posts: 87

Original Poster
Rep: Reputation: 15
I can not edit monitor specs

Due to the fact that my monitor is not correctly found it only works if I first go to runlevel 3, then start 5 as previously described...for some reason

In previous versions of fedora and redhat I could edit /etc/xorg.conf and the "monitor" section and fill in the correct vertical and horizontal frequencies. Now it seems there is no monitor options at all. Where can I manually fix the monitor settings?

really thankful for help,
 
Old 10-30-2007, 04:28 AM   #6
martinr
Member
 
Registered: Mar 2006
Location: Stockholm, Sweden
Distribution: FC10 x86_64, RHEL4/5 x86_64
Posts: 87

Original Poster
Rep: Reputation: 15
Question startup screen isn't showing

Here's the deal. It seems like the nvidia driver for fedora (livna respo) which is fairly awesome btw correctly detects both card and screen and can do all kind so nice things... It can also be used to rewrite the xorg.conf file with correct information such as a monitor section. I tried both this and before it manually adding a monitor section.

Still, it almost seems like what is written in the xorg.conf doesn't matters... or it matters, but not as much as it used to in eralier versions. If there is some typo startup complains. But whether I have a monitor section (with correct values) or not doesn't seem to matter. I still need to boot to runlevel 3 and then start runlevel 5 for things to work. If I try to initiate 5 from the beginning the screen complains about frequencies and then it frezees (A few times it has actually continued booting and after a few minutes worked as it should)


Anyone a clue?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Startup command in runlevel 4 darklink2058 Slackware 3 10-02-2007 10:44 AM
Runlevel 3 before booting waelaltaqi Linux - Software 2 02-13-2006 09:45 PM
runlevel 3 while startup? polemon Linux - Newbie 4 02-13-2006 06:11 PM
Runlevel 3 and 4 startup configs ghight Linux - Software 4 12-19-2003 10:27 AM
Enter runlevel: on startup sikandar Linux - Software 19 08-26-2003 10:57 AM


All times are GMT -5. The time now is 03:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration