LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 01-16-2005, 01:05 PM   #1
darknails
Member
 
Registered: Jul 2004
Location: Germany
Distribution: Debian
Posts: 46

Rep: Reputation: 15
Startup is very slow FC3


Hello,
I'm trying to figure out why it takes ages to load the programs at the start up, after someone fiddled with some x-server or x-server related configuration file.

First, it takes ages to complete the
Code:
checking sendmail................[OK]
process when the kernel is loaded. And then what is worse, is that it takes ages for the login screen to come up. and after the login, when the gnome is load the Windows Manager, Network Manager, and CD Handler, etc. it takes long time too.

I post my x-server configuration file here incase someone needs to know:
Code:
# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
#	InputDevice    "Mouse0" "AlwaysCore"
	InputDevice    "Keyboard0" "CoreKeyboard"
#	InputDevice    "SynapticsMouse" "CorePointer"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "mouse"
	Load  "synaptics"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
#	Option	    "SendCoreEvents" "yes"

EndSection

#Section "InputDevice"
#        Identifier  	"SynapticsMouse"
#        Driver  	"synaptics"
##       Option 	"Device"  	"/dev/psaux"
#	Option 	"Device"  	"/dev/input/mice"
# 	Option	"Protocol"	"auto-dev"
#  	Option	"LeftEdge"      "1700"
#  	Option	"RightEdge"     "5300"
#  	Option	"TopEdge"       "1700"
#  	Option	"BottomEdge"    "4200"
#  	Option	"FingerLow"	"25"
#  	Option	"FingerHigh"	"30"
#  	Option	"MaxTapTime"	"180"
#  	Option	"MaxTapMove"	"220"
#  	Option	"VertScrollDelta" "100"
#  	Option	"MinSpeed"	"0.06"
#  	Option	"MaxSpeed"	"0.12"
#  	Option	"AccelFactor" "0.0010"
#  	Option	"SHMConfig"	"on"
##	Option	"Repeater"	"/dev/ps2mouse"
#EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "LCD Panel 1024x768"
	HorizSync    31.5 - 48.5
	VertRefresh  40.0 - 70.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "radeon"
	VendorName  "Videocard vendor"
	BoardName   "ATI Radeon Mobility M9"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
and my kernel version is 2.6.10-1.741_FC3

Thanks..in advance

Last edited by darknails; 01-16-2005 at 01:14 PM.
 
Old 07-07-2007, 02:01 PM   #2
Mirkridian
LQ Newbie
 
Registered: Sep 2006
Distribution: Fedora
Posts: 10

Rep: Reputation: 0
I know this is a very old post... but I found it through a search, and I'm having exactly the same problem in Fedora Core 6. If the original poster found a solution or if someone else did since this was posted, I would very much like to hear it, as I haven't yet been able to fix it..
 
Old 07-08-2007, 03:51 PM   #3
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
When the network is initialized, the kernel may halt while waiting for an interrupt to be generated by the networking hardware. If, for some reason, the hardware is not responding, a "wait for timeout" of 30 to 60 seconds can cause you to think that your system is "slow."

You can check for this by disabling the starting of the network service(s) during boot, and then starting them "by hand" later.

Use the system-config-services command to change the list of services to be started during bootup, and you can use to same command to start those services by hand. (You "uncheck" the box to disable the service start during boot, and just click on the "start" button to start it later "by hand".

If it is a network hardware response time problem, see if you can speed it up by changing your network settings.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow startup Dosenwurst Debian 3 06-15-2005 08:09 AM
Slow Startup on pentium 4 anubis26 Fedora 2 03-26-2005 06:04 PM
Slow startup sdat1333 Mandriva 2 11-24-2004 10:38 AM
mouse slow on startup..? marlor Slackware 4 07-10-2004 07:21 PM
X startup really slow ryedunn Mandriva 2 03-05-2004 05:27 PM


All times are GMT -5. The time now is 09:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration