LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-17-2009, 11:41 AM   #1
mickeyboa
Senior Member
 
Registered: May 2004
Location: Indianapolis, Indiana
Distribution: FC-KDE, 32 and 64 bit
Posts: 1,398

Rep: Reputation: 55
Starting Applications in KDE-4.2 after Login


FC10/KDE-4.2

I want to AutoStart the kdeblutooth4 app. and put the Icon in the Tray each time I login to my KDE Desktop . So as to get my bluetooth mouse to work, I know how to get the mouse started after login, but first I have to get kdebluetooth Icon to AutoStart into Panel Tray.
I know how to goto Menu and click onto kdebluetooth4, before someone jumps on that one.

Last edited by mickeyboa; 02-17-2009 at 11:45 AM.
 
Old 02-17-2009, 11:54 AM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,297

Rep: Reputation: 205Reputation: 205Reputation: 205
In Configure your desktop--> Advanced there's an Autostart section, try putting it in there.
 
Old 02-17-2009, 12:22 PM   #3
metrofox
Member
 
Registered: Jan 2009
Location: Palermo, Italy
Distribution: Slackware
Posts: 236

Rep: Reputation: 37
Or create a link between the binary file(it could be in /usr/bin/)to ~/.kde/Autostart. Just type:

Code:
ln -s programExecutable ~/.kde/Autostart
It's the same step than the {BBI}Nexus{BBI}'s one.

Last edited by metrofox; 02-17-2009 at 12:25 PM.
 
Old 02-17-2009, 12:30 PM   #4
mickeyboa
Senior Member
 
Registered: May 2004
Location: Indianapolis, Indiana
Distribution: FC-KDE, 32 and 64 bit
Posts: 1,398

Original Poster
Rep: Reputation: 55
There is no Configure your desktop--> Advanced, in KDE-4.2 . I assume your talking about right clicking on Desktop for this window?

It has a "Appearance Settings" in window that popsup and there is no settings for Autostarting.

KDE-4 is going to take time to get the hang of the settings.
 
Old 02-17-2009, 12:44 PM   #5
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,297

Rep: Reputation: 205Reputation: 205Reputation: 205
Quote:
Originally Posted by mickeyboa View Post
There is no Configure your desktop
Yes there is, the icon is a spanner and screwdriver.

The metrofox way will work just the same except you need to link it to ~/.kde4/Autostart

Last edited by {BBI}Nexus{BBI}; 02-17-2009 at 12:47 PM.
 
Old 02-17-2009, 01:09 PM   #6
mickeyboa
Senior Member
 
Registered: May 2004
Location: Indianapolis, Indiana
Distribution: FC-KDE, 32 and 64 bit
Posts: 1,398

Original Poster
Rep: Reputation: 55
If i right click on Desktop , I get a Window that opens with a spanner wrentch that says
"Appearance Settings" .

If I right click on Panel at bottom I get a Spanner Wrentch and it says "Task Manager Settings"

I'm using KDE-4.2.0-2, what version are you using ?
 
Old 02-17-2009, 01:15 PM   #7
metrofox
Member
 
Registered: Jan 2009
Location: Palermo, Italy
Distribution: Slackware
Posts: 236

Rep: Reputation: 37
I found the right place:

K--->Computer--->System Settings-->Click on "Advanced"--->There could be a button with wrote on "Autostart" or something of similar(I've got an Italian KDE.). Once there click on "Add program" or "Add script"...Let me know Any way, the terminal way is also right, and it's faster and more professional and more linux way
 
Old 02-17-2009, 01:45 PM   #8
mickeyboa
Senior Member
 
Registered: May 2004
Location: Indianapolis, Indiana
Distribution: FC-KDE, 32 and 64 bit
Posts: 1,398

Original Poster
Rep: Reputation: 55
Nothing like that in Kmenu > Settings .

Cant one just goto /home/user/.kde/Autostart and enter a script to start a Application after Login.

For starting Kdebluetooth4 how would you do the script in Autostart ??

Doing things from the command line can be a hell-of-alot easier than finding something in a GUI.

Thanks Jim
 
Old 02-17-2009, 02:21 PM   #9
mickeyboa
Senior Member
 
Registered: May 2004
Location: Indianapolis, Indiana
Distribution: FC-KDE, 32 and 64 bit
Posts: 1,398

Original Poster
Rep: Reputation: 55
Solved- Starting Applications in KDE-4.2 after Login

with Konqueror I went into /home/user/.kde/Autostart/bluetooth.sh, made the text file bluetooth.sh, and edited it.


#!/bin/bash

/usr/bin/kbluetooth4




And I had to do a su and chmod +x /home/user/.kde/Autostart/kbluetooth.sh
Restarted KDE and it put the bluetooth Icon in Tray and enabled my bluetooth mouse.
Like I said doing it on the command is a Hell-of-Alot easier.
 
Old 02-17-2009, 02:41 PM   #10
metrofox
Member
 
Registered: Jan 2009
Location: Palermo, Italy
Distribution: Slackware
Posts: 236

Rep: Reputation: 37
There wasn't any need to make a normal script which links to executable, you could create a direct link from the executable to ~/.kde/Autostart just typing:

Code:
ln -s /usr/bin/kbluetooth4 ~/.kde/Autostart
I did it with compiz when I had KDE3.5.10. However, things are the same between a very basic bash script which runs the kbluetooth4 command and the making of a link which links the executable in ~/.kde/Autostart.
 
Old 02-17-2009, 02:43 PM   #11
mickeyboa
Senior Member
 
Registered: May 2004
Location: Indianapolis, Indiana
Distribution: FC-KDE, 32 and 64 bit
Posts: 1,398

Original Poster
Rep: Reputation: 55
Yeah your right, but it is working okay now.

Thanks Jim
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I am having a problem starting applications in a new installation of KDE leland9000 Linux - Desktop 1 02-26-2008 04:55 PM
Can't stop Gaim starting at KDE login dmorrell Linux - Software 1 01-02-2007 04:47 AM
Getting rid of unused Gnome applications starting at boot (using KDE) finnjimm Linux - Software 1 07-24-2005 10:53 PM
Starting applications at login in GNOME janisj Linux - Software 1 08-07-2004 06:40 AM
some kde applications not execute in RHL 7.2 on login as root chinmay nautiya Linux - Software 5 01-18-2003 06:35 AM


All times are GMT -5. The time now is 11:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration