LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Sound Server, ArTs, no sound FC4 (http://www.linuxquestions.org/questions/fedora-35/sound-server-arts-no-sound-fc4-355894/)

javb 08-22-2005 02:13 PM

Sound Server, ArTs, no sound FC4
 
Hi, i just installed FC4 on my Inpiron 6000, it was just ok, the sound was working, "good", after installing i did "yum update" (thinking that it was just gonna update my system to the latest stable versions of all my packages installed -- please correct me if this is wrong) after i made "update" and reboot my system, sound is gone, there is nothing, the drivers are working "well" nothing seems to be wrong, the only thing is that THERE IS NO SOUND.

I logged as root to the X, and i got a message:
--------------------------------------------------------------
sound server infromational message:
Error while initializing the sound driver:
device:default can`t be opened for playback (invalid argument)
The sound server will continue, using the null output device.
---------------------------------------------------------------

i uninstalled and installed again ALSA, unstalled it and installed from the fedora page.
so i dont know what to do.
Some times KDE crashes due to the sound server, and mention something related with ArTs?
i think i read something about my problem related to this, but NOTHING YET.
please i really need help, i need MY SOUND working.
(i was thinking of installed the ALSA version that came in the installation CDs, because they worked, but dont know how to do it, dont even know in which CD i ll look)
(im not even sure if the ALSA is the problem.)

anyway i hope u can tell me something helpful. thanks guys.
P.s: I have being "googling" a lot, this problem seems to be new

fpd 08-23-2005 11:35 PM

jb,

I am using FC3 and updated using the GUI tool with the ( ! ) on the taskbar and lost audio. (insert long story about searching forum sites here). In the end I simply double-clicked the speaker icon and found that everything was muted. I unmuted the needful and I can hear my computer again.

rickh 08-24-2005 12:38 PM

Quote:

i just installed FC4 on my Inpiron 6000, it was just ok, the sound was working, "good", after installing i did "yum update" (thinking that it was just gonna update my system to the latest stable versions of all my packages installed -- please correct me if this is wrong) after i made "update" and reboot my system, sound is gone, there is nothing, the drivers are working "well" nothing seems to be wrong, the only thing is that THERE IS NO SOUND.
I did exactly the same thing with exactly the same result.

On bootup, I get this message, evidently from Gnome:
'No volume control elements and/or devices found.'

I don't even have the volume controller on the taskbar. When I try to run it from the menu, I get this error:
'Registry is not present or it is corrupted, please update it by running gst-register'

I managed to find gst-register and execute it ... It said it was adding all kinds of sound related plugins, but nothing changed as far as sound output is concerned.

lsmod | grep snd
Code:

snd_atiixp            27105  0
snd_ac97_codec        98437  1 snd_atiixp
snd_seq_dummy          4677  0
snd_seq_oss            45477  0
snd_seq_midi_event    11713  1 snd_seq_oss
snd_seq                79769  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device        11217  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            63089  0
snd_mixer_oss          20673  1 snd_pcm_oss
snd_pcm              122957  3 snd_atiixp,snd_ac97_codec,snd_pcm_oss
snd_timer              38217  2 snd_seq,snd_pcm
snd                    69697  9 snd_atiixp,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              13409  1 snd
snd_page_alloc        12105  2 snd_atiixp,snd_pcm

Fedora evidently doesn't have alsaconf ... How do I probe my soundcard?

As with javb (above), it was working fine until I did 'yum update'.

rickh 08-24-2005 02:27 PM

OK. I got mine working. I did a lot of stuff, so I'm not positive, but it seemed that the key was to run gst-register for each individual user.

javb 08-24-2005 07:00 PM

Ok, here i have my solution.. i made it.. its a stupid thing.. as many in linux.

Well, the thing is , when you make Update, dont know why, but there is an option in ALSAMIXER, named (External Amplifier) it is muted.
Unmute it, and mute HEADPHONE jack.. so u ll have sound again.

Install system-config-soundcard package (yum), to probe it.

thats it.

USING KDE.
FC4.
alsamixer.

hope it helps.

see ya guys and thanks who helped.

mulciber 09-05-2005 09:57 PM

Thanks javb, that worked for me!

Lnx805 09-06-2005 12:57 AM

Hmmm, this seems to be a common problem.

So basically I should "update" alsamixer and make the suggested settings[??].
And then install "yum" the "system-config-soundcard package" [??].

I've been trying to sort this out for some time now and for someone that's new, it's very frustrating.
Thx...
:newbie:

sp1c3b0y 09-22-2005 12:30 PM

It Works!

I cannot believe I've searched the net up and down to find out it was soo simple (and studpid)

Cheers I'll keep linux after all :)


All times are GMT -5. The time now is 06:53 AM.