LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   sound configuration in fc8 (http://www.linuxquestions.org/questions/fedora-35/sound-configuration-in-fc8-602040/)

manoj_bhu 11-24-2007 01:10 AM

sound configuration in fc8
 
Hi
I am using a dual boot lenovo system (fedora 8 and Windows XP). The system has internal speakers within cabinet and also a provision for connecting external speakers. Windows XP plays sound on internal speakers if external speakers are not connected whereas Fedora 8 with pulseaudio server plays sound only on external speakers.Fedora 8 plays only terminal beeps on internal speakers. What changes shoul d i make so that in fedora 8 the sounds are played on internal speakers if external speakers are not connected ?
Thanks in advance
M K Singh

Simon Bridge 11-24-2007 06:02 PM

fedora 8 has a sound configuration guis - check the setings for system and other sounds. It looks like different systems are claiming different parts of the card - look at your hardware info and see how many sound cards are listed.

manoj_bhu 11-25-2007 11:19 PM

Hi
Thanks for replying. I have checked the system configuration for sound. It lists only one sound card namely,Intel Corporation 82801H(ICH8 family) HD Audio Controller. My chipset is i965.
MK Singh

Simon Bridge 11-26-2007 06:04 AM

OK, but try disabling system sounds.

What does system-config-soundcard have to say in entirety?


# alsamixer
# rpm -qa | grep alsa
# lsmod | grep snd
# uname -a
# pulseaudio --dump-modules

f8 uses pulseaudio by default, so I hope you didn't install by some other means...
Strongly suggest gaining an understanding of how pulseaudio works:
http://www.linux.com/feature/119926
... is an overview. Use the links to the FAQ and the developer hints.

manoj_bhu 11-27-2007 03:26 AM

Hi
Following is the output of various commands. I hope this helps.I am using fresh installation of f8,i mean no upgrade from previous versions, with default pulse audio installation.
Thanks
MK singh

[root@mks ~]# alsamixer
*** PULSEAUDIO: Unable to connect: Connection refused

alsamixer: function snd_ctl_open failed for default: Connection refused
[root@mks ~]# rpm -qa|grep alsa
bluez-utils-alsa-3.20-4.fc8
alsa-lib-1.0.15-1.fc8
alsa-lib-devel-1.0.15-1.fc8
alsa-lib-1.0.15-1.fc8
alsa-plugins-pulseaudio-1.0.14-5.fc8
alsa-utils-1.0.15-1.fc8
[root@mks ~]# lsmod |grep snd
snd_hda_intel 361577 2
snd_usb_audio 95169 0
snd_usb_lib 24001 1 snd_usb_audio
snd_rawmidi 28865 1 snd_usb_lib
snd_seq_dummy 11461 0
snd_seq_oss 37313 0
snd_seq_midi_event 15041 1 snd_seq_oss
snd_seq 56673 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 15061 4 snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 45889 0
snd_mixer_oss 22721 2 snd_pcm_oss
snd_pcm 80201 3 snd_hda_intel,snd_usb_audio,snd_pcm_oss
snd_timer 27721 2 snd_seq,snd_pcm
snd_page_alloc 16465 2 snd_hda_intel,snd_pcm
snd_hwdep 16073 2 snd_hda_intel,snd_usb_audio
snd 60137 13 snd_hda_intel,snd_usb_audio,snd_rawmidi,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss ,snd_pcm,snd_timer,snd_hwdep
soundcore 15073 2 snd
[root@mks ~]# uname -a
Linux mks.bhu.ac.in 2.6.23.1-49.fc8 #1 SMP Thu Nov 8 22:14:09 EST 2007 x86_64 x86_64 x86_64 GNU/Linux
[root@mks ~]# pulseaudio --dump-modules
module-alsa-sink n/a
module-alsa-source n/a
module-cli n/a
module-cli-protocol-tcp n/a
module-cli-protocol-unix n/a
module-combine n/a
module-default-device-restore n/a
module-detect n/a
module-esound-compat-spawnfd n/a
module-esound-compat-spawnpid n/a
module-esound-protocol-tcp n/a
module-esound-protocol-unix n/a
module-gconf n/a
module-hal-detect n/a
module-http-protocol-tcp n/a
module-http-protocol-unix n/a
module-ladspa-sink n/a
module-match n/a
module-mmkbd-evdev n/a
module-native-protocol-fd n/a
module-native-protocol-tcp n/a
module-native-protocol-unix n/a
module-null-sink n/a
module-oss n/a
module-pipe-sink n/a
module-pipe-source n/a
module-remap-sink n/a
module-rescue-streams n/a
module-rtp-recv n/a
module-rtp-send n/a
module-simple-protocol-tcp n/a
module-simple-protocol-unix n/a
module-sine n/a
module-suspend-on-idle n/a
module-volume-restore n/a
module-x11-bell n/a
module-x11-publish n/a
module-x11-xsmp n/a
[root@mks ~]#

manoj_bhu 11-27-2007 03:35 AM

Hi
I am able to enable and disable system beep from system-config-sound gui.
MK Singh

guedellas 01-01-2008 01:51 PM

Sound through headphones or external speakers but no through on-board speakers
 
Hi guys!

mainly the same problem.
I can hear my sounds (films, music) only through headphones or external speakers, but my on-board speakers apparently don't work.
My computer: acer 5920G.

Do you listen to your sounds with the internal speakers?
How could you solve the problem?

My outputs:
alsamixer output is correct. I can modify system volume with no problem.

rpm -qa | grep alsa
Code:

alsa-plugins-pulseaudio-1.0.14-5.fc8
alsa-lib-1.0.15-1.fc8
alsa-utils-1.0.15-1.fc8
bluez-utils-alsa-3.20-4.fc8

lsmod | grep snd
Code:

snd_hda_intel        274529  5
snd_seq_dummy          6725  0
snd_seq_oss            29889  0
snd_seq_midi_event      9793  1 snd_seq_oss
snd_seq                44849  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device        10061  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            37569  0
snd_mixer_oss          16705  2 snd_pcm_oss
snd_pcm                63685  3 snd_hda_intel,snd_pcm_oss
snd_timer              20549  2 snd_seq,snd_pcm
snd_page_alloc        11337  2 snd_hda_intel,snd_pcm
snd_hwdep              10309  1 snd_hda_intel
snd                    43461  16 snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore              9633  2 snd

uname -a
Code:

Linux deimos 2.6.23.9-85.fc8 #1 SMP Fri Dec 7 15:49:59 EST 2007 i686 i686 i386 GNU/Linux
pulseaudio --dump-modules
Code:

module-alsa-sink                        n/a
module-alsa-source                      n/a
module-cli                              n/a
module-cli-protocol-tcp                n/a
module-cli-protocol-unix                n/a
module-combine                          n/a
module-default-device-restore          n/a
module-detect                          n/a
module-esound-compat-spawnfd            n/a
module-esound-compat-spawnpid          n/a
module-esound-protocol-tcp              n/a
module-esound-protocol-unix            n/a
module-gconf                            n/a
module-hal-detect                      n/a
module-http-protocol-tcp                n/a
module-http-protocol-unix              n/a
module-ladspa-sink                      n/a
module-match                            n/a
module-mmkbd-evdev                      n/a
module-native-protocol-fd              n/a
module-native-protocol-tcp              n/a
module-native-protocol-unix            n/a
module-null-sink                        n/a
module-oss                              n/a
module-pipe-sink                        n/a
module-pipe-source                      n/a
module-remap-sink                      n/a
module-rescue-streams                  n/a
module-rtp-recv                        n/a
module-rtp-send                        n/a
module-simple-protocol-tcp              n/a
module-simple-protocol-unix            n/a
module-sine                            n/a
module-suspend-on-idle                  n/a
module-volume-restore                  n/a
module-x11-bell                        n/a
module-x11-publish                      n/a
module-x11-xsmp                        n/a

Any help will be really appreciated.

TIA!!

Simon Bridge 01-01-2008 07:53 PM

Quote:

Originally Posted by manoj_bhu
[root@mks ~]# alsamixer
*** PULSEAUDIO: Unable to connect: Connection refused
alsamixer: function snd_ctl_open failed for default: Connection refused

... well - here's the problem.

http://www.nabble.com/No-sound-with-...d14412563.html
http://www.linuxquestions.org/questi...-x8664-598248/
... eliminate security as an issue. Disable SELinux.

guedellas 01-06-2008 07:37 AM

Hi Simon,

thanks for the reply, but I think it does not apply to my case.
In other forums concerning about the installation of linux on an Acer 5920 I've read that the problem maybe is that I have to activate "surround" on the "mixer" (ubuntu people). Rocket engineering for me at this point. :scratch:


Is there any similar in Fedora? I've tried to do that but don't find the right option in System->Preferences->HW->Sound.
Any command?? alsamixer on the shell doesn´t show any mixer around neither.

Thank you very much!

guedellas 01-06-2008 07:46 AM

Hi again, pal.

I was right, for my case. Now it has all the sense, don't you think? Find the option and all go smooth and clear.

Thanks!

Simon Bridge 01-06-2008 09:23 PM

Where did you find the option. Well done BTW.

guedellas 01-07-2008 02:30 PM

gnome-volume-control (system -> preferences -> hardware -> volume control [or something similar])
Then you can go to Edit -> Preferences and enable the Surround option. Raise the volume and enjoy!

Lurking around I found that it also can be done with "amixer -c 0 sset Surround 1+ unmute cap", really useful combined with xbindkeys, to exploit all the options of the laptop, or if you don't use gnome.

Now I feel great with my laptop!

Thanks for the support!!

ghiro 03-06-2008 02:01 PM

that helped me a lot guedallas.

thanks you so much!

popatopalous 04-16-2008 02:34 PM

Quote:

Originally Posted by manoj_bhu (Post 2971975)
Hi
I am able to enable and disable system beep from system-config-sound gui.
MK Singh

Shouldn't you be hearing guitar chords? Are you in KDE?

jludwig 05-07-2008 07:12 PM

I found on my last upgrade the file /etc/inittab.rpmnew was installed and did not replace inittab.
I had horrendous problems with printing, sound, networking, etc until I replaced inittab with inittab.rpmnew and rebooted.
I.E
[root@localhost ~]#mv inittab inittab.old
[root@localhost ~]#mv inittab.rpmnew inittab
[root@localhost ~]#shutdown -r 0
All my issues went away.
Check to see if you have a inittab.rpmnew that is newer than inittab.
I.E.
[root@localhost ~]# ll inittab*


All times are GMT -5. The time now is 11:27 PM.