LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 09-09-2005, 07:21 AM   #1
yekrahs
Member
 
Registered: Aug 2005
Location: England
Distribution: SUSE 10.0, LiMP (Linux Multimedia Player)
Posts: 86

Rep: Reputation: 15
Something STRANGE is happening when I try to mount USB / floppies etc.


PROBLEM #1
Mounting floppies / USB disks from root has worked fine from root.
But does anyone know how to mount these when not in root?

When I try, Fedora Core 4 tells me that I don't have the permissions: it's a bit of a pain if you have to log in as root to mount anything.
Using the 'mount' command won't work unless you're 'su' in terminal mode as a normal user, too.


PROBLEM #2
Even when I have the things mounted, Fedora tells me that I don't have the permission to write to the floppy / USB etc. when not as root. So I logged into root to change this & alter the permissions,

...but this is the STRANGE bit:

when I right clicked on the floppies etc. to alter the permissions, and put a tick in the box for users in the same group to be able to write, and also in the box for Others to write, the tick disappeared just after I put it in!

I tried it again, but every time I try to tick the box to change the permissions, it disappears again!


How can I fix this? Or is my PC playing mind games with me?


 
Old 09-10-2005, 03:55 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,386

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
1 - ensure they have direct entries in /etc/fstab and have the "user" option specified for each one.

2 - they don't support the file permission attributes you wish to change. there is simply nowhere for that change to be stored. you can force permissions on non unix filesystems using the umask= option in the relevant fstab entry.
 
Old 09-12-2005, 09:36 AM   #3
yekrahs
Member
 
Registered: Aug 2005
Location: England
Distribution: SUSE 10.0, LiMP (Linux Multimedia Player)
Posts: 86

Original Poster
Rep: Reputation: 15
So about the directories in /etc/fstab...

do I just type

mount -t vfat /dev/sda1 /mnt/USB or
mount -t vfat /dev/fd0 /mnt/floppy

or is there a bit more to it than that? (I'm guessing there is)



If so, are there any good Howto's out there on how to use the /etc/fstab file, would you know?



Thanks
 
Old 09-12-2005, 02:21 PM   #4
jonty-comp
LQ Newbie
 
Registered: Sep 2005
Location: Chesterfield, England
Distribution: Debian Sarge
Posts: 9

Rep: Reputation: 0
In your case you would open /etc/fstab with KWrite (or whatever you use) as root and add the following:

/dev/sda1 /mnt/USB user,noauto 0 0
/dev/fd0 /mnt/floppy user,noauto 0 0

(pressing TAB a few times for the gaps)
This will make it so that any user can mount the device, although on my system I don't know whether i've done something wrong but I can't copy files and folders to them (but my spare hard drive is old and keeps malfunctioning anyway, so it might just be that!)

What I did then was make a link to the drive on the Desktop (this is in KDE, so it might not work in GNOME) and when I clicked on it, it mounted it and opened a Konqueror window displaying it's contents.

Hope that helps!

P.S. Using the noauto option in fstab means that it won't mount at system startup, but only when it's required. This is useful if you plug in your USB stick after boot-up. Also, you can plug in any 1 USB flash memory device at boot, and it will still work! (it does on mine anyway!)
 
Old 09-15-2005, 06:04 AM   #5
yekrahs
Member
 
Registered: Aug 2005
Location: England
Distribution: SUSE 10.0, LiMP (Linux Multimedia Player)
Posts: 86

Original Poster
Rep: Reputation: 15
Thanks very much


I just came across a good howto in simple english, as well (if anyone else is reading this)

http://www.tuxfiles.org/linuxhelp/fstab.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot Floppies and USB Floppy Drives R-Razi Linux - Newbie 3 08-23-2004 11:51 AM
Can't mount/format/dd/anything floppies. Ebel Linux - Software 6 08-22-2004 02:33 PM
a question about mount and floppies tuxfood Linux - General 3 08-05-2004 04:05 AM
Strange happening...won't boot to kdm. Nu-Bee Linux - General 2 12-07-2003 01:22 PM
mount usb module then mount usb hard drive guanyu Linux - Hardware 1 10-08-2003 11:50 AM


All times are GMT -5. The time now is 09:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration