LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-22-2007, 12:53 PM   #1
cfalzone
LQ Newbie
 
Registered: Feb 2007
Location: Erie, PA, USA
Distribution: Fedora Core 6
Posts: 3

Rep: Reputation: 0
Question Slow Download Speed with FC6


I hook my linux box and windows box up to the same internet connection through a router / switch. My linux box seemed to be getting really horrible download speeds, so I tried one of those speed test things. The windows machine is getting 5720kbps download, the linux box is getting 73kbps. On top of that a 100MB file takes 20 mins to download on the windows box and 8 hrs to download on the linux box!! That does not make any sense to me.

Could you guys give me some pointers on how to find out why this happening and/or how to fix it? I am running Fedora Core 6. The speed test I tried is here: ((won't let me post it yet .. this is my first post -- Search google for speed test it is the first one, called Speakeasy)).

I have already tried hooking the linux box directly up to the modem to see if it was my router/switch that was causing the issue and it is not.

Thanks,
Chris F.


Additional Info:

ifconfig output:
Code:
eth0      Link encap:Ethernet  HWaddr 00:07:E9:87:EE:C7
          inet addr:192.168.1.6  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::207:e9ff:fe87:eec7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:24816 errors:0 dropped:0 overruns:0 frame:0
          TX packets:19458 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:22467844 (21.4 MiB)  TX bytes:2599552 (2.4 MiB)
          Base address:0xec40 Memory:fe1c0000-fe1e0000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1594 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1594 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4744156 (4.5 MiB)  TX bytes:4744156 (4.5 MiB)
 
Old 02-23-2007, 06:15 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
As root, turn off the ip6 networking...........

In /etc/modprobe.conf add the line: inet6 addr: alias net-pf-10 off
In /etc/sysconfig/network add/change the line: NETWORKING_IPV6=no
Edit the /etc/sysconfig/network-scripts/ifcfg-eth0 file and add/change:
IPV6INIT=no

Also do: chkconfig --level 2345 ip6tables off

When done restart the network service: service network restart
 
Old 02-23-2007, 10:29 AM   #3
cfalzone
LQ Newbie
 
Registered: Feb 2007
Location: Erie, PA, USA
Distribution: Fedora Core 6
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Lenard
As root, turn off the ip6 networking...........

In /etc/modprobe.conf add the line: inet6 addr: alias net-pf-10 off
In /etc/sysconfig/network add/change the line: NETWORKING_IPV6=no
Edit the /etc/sysconfig/network-scripts/ifcfg-eth0 file and add/change:
IPV6INIT=no

Also do: chkconfig --level 2345 ip6tables off

When done restart the network service: service network restart
Ok I did all that. Here are the files:
/etc/modprobe.conf:
Code:
alias eth0 e1000
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel9x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias net-pf-10 off
/etc/sysconfig/network:
Code:
NETWORKING=yes
NETWORKING_IPV6=no
HOSTNAME=localhost.localdomain
/etc/sysconfig/network-scripts/ifcfg-eth0:
Code:
# Intel Corporation 82540EM Gigabit Ethernet Controller
DEVICE=eth0
BOOTPROTO=none
HWADDR=00:07:E9:87:EE:C7
ONBOOT=yes
NETMASK=255.255.255.0
IPADDR=192.168.1.6
GATEWAY=192.168.1.1
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=yes

It didn't seem to help, but I am going to restart then see what happens.
Thanks for the help!!


EDIT: No Change after reboot.

Last edited by cfalzone; 02-23-2007 at 10:39 AM.
 
Old 02-23-2007, 11:15 AM   #4
cfalzone
LQ Newbie
 
Registered: Feb 2007
Location: Erie, PA, USA
Distribution: Fedora Core 6
Posts: 3

Original Poster
Rep: Reputation: 0
Found the key to open the door ...

After much searching I found a few articles on tcp window scaling that raised an eyebrow ... and finally I came accross the winner ...

Code:
sysctl -w net.ipv4.tcp_window_scaling=0
Fixed the problem, and putting this ...

Code:
net.ipv4.tcp_window_scaling = 0
into my /etc/sysctl.conf, plus a reboot made it permanent.
Thanks Again.
--Chris Falzone

Last edited by cfalzone; 02-23-2007 at 11:16 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow download speed with torrents Zmyrgel Linux - Networking 1 01-05-2007 06:32 AM
Liunx Has Slow Download Speed? jimbo-62 Linux - Networking 3 11-11-2006 01:49 PM
NIC transfer speed fast... receive speed slow landev Linux - Networking 5 11-07-2006 03:09 PM
download speed too slow sharadshankar Linux - Networking 1 03-24-2006 03:25 AM
upload/download speed slow only over WAN? Help Please slack_usr Slackware 19 12-07-2004 10:03 AM


All times are GMT -5. The time now is 01:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration