LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 04-10-2005, 09:36 PM   #1
Phaete
LQ Newbie
 
Registered: Mar 2003
Posts: 6

Rep: Reputation: 0
Slack/Fedora dual-boot using LVM


After reading a How-To on LVM, I suspect I made a big mistake when adding a new HDD and Fedora install to a working Slack 10 system.

I booted from the Fedora bootable CD burned from ISO and the install ran fine. The existing system is a Slack install to a smaller 4GB HDD (hda). I installed the Fedora Core 3 onto a clean 10GB drive (hdb) and decided, rather than screw something up when asked to install GRUB, I said no assuming I would simply add boot instructions to my existing /etc/lilo.conf after install.

So, Fedora finished and I ran #fdisk /dev/hdb to see how files were laid down:

Disk /dev/hdb: 10.2 GB, 10248118272 bytes
255 heads, 63 sectors/track, 1245 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 13 104391 83 Linux
/dev/hdb2 14 1245 9896040 8e Linux LVM

It seems the default Fedora install uses LVM. I can't seem to mount this filesystem (if there is such a mount of it), so obviously can't modify lilo for a second OS boot.

Is this possible or must I reinstall Fedora selecting either a GRUB installer or more native filesystem than using a Logical Volume Manager? I would actually like to keep LVM intact if it isn't too much for a newbie

Thx in advance!
 
Old 04-11-2005, 07:20 AM   #2
Phaete
LQ Newbie
 
Registered: Mar 2003
Posts: 6

Original Poster
Rep: Reputation: 0
Setup information

Contents of fstab (after I added the /fedora mount point to /hdb1 and guessed at file type of reiser since both partitions display as type 83 = Linux in fdisk ... this is probably incorrect?!):

root@DaBox:/fedora# more /etc/fstab
/dev/hda1 swap swap defaults 0 0
/dev/hda2 / reiserfs defaults 1 1
/dev/hdb1 /fedora reiserfs defaults 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0


... and I created a symlink to the fedora kernel called /fedora/vmlinuz, as below:

root@DaBox:/fedora# ls -p
System.map-2.6.9-1.667 initrd-2.6.9-1.667.img vmlinuz-2.6.9-1.667
config-2.6.9-1.667 lost+found/
grub/ vmlinuz@


... finally, I manually added the boot setup in /etc/lilo.conf as follows:

root@DaBox:/fedora# more /etc/lilo.conf
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda2
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda2
label = Slackware 10
read-only

image = /fedora/vmlinuz
root = /dev/hdb1
label = Fedora Core-3
read-only

# Linux bootable partition config ends


I only get one OS option upon boot, however.
 
Old 04-13-2005, 01:50 PM   #3
snecklifter
Member
 
Registered: Mar 2004
Location: UK/West Yorkshire/Huddersfield
Distribution: Fedora 7
Posts: 982

Rep: Reputation: 30
You'll need to check Reiserfs support for your kernel and lilo. I dont think lilo supports reiser on one of the kernels (2.4 or 2.6, cant remember) but this will be the source of your problems.
 
Old 04-14-2005, 04:13 PM   #4
Phaete
LQ Newbie
 
Registered: Mar 2003
Posts: 6

Original Poster
Rep: Reputation: 0
I believe the problem to be in my lilo.conf definition.

Based on feedback I get from successful Slack boot, /dev/hdb1 is ext3, not reiserfs, so I changed the lilo.conf to reflect this.

Also, I was missing a line related to initrd, so added that as well. I'm offsite, so don't have the exact syntax, but I have modified fstab to:

.
.
.
/dev/hdb1 /mnt/fc3 ext3 defaults 0 0
.
.


Selecting the Fedora boot now properly attempts the load of the fc3 kernel, but I still get kernel panic after the kernel discovers a mounted 'volume' called "VolGroup00". I have gotten further with the initrd instruction, but it still bails with something about not being able to mount a file system. I will post the specifics, later, but I suspect it has something to do with mounting the filesystems WITHIN the LVM volume group.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slack and suse dual boot. boot error cormack Slackware 4 05-24-2006 01:10 AM
Fedora Core 3 Dual Boot, Dual Hard drives, Grub Boot Loader Denali03 Linux - Newbie 1 03-04-2005 01:44 PM
Slack 10 + Win Xp Dual Boot Help roel81 Linux - Newbie 2 09-06-2004 10:36 PM
Fedora/Slack Dual-Boot w/ GRUB mijenks Linux - Software 0 06-11-2004 07:40 AM
Dual boot with Slack 8.1 and XP?!? bripage Linux - General 4 06-27-2002 03:40 PM


All times are GMT -5. The time now is 05:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration