LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Simple (?) resolution issue. (http://www.linuxquestions.org/questions/fedora-35/simple-resolution-issue-582414/)

Zombie13 09-05-2007 12:14 PM

Simple (?) resolution issue.
 
Not much of an issue, really...

I have my FC6 box hooked up to my 32" LCD TV. I'm using a desktop resolution of 800x600 so it's easy to see from across the living room. However, the boot-up sequence with the blue border seems to be displaying at a much higher resolution, it's nearly impossible to read the boot messages.

Is this easy to change?

Cheers.

b0uncer 09-05-2007 02:16 PM

It's the (virtual) framebuffer, which is enabled or disabled in your kernel. You can probably change the resolution of the framebuffer by adding a special parameter to your bootloader's kerner line, which tells the kernel to use specific resolution. This depends on your bootloader, but you're probably using GRUB if you're using Fedora Core 6.

If I'm right, the option you pass to the kernel is vga=value where value depends on the resolution you wish to use.

There are surely tables on the web that show all the possible values (which are three-digit values) for different resolutions and colour depths. I think for 800x600 resolution you could use value 788 or 789, so the option would be vga=788 for example.

You can first try this before saving any changes. Reboot your pc, when GRUB pops up you either get it's boot menu or press ESC (when asked to) to see the menu. Select the kernel you wish to boot (default should be selected, so no need to change..) and hit 'e' button to edit the boot lines. Hilight the line that starts with 'kernel' and press 'e' again to edit it. If the line already has a 'vga=something', edit that, or if it doesn't, simply add the 'vga=788' somewhere on the line, separated by spaces. Press enter and hit 'b' button to boot that kernel, and see if it is what you want..

When you want to save that setting, edit your GRUB configuration; become root ('su' in terminal, for example), launch a text editor and edit the file /boot/grub/menu.lst -- in that file locate the line(s) that start with kernel, and either add the vga=788 somewhere in the line, or edit an existing value if needed. Save and exit - that's it.

Zombie13 09-25-2007 07:00 AM

Thanks for the reply. Unfortunately I tried what you said, and it has made no difference at all. Do you have any other ideas I could try?

Cheers.

shafty023 10-04-2007 04:45 PM

Once you have Fedora booted can you read text? Or is it still hard to read?

Zombie13 10-05-2007 04:20 AM

Once I get to the login screen, all the fonts etc are fine, with the display set to 1024x768 or 800x600 (depending how close to the TV I'm sat hehe).

It's just the boot sequence with the blue border that has the tiny font.

shafty023 10-05-2007 09:37 AM

Oh ok, then ya b0uncer was right that it is the framebuffer that is causing the text to be unreadable. I wouldn't imagine that should be too much of an issue.
Here's a good link posted here at linuxquestions.org that explains exactly how to do this. I've realized searching for previous articles is useful as someone has probably already answered what u want to know. Anyways here it is -> http://www.linuxquestions.org/linux/...fer_Resolution


All times are GMT -5. The time now is 08:17 PM.