LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 03-16-2005, 05:56 PM   #1
mreinecker
Member
 
Registered: Mar 2005
Location: New Jersey
Distribution: SuSE Professional 9.2
Posts: 31

Rep: Reputation: 15
Sharing Files...?


I just installed Fedora today for the first time. This is my first experience using Linux. I also have Windows XP on my computer, and I only have one hdd. I have all my music on the partition that Windows is on. Can I simply make a new partition, move the music to this, and access these files while using Fedora ? If not, how can I access my music ? Thanks for the help.
 
Old 03-16-2005, 06:25 PM   #2
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
If Fedora auto-detected your XP partition, you should just be able to point your music player (Xmms etc.) at that partition/directory, and play them from there.

Cheers,

mj
 
Old 03-16-2005, 06:45 PM   #3
mreinecker
Member
 
Registered: Mar 2005
Location: New Jersey
Distribution: SuSE Professional 9.2
Posts: 31

Original Poster
Rep: Reputation: 15
I don't know if Fedora did. If it did, I am unsure of the directory name.
 
Old 03-16-2005, 07:13 PM   #4
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
Check /etc/fstab for an entry that contains an NTFS filesystem at either /dev/hda1 or /dev/hda2 (in a terminal, use less /etc/fstab and press q when finished). If it's there, then just type mount foobar, where foobar is the mount point listed for that partition in /etc/fstab.

Cheers,

mj
 
Old 03-16-2005, 07:37 PM   #5
mreinecker
Member
 
Registered: Mar 2005
Location: New Jersey
Distribution: SuSE Professional 9.2
Posts: 31

Original Poster
Rep: Reputation: 15
I do not see the partition listed. It should be recognized has hda5. If I try and mount hda5 it cannot find it
 
Old 03-16-2005, 08:17 PM   #6
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
If you're sure that it is at /dev/hda5, then you can create a mount point and moint it as follows:
Code:
mkdir /windows                 # as root
mount -t ntfs /dev/hda5 /windows
If this all goes according to plan, then add a line to /etc/fstab to have it done automatically - something like /dev/hda5 /windows ntfs ro,user,auto 0 0 should do the trick.

If you aren't sure that it's /dev/hda5, then run (as root) fdisk -l /dev/hda and look for the NTFS entry. Another potential, but hopefully unlikely problem is lack of support for NTFS in your current kernel. If it complains about not being able to understand this 'NTFS thang', then you may wish to try running insmod ntfs, on the off-chance that there's a module ready to be installed for it.

Cheers,

mj

Last edited by mjrich; 03-16-2005 at 08:21 PM.
 
Old 03-16-2005, 08:49 PM   #7
mreinecker
Member
 
Registered: Mar 2005
Location: New Jersey
Distribution: SuSE Professional 9.2
Posts: 31

Original Poster
Rep: Reputation: 15
Thanks, that did the trick. I have the partition mounted, however I am unclear on how to have it done automaticly. Could you please explain further on how to do this ? I appreciate the help.

Also, how do I enable users to view this drive and use and play the music on it ? I'm not having much luck.

Last edited by mreinecker; 03-16-2005 at 09:08 PM.
 
Old 03-16-2005, 09:54 PM   #8
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
If you have the option auto included in /etc/fstab, it should be mounted at boot time along with your other partitions. The 'user' option allows an ordinary user to mount and unmount the partition, which can be changed to 'users' to allow any user to mount/unmount. You may also need to add the umask option, e.g. umask=0222 (after auto) to ensure that the permissions are correct.

Cheers,

mj
 
Old 03-17-2005, 06:07 AM   #9
mreinecker
Member
 
Registered: Mar 2005
Location: New Jersey
Distribution: SuSE Professional 9.2
Posts: 31

Original Poster
Rep: Reputation: 15
How do I add these options and access /etc/fstab?


Thanks.
 
Old 03-17-2005, 12:59 PM   #10
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
Quote:
How do I add these options and access /etc/fstab?
Just edit the file as root (download a cheatsheet for Vim from www.vim.org or http://www.linuxquestions.org/questi...icle&artid=245, or use any console-based text editor) and change the line for /dev/hda5 (or add it if it's not there) to
Code:
/dev/hda5     /windows     ntfs     ro,users,auto,umask=0222     0     0
Make sure that you have the mount point /windows still exists, then type mount /windows into a console - it should mount automatically for you next time you reboot - this is just for the first time. You can also now create a shortcut on the desktop, by right clicking on the desktop, and (depending on which window manager or desktop environment you're using) selecting Create New -> Device -> Hard Disk Device, and then select /dev/hda5 from the drop-down list under devices, giving it a name, icon, etc. etc.

Cheers,

mj
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sharing files onelung02 Slackware 14 06-08-2005 12:04 PM
mandrake 10.1 sharing files and internet sharing xfiles_arram Linux - Networking 0 05-21-2005 02:22 PM
sharing files gazza Mandriva 4 09-06-2004 12:28 PM
sharing files ridha Linux - Networking 1 02-01-2003 10:18 AM
Sharing Files in C++ Gaz Programming 0 03-25-2001 07:40 AM


All times are GMT -5. The time now is 08:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration