LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 10-10-2007, 03:58 PM   #1
scott.anderson
Member
 
Registered: Mar 2005
Location: Natick, MA
Distribution: Redhat EL 5.2, Fedora 8
Posts: 30

Rep: Reputation: 15
setting 1440x900 screen resolution in F7 with Intel 946GZ chipset


We have a Lenovo with a L192 widescreen monitor. The specs for the monitor say that its optimum resolution is 1440x900:

http://www-307.ibm.com/pc/support/si...cid=MIGR-65756

We installed Fedora 7 and that resolution was automatically chosen by the installer. However, when we run the software, the screen has a 2-inch wide black vertical band at the left and the fonts look a little fuzzy. So, it seems that something has gone wrong in specifying the resolution.

We tried using 915resolution as follows:

# 915resolution 3c 1440 900

and nothing changed. We think we changed the /etc/X11/xorg.conf file correctly:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1440x900"
EndSubSection
EndSection

Nothing changed.

Any suggestions of how to fix it?

Thanks,

Scott
 
Old 10-10-2007, 05:26 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
You could try using the gtf program to generate your own modeline.
Code:
gtf 1440 900 60 -x
Insert the modeline in the Monitor section. I've had better look changing the name from "1440x900_60.00" to "1440x900_60". I don't know why but the ".00" seems to confuse X11. Change the Modes to "1440x900_60". I used 60hz for this example. You may change that.

It might be a bad setting for the vertical or horizontal frequencies as well. Make sure you have the correct monitor selected.

Sometimes you can find suggested settings searching on google with the exact model number in the search. Some people will have a website containing there complete setup. This can be handy.
For example, maybe this link can help:
http://ubuntuforums.org/archive/index.php/t-494417.html

You might want to post the "Monitor" section. Someone with the same computer may spot a difference. ( Is this a laptop LCD display? I though Lenova made Laptops. )

Last edited by jschiwal; 10-10-2007 at 05:28 PM.
 
Old 10-11-2007, 04:04 PM   #3
scott.anderson
Member
 
Registered: Mar 2005
Location: Natick, MA
Distribution: Redhat EL 5.2, Fedora 8
Posts: 30

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jschiwal View Post
You could try using the gtf program to generate your own modeline.
Code:
gtf 1440 900 60 -x
Insert the modeline in the Monitor section. I've had better look changing the name from "1440x900_60.00" to "1440x900_60". I don't know why but the ".00" seems to confuse X11. Change the Modes to "1440x900_60". I used 60hz for this example. You may change that.

You might want to post the "Monitor" section. Someone with the same computer may spot a difference. ( Is this a laptop LCD display? I though Lenova made Laptops. )
Thanks for your suggestions. The original xorg.conf file was pretty terse; I guess a lot of things default nowadays. Here's what I have currently:

Code:
# Xorg configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "intel"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
  	   	Modes "1440x900_60" "1280x1024_76"
	EndSubSection
EndSection

Section "Monitor"
    Identifier  "Monitor0"
# === mode lines based on GTF ===
# 1440x900 @ 60.00 Hz (GTF) hsync: 55.92 kHz; pclk: 106.47 MHz
Modeline "1440x900_60"  106.47  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync
# 1280x1024 @ 76.00 Hz (GTF) hsync: 81.32 kHz; pclk: 141.82 MHz
Modeline "1280x1024_76"  141.82  1280 1376 1512 1744  1024 1025 1028 1070  -HSync +Vsync

EndSection
I logged out (that restarts the X11 server, right) and found it made no difference. I'm pretty sure it's reading the xorg.conf file, because the first time I had some syntax error and it complained about that.


I have some other data that may prove helpful: I used System>Preferences>Hardware>Screen Resolution to try all the available screen resolutions. *all* of them, except for the 1440x900@60 option, used the full width of the screen. However, every one of the full-screen resolutions also ended up slightly distorted. For example, a circle comes out looking like a short and fat oval: squashed in the vertical and stretched in the horizontal. The resolutions were:

1280x1024@70
1152x864@75
1024x768@75
832x624@75
800x600@75
640x480@75

Of course, all of these have an aspect ratio of 4:3, which is the aspect ratio of a standard TV, not a wide-screen. The 1440x900 resolution is an aspect ratio of 1.6, so it's not surprising that it should be different.

The 1440x900@60 option continues to have the black band of unused pixels, and on that resolution circles look oval in the other direction: narrow and tall.

Interestingly, I left the machine with the 1280x1024@70 resolution, and when I logout, it returns to 1440x900 with the black band, but when I login it switches to 1280x1024. Is that because the resolution is a personal setting for root?

Any other ideas? I really appreciate the help.

Scott

PS: to answer your other question, Lenovo does make desktops as well as laptops. This model is a ThinkCentre M55e.

Last edited by scott.anderson; 10-11-2007 at 04:24 PM. Reason: provide computer model
 
Old 10-11-2007, 04:32 PM   #4
shafty023
Member
 
Registered: Oct 2007
Distribution: OSX
Posts: 248

Rep: Reputation: 31
I have a widescreen LCD at home capable of running 1680x1050 resolution and have had no problem getting it to work.
I didn't have to specify the refresh rate like you are doing either. I did notice you are not specifying your monitor in xorg.conf . How come? This will lead your monitor to be detected as generic and you won't be able to specify extended resolutions.
Add a section like this

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "whatever your model is"
HorizSync 31.0 - 107.0
VertRefresh 56.0 - 75.0
Option "dpms"
EndSection

Please find the SPECIFIC HorizSync & VertRefresh for your EXACT monitor. Do not use the values I have above. Let me say that again, DO NOT COPY/PASTE what I wrote above as it will probably not work and could damage your monitor. Use google to find the values for the model # of your monitor
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Resolution will not go beyond 800x600 (Intel chipset) Rhino25782 Linux - Laptop and Netbook 9 04-03-2008 05:54 AM
intel 946GZ drivers logicalfuzz Linux - Hardware 4 07-21-2007 03:20 AM
intel 946gz video problem with sax2 chuckbuhler Linux - Hardware 2 04-23-2007 09:26 PM
Resolution issues - Dell D620 Intel 945 chipset dkinfl Linux - Hardware 18 04-12-2007 04:13 PM
Intel 845 Chipset setting screen resolution sankarram Linux - Newbie 2 02-18-2005 12:14 PM


All times are GMT -5. The time now is 07:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration