LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-30-2007, 08:31 AM   #1
wayno
Member
 
Registered: May 2007
Location: Brisbane, Australia
Distribution: Fedora 8/9, Xandros (eeepc)
Posts: 110
Blog Entries: 1

Rep: Reputation: 15
Samba server did not respond after 20000 milliseconds


I'm tearing my hair out here and need some help. I recently built a new Fedora 8 box on an old Dell that was previously running FC5. I have a second hard disk mounted under /mnt/store that holds all my pictures, music, videos, etc and I have an NFS mount point on /mnt/store that I connect to from 2 other Fedora boxes and also need to share Pictures, Music & Videos folders underneath /mnt/store for a couple of Windows boxes. This configuration was working fine in FC5. I made sure I punched a hole in the firewall but just for good measure I disabled iptables and selinux. Whenever I try to connect to the server (that is, either directly to a share or just to the server to list shares), I just get timeouts. On Linux when running:
Code:
smbclient -L <server>
the response I get is
Code:
Receiving SMB: Server stopped responding
session setup failed: Call timed out: server did not respond after 20000 milliseconds
Here is my (mostly default) config file:
Code:
[global]
        workgroup = mooreinn
        server string = Fedora Samba Server
        hosts allow = 192.168.2. 127.
        printcap name = /etc/printcap
        cups options = raw
        log file = /var/log/samba/%m.log
        max log size = 50
        security = user
         username map = /etc/samba/smbusers
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        domain master = yes
       preferred master = yes
        dns proxy = no
        username map = /etc/samba/smbusers
        oplocks = true
        kernel oplocks = true
        level2 oplocks = true
[homes]
        comment = Home Directories
        browseable = no
        writeable = yes
[Profiles]
        path = /home/profiles
        browseable = no
[printers]
        comment = All Printers
        path = /var/spool/samba
        browseable = yes
        printing = cups
        writeable = yes
        printable = yes
        use client driver = yes
[Pictures]
        comment = Our Pictures
        path = /mnt/store/Pictures
        writeable = yes
        browseable = yes
        valid users = user1,user2
[Music]
        comment = Our Music
        path = /mnt/store/Music
        writeable = yes
        browseable = yes
        valid users = user1,user2
[Videos]
        comment = Our Videos
        path = /mnt/store/Videos
        writeable = yes
        browseable = yes
        valid users = user1,user2
[Database]
        comment = Database Folder
        path = /mnt/store/Database
        writeable = yes
        browseable = yes
        valid users = user1,user2
[Backup]
        comment = PC Backup
        path = /mnt/store/backup
        writeable = yes
        browseable = yes
        valid users = user1,user2
I've searched and searched looking for an answer to this but all I've managed to find is people asking the same question. I'm using Fedora 8 (2.6.23.1-42.fc8) and Samba 3.0.27a-0.fc8. Client is either Samba 3.0.27a-0.fc8 or Windows XP SP2. The Samba logs tell me absolutely nothing other than when the service started. From the F8 machine I'm trying to use as a client, I can successfully connect to shares on the Windows boxes so I'm happy the client does actually work. I've created users and set passwords via system-config-samba and smbpasswd. I've tried the client with name and IP with the same result (I'm happy name resolution works in my network anyway). I have tried stopping NFS because I heard there can be conflicts but had the same result.

Any ideas? Am I missing something really obvious?
 
Old 11-30-2007, 09:55 AM   #2
David1357
Senior Member
 
Registered: Aug 2007
Location: South Carolina, U.S.A.
Distribution: Ubuntu, Fedora Core, Red Hat, SUSE, Gentoo, DSL, coLinux, uClinux
Posts: 1,302
Blog Entries: 1

Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by wayno View Post
Any ideas? Am I missing something really obvious?
Is the samba service started?

# chkconfig --list | grep smb
 
Old 11-30-2007, 10:42 AM   #3
Slick666
Member
 
Registered: Feb 2006
Distribution: Ubuntu 8.04; Debian Etch
Posts: 167

Rep: Reputation: 33
You shoudl try the command "testparm". This will check your samba configuration and hopefully provide some feedback as to possible errors. Also remember to restart the deamon after you've made changes.
 
Old 11-30-2007, 08:11 PM   #4
kjuergen
Member
 
Registered: May 2007
Location: AZ, USA
Distribution: CentOS5, Kubuntu 10.04
Posts: 38

Rep: Reputation: 16
Same problem here with Samba/FC8. Now I have a 90% useless server and I hope that there will be a solution I can follow.....

Juergen
 
Old 12-01-2007, 05:04 AM   #5
wayno
Member
 
Registered: May 2007
Location: Brisbane, Australia
Distribution: Fedora 8/9, Xandros (eeepc)
Posts: 110
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by David1357 View Post
Is the samba service started?

# chkconfig --list | grep smb
I know I said obvious but ......

Yes, the service is definitely running.
 
Old 12-01-2007, 05:07 AM   #6
wayno
Member
 
Registered: May 2007
Location: Brisbane, Australia
Distribution: Fedora 8/9, Xandros (eeepc)
Posts: 110
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Slick666 View Post
You shoudl try the command "testparm". This will check your samba configuration and hopefully provide some feedback as to possible errors. Also remember to restart the deamon after you've made changes.
I've seen reference to this before but the command doesn't exist on my system. I installed Samba with the base F8 install and have since upgraded it with Yum.
 
Old 12-01-2007, 10:09 AM   #7
wayno
Member
 
Registered: May 2007
Location: Brisbane, Australia
Distribution: Fedora 8/9, Xandros (eeepc)
Posts: 110
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Well apparently the problem is with encrypted passwords. I set
Code:
encrypt passwords = no
and it all sprang into life. I felt sure I had tried this previously but maybe I missed it.
 
Old 12-01-2007, 12:50 PM   #8
David1357
Senior Member
 
Registered: Aug 2007
Location: South Carolina, U.S.A.
Distribution: Ubuntu, Fedora Core, Red Hat, SUSE, Gentoo, DSL, coLinux, uClinux
Posts: 1,302
Blog Entries: 1

Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by wayno View Post
I know I said obvious but ......

Yes, the service is definitely running.
If it is running, then you should see some good messages in the output from dmesg. There should also be interesting messages in the log files in "/var/log". Files of interest are "messages" and "samba/smbd.log".

You can also stop the samba daemon and run it interactively with "-i" and with a debug level "-d". That is probably the easiest way to debug problems with a samba server.
 
Old 12-01-2007, 12:53 PM   #9
David1357
Senior Member
 
Registered: Aug 2007
Location: South Carolina, U.S.A.
Distribution: Ubuntu, Fedora Core, Red Hat, SUSE, Gentoo, DSL, coLinux, uClinux
Posts: 1,302
Blog Entries: 1

Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by wayno View Post
Well apparently the problem is with encrypted passwords. I set
Code:
encrypt passwords = no
and it all sprang into life. I felt sure I had tried this previously but maybe I missed it.
I am running samba on FC4 with "encrypt passwords" set to "yes". You may want to try the debugging suggestions I mentioned above before you give up on this option. Otherwise you are just masking the real problem by giving up a layer of security.
 
Old 12-02-2007, 12:26 AM   #10
wayno
Member
 
Registered: May 2007
Location: Brisbane, Australia
Distribution: Fedora 8/9, Xandros (eeepc)
Posts: 110
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by David1357 View Post
I am running samba on FC4 with "encrypt passwords" set to "yes". You may want to try the debugging suggestions I mentioned above before you give up on this option. Otherwise you are just masking the real problem by giving up a layer of security.
Thanks I will give that a go and see what I get.
 
  


Reply

Tags
samba, smbclient, timeout


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftp server doesn't respond to NLST y2kram Linux - Networking 1 06-27-2007 01:34 PM
blocking port no 20000 gadekishore Linux - Networking 2 02-19-2006 01:34 AM
my system wont respond when i exit x server linuxnewb1984 Fedora 3 01-22-2006 12:51 AM
Qmail smtp server does not respond kmashraf Linux - Networking 3 02-25-2005 12:51 PM
Can't get my http server to respond to requests... garydamm Linux - Networking 9 01-16-2005 10:00 AM


All times are GMT -5. The time now is 03:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration