LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 08-21-2007, 08:02 AM   #1
cbraidwo
LQ Newbie
 
Registered: Aug 2007
Posts: 7

Rep: Reputation: 0
Samba Installation/Configuration


I have a new Fedora 7 installation (my first attempt at Linux). I installed Samba to set up some shares, but the configuration menu option doesn't show up at Adminitration->Server Settings, or anywhere else that I can find. Is this an issue with the Samba installation, something to be concerned about, or just something to work around? Thanks for the help.
 
Old 08-21-2007, 08:05 AM   #2
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
you can use swat to configure your samba
or just modify the /etc/samba/smb.conf for your needs.
But don't froget to adjust seLinux so that samba shares will work.

BTW what you're looking for is probably not installed. system-config-samba or similar.
 
Old 08-21-2007, 09:38 AM   #3
cbraidwo
LQ Newbie
 
Registered: Aug 2007
Posts: 7

Original Poster
Rep: Reputation: 0
I know I can use SWAT or the command line, but until I know more about what I'm doing I would rather have one more tool to work with. I'm pretty sure system-config-samba is installed, but I'll check to make sure tonight. Figuring out how to adjust SELinux is also on the slate for tonight. Thanks for the help.
 
Old 08-21-2007, 04:21 PM   #4
cbraidwo
LQ Newbie
 
Registered: Aug 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Well, I've checked, and system-config-samba is installed. I used yum to remove and reinstall it, and it still doesn't show up on the menu. Annoying.
 
Old 08-22-2007, 09:52 AM   #5
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
never the less - do you use gnome or kde?
Issue ALT+F2 and enter system-config-samba then it will show up.
 
Old 08-22-2007, 11:04 AM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
You could run "kdesu /usr/bin/system-config-samba" from the shell.

There is some documentation on using the tool available in:
/usr/share/doc/system-config-samba-1.2.35/index.html

The samba package also supplies the online Samba 3 series of books such as "Samba 3 by Example".

Last edited by jschiwal; 08-22-2007 at 11:10 AM.
 
Old 08-22-2007, 02:33 PM   #7
cuda
Member
 
Registered: Jan 2007
Posts: 43

Rep: Reputation: 15
odcheck run to the hills
 
Old 08-22-2007, 04:52 PM   #8
cbraidwo
LQ Newbie
 
Registered: Aug 2007
Posts: 7

Original Poster
Rep: Reputation: 0
I'm using gnome at the moment - should I switch to kde?? This is all pretty new to me, at this point in time I would have nothing to unlearn if there's a good reason to switch.
 
Old 08-23-2007, 01:18 AM   #9
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
No you don't have to switch and it isn't a good reason or a final soloution.
What happend when you tried
Quote:
Issue ALT+F2 and enter system-config-samba then it will show up
??



@cuda
Run to the Hills,
run for yours life
...
We fought him hard we fought him well
Out on the plains we gave him hell
 
Old 08-23-2007, 10:45 AM   #10
cbraidwo
LQ Newbie
 
Registered: Aug 2007
Posts: 7

Original Poster
Rep: Reputation: 0
Nothing. ALT+F2 did nothing. I was able to run system-config-samba from the command line in a system window though.
 
Old 08-24-2007, 05:29 AM   #11
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
fine

so don't know why it isn't in your menu bar
but btw I crashed my menu bar also all over....
then I added everything again
 
Old 08-24-2007, 06:34 AM   #12
cbraidwo
LQ Newbie
 
Registered: Aug 2007
Posts: 7

Original Poster
Rep: Reputation: 0
I guess I'll just need to add it manually. Running it from the command prompt isn't a big deal, but it's not as convenient. In any case, my samba shares are working just fine.

Now if I can just figure out how to get ushare working with my firewall enabled I'll be getting somewhere.
 
  


Reply

Tags
configuration, fedora, samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation of Binutils(configure:error:installation or configuration problem:C ...) h_r0019 Linux From Scratch 1 05-05-2007 07:40 AM
samba configuration paul62 Linspire/Freespire 6 11-28-2006 11:16 AM
SAMBA configuration nawin_g Linux - Networking 9 11-08-2005 03:23 PM
Samba installation and configuration LinuxGuru707 Linux - Networking 1 08-13-2004 01:18 PM
samba configuration pantera Red Hat 1 06-24-2004 06:52 PM


All times are GMT -5. The time now is 04:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration