LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 04-14-2004, 03:52 AM   #1
Joe47
Member
 
Registered: Dec 2002
Location: San Diego California
Distribution: Fedora Core 6
Posts: 64

Rep: Reputation: 15
Rythmbox 0.5.4 problems


When I try to play ogg or mp3 under Rythmbox 0.5.4, I get
the following error: osscommon: Unable to open /dev/dsp (in use?)
Any help would be appreciated. Thanks
 
Old 04-17-2004, 03:56 PM   #2
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
first of all, rhythmbox cannot play mp3 unless you have installed a patched version. mp3 support has been removed since Red Hat Linux 8.0 due to patenting and licencing issues.

* Is your soundcard configured? redhat-config-soundcard

* Are the audio driver kernel modules loaded? /sbin/lsmod

* Check the ownership and permissions of /dev/dsp. ll /dev/dsp

* Make sure you don't have a sound server (esd in GNOME, artsd in KDE) running, which blocks the device.

* Try a different player, e.g. xmms -- get xmms-mp3 from ftp://ftp.uninett.no/pub/linux/Fedor.../rpm.livna.org
 
Old 05-11-2004, 03:02 PM   #3
fluky
LQ Newbie
 
Registered: May 2004
Location: Trondheim, Norway
Distribution: debian
Posts: 1

Rep: Reputation: 0
kill esd

Hi,

I had this problem this morning after reinstalling debian, and it seemed that an other process did use /dev/dsp. Try
$lsof | grep dsp

and kill the process using dsp. This worked for me(esd was using it). Now mplayer seems to run fine as well
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iPod Nano Music Player/Rythmbox Sync Problem mrbadboy Linux - Hardware 1 09-22-2005 11:54 AM
Rythmbox driver problem Toxodont Linux - Software 2 02-18-2005 11:15 AM
Problems with OSS while trying to avoid problems in ALSA (scratchy sound) GT_Onizuka Linux - General 1 02-06-2004 12:55 AM
Problems, problems, problems. Lets start with the soundcard Kre8ive Linux - Newbie 5 08-07-2003 02:20 AM
Problems, problems, problems. Lets start with the ES 1868 AudioDrive Kre8ive Linux - Newbie 1 08-06-2003 08:04 PM


All times are GMT -5. The time now is 12:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration