LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 06-06-2006, 06:54 AM   #1
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,426

Rep: Reputation: 53
Running Yum update problem


Hi folks,

FC5

On running
# yum update

following error resulted
Code:
....
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution-sharp
Error: Missing Dependency: libecal-1.2.so.3 is needed by package gnome-panel
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution-webcal
Please advise whether to install the package to satisfy the dependencies OR wait for the website to get it fixed? TIA

B.R.
satimis
 
Old 06-06-2006, 07:23 AM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
It could be that the mirror you are using is not yet fully synced. Try updating later and if you keep having the same problem, try "yum upgrade" instead of "yum update".
 
Old 06-06-2006, 08:47 AM   #3
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,150

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Those messages are, in my experience, more common when an application specifies a specific library version rather than a version "no less than" some value, and the upgrade is going to increase the version number. Since the upgrade will delete the older version, the message you see is generated by YUM.

I usually delete the applications and reinstall them, but you might be able to install the newer library without deleting the older one. Then the upgrade might not complain. (I've never tried this approach, so I can't, in fact, recommend it.)
 
Old 06-06-2006, 09:52 AM   #4
noxious
Member
 
Registered: May 2004
Location: Ohio, USA
Distribution: LinuxMint Gloria, Ubuntu 9.10
Posts: 299

Rep: Reputation: 30
Same problem here... I updated the rest of the packages one-by-one, and left evolution and gnome-panel to wait for a resolution to libecal-1.2.so.3.

I knew fedora would break itself - it always does.
 
Old 06-06-2006, 04:49 PM   #5
zeitounator
Member
 
Registered: Aug 2003
Location: Montpellier, France, Europe, World, Solar System
Distribution: Debian Sarge, Fedora core 5 (i386 and x86_64)
Posts: 262

Rep: Reputation: 30
while waiting for a fix, a solution there: http://www.linuxquestions.org/questi...d.php?t=452199
 
Old 06-06-2006, 05:15 PM   #6
Crito
Senior Member
 
Registered: Nov 2003
Location: Knoxville, TN
Distribution: Kubuntu 9.04
Posts: 1,168

Rep: Reputation: 53
LOL, guess it's not 64-bit related then. They screwed all the packages up.

It's been a long week already...
 
Old 06-08-2006, 01:17 PM   #7
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,150

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
FYI: The problem seems to have been fixed now, with an update to gnome-panel (and some others) being posted.
 
Old 06-09-2006, 05:30 AM   #8
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,426

Original Poster
Rep: Reputation: 53
Hi folks,

FC5_64
======

Tried running "yum update". Still failed.

# yum update
Code:
.....
Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 evolution               x86_64     2.6.2-1.fc5.5    updates            12 M
 evolution-data-server   x86_64     1.6.2-1.fc5.1    updates           4.2 M
 evolution-data-server-devel  x86_64     1.6.2-1.fc5.1    updates           474 k
 evolution-sharp         x86_64     0.10.2-9.3       updates           147 k
 evolution-webcal        x86_64     2.4.1-3.4        updates            78 k
 gdm                     x86_64     1:2.14.4-1.fc5.3  updates           3.6 M
 gnome-panel             x86_64     2.14.2-1.fc5.1   updates           3.1 M
 gnome-panel-devel       x86_64     2.14.2-1.fc5.1   updates            50 k
 gthumb                  x86_64     2.7.7-1          updates           1.9 M
 mc                      x86_64     1:4.6.1a-13.FC5  updates           2.1 M
 pam                     i386       0.99.4.0-fc5.4   updates           930 k
 pam                     x86_64     0.99.4.0-fc5.4   updates           927 k
 pam-devel               i386       0.99.4.0-fc5.4   updates            90 k
 pam-devel               x86_64     0.99.4.0-fc5.4   updates            90 k
 planner                 x86_64     0.13-4.4         updates           2.1 M

Transaction Summary
=============================================================================
Install      0 Package(s)
Update      15 Package(s)
Remove       0 Package(s)
Total download size: 32 M
Is this ok [y/N]: y
Downloading Packages:
.....
........
Running Transaction Test
Finished Transaction Test


Transaction Check Error:   file /etc/gconf/schemas/gthumb.schemas from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/bin/gthumb from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/lib64/bonobo/servers/GNOME_GThumb.server from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/lib64/bonobo/servers/GNOME_GThumb_CatalogView.server from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/lib64/bonobo/servers/GNOME_GThumb_Viewer.server from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/lib64/gthumb/libgthumb.la from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/lib64/gthumb/libgthumb.so from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/lib64/gthumb/modules/libduplicates.so from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/lib64/gthumb/modules/libjpegtran.so from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/lib64/gthumb/modules/libphotoimporter.so from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/lib64/gthumb/modules/libpngexporter.so from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/lib64/gthumb/modules/libsearch.so from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/lib64/gthumb/modules/libwebexporter.so from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/libexec/gthumb-catalog-view from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/libexec/gthumb-image-viewer from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/share/applications/gthumb.desktop from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/share/gnome/help/gthumb/C/gthumb.xml from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/share/gthumb/albumthemes/Classic/thumbnail.gthtml from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/share/gthumb/albumthemes/ClassicClips/thumbnail.gthtml from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/share/gthumb/albumthemes/NeatRound/layout.css from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
  file /usr/share/gthumb/albumthemes/NeatRound/thumbnail.gthtml from install of gthumb-2.7.7-1 conflicts with file from package gthumb-2.7.5.1-1.fc5.1
B.R.
satimis
 
Old 06-09-2006, 05:44 AM   #9
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Try
Code:
#yum remove gthumb
#yum upgrade
#yum install gthumb
 
Old 06-09-2006, 08:46 AM   #10
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,426

Original Poster
Rep: Reputation: 53
Hi reddazz,

Tks for your advice. It worked for me.

Quote:
Try
Code:
#yum remove gthumb
#yum upgrade
#yum install gthumb
# yum remove gthumb
Code:
...
....
Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Removing:
 gthumb                  x86_64     2.7.5.1-1.fc5.1  installed         5.7 M
Removing for dependencies:
 gnome-session           x86_64     2.14.2-1         installed         1.4 M
 gnome-volume-manager    x86_64     1.5.15-1         installed         1.7 M

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       3 Package(s)
3 packages removed.

Then ran;
# yum install gthumb

Problem solved. Tks.

B.R.
satimis
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with yum update rickronn Linux - Distributions 2 03-26-2006 07:55 PM
Yum update problem DanielTan Linux - General 2 09-28-2005 03:43 AM
yum update problem hraposo Fedora 2 08-29-2004 01:43 PM
yum update problem disorderly Fedora 4 08-19-2004 02:00 PM
Running yum asks for "sysadmin to update headers" Equisilus Fedora 0 06-25-2004 04:52 PM


All times are GMT -5. The time now is 02:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration