LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Resolution and refresh rate (http://www.linuxquestions.org/questions/fedora-35/resolution-and-refresh-rate-587842/)

phantom_cyph 09-27-2007 05:36 PM

Resolution and refresh rate
 
So...my highest resolution is 800x600, and I can only go to 60Hz. Now, I thought I could use the command in Debian based OSs, but it doesn't recognize "dpkg-reconfigure xserver-xorg". So...how do I do it? I've looked at other threads, but many are unhelpful (they say its already been answered, no link), and the search doesn't work well with 2 words.

phantom_cyph 09-28-2007 05:36 AM

I didn't realize it was this difficult...

mdg 09-28-2007 08:46 AM

Post your xorg.conf file - especially the "monitor" and "modes" sections.

What is the max. resolution and refresh rate of your monitor?

phantom_cyph 09-28-2007 11:38 AM

Can't post it right now (I'm at school). However, my monitor is new, and can have a resolution 1600x1200 and a refresh rate of 85Hz. I opened my xorg.conf file, but it didn't show the possible resolutions, not even the 800x600.

mdg 09-28-2007 12:19 PM

This is an example of the relevant sections in xorg.conf. I don't use Fedora, but I'm pretty sure it's the same across the board. You would substitute the refresh rates specified for your monitor according to the manufacturer.

Code:

Section "Monitor"
        Identifier        "Monitor1"
        Option                "DPMS"
          HorizSync      30.0 - 81.0
          VertRefresh    56.0 - 75.0
 EndSection


Section "Screen"
        Identifier        "Default Screen"
        Device                "nVidia"
        Monitor                "Monitor1"
        DefaultDepth        24
        SubSection "Display"
                Depth                16
                Modes                "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
        SubSection "Display"
                Depth                24
                Modes                "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
        EndSubSection
EndSection


phantom_cyph 09-28-2007 03:02 PM

Here is what mine looks like:

Quote:

# Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection


mdg 09-28-2007 03:28 PM

After backing up xorg.conf, try adding a modeline for default depth 24 so your "Screen" section looks like this:
Code:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor        "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes        "1600x1200" "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Also, add a "Monitor" section and substitute the HorizSync and VertRefresh values in the example below with your screen's refresh rates:
Code:

Section "Monitor"
        Identifier        "Monitor0"
          HorizSync      30.0 - 81.0
          VertRefresh    56.0 - 75.0
 EndSection


phantom_cyph 09-28-2007 04:20 PM

HELP!! I copied the resolutions you have set, but I think my monitor only likes 1024x768 as the highest, so 1600x1200 is too high, and my monitor is not liking it. It didn't revert to a lower resolution so I can edit anything. Right not I'm in Knoppix but it doesn't read my hdd, only 2 drives that are 703bytes. I left the copy of the xorg.conf file on my desktop but I can't get to it.

pixellany 09-28-2007 04:42 PM

You can get to the config files by simply booting into single-user mode. When the GRUB menu comes up, hit any key to stop the countdown, then "e" for edit (or maybe first "c" for a command prompt.) Edit the kernel line, adding "single" at the end (no quotes). This will boot you into a terminal mode with root powers.

Before editing xorg.conf again, double-check your monitor specs. If in doubt, start with a moderate resolution and then keep trying higher until you find the sweet spot.

phantom_cyph 09-28-2007 09:26 PM

Thanks! It worked! (of course). Now I just have the resolution I want and one lower in here, and it looks great!


All times are GMT -5. The time now is 05:06 PM.