LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   RE: Fedora Core 5.0 (the whole story) (http://www.linuxquestions.org/questions/fedora-35/re-fedora-core-5-0-the-whole-story-457971/)

gtoman 06-24-2006 06:32 PM

RE: Fedora Core 5.0 (the whole story)
 
I have an emachines T6528 that came with XP Home. I installed another hard drive with Fedora Core 5.0 on it, so, I now have my choice of which hard drive I want to boot into. When I boot into the Fedora hard drive, I can see the cursor during boot up and loading of the OS but when it gets to the login screen, it's not there. I type in my login name and password and it goes to my desktop, but no mouse pointer (cursor). I can move the mouse and when the invisible pointer gets to a menu bar icon, or a desktop icon, the icon will highlite and I can open the program. So all it does is highlite a program icon after I hunt and find it. My graphics came embedded into the motherboard, no video card. it's nVidea GeForce 6100 GPU with available PCI-Express slot. When I right click the mouse, on the desktop, it does bring up a menu, so that works.

So, per another technical help answer I got, he says to go into the Terminal program, so I did, and here's what it shows:

When I first enter the Terminal program, at the jim/localhost$ (I think thats what it shows) command prompt, I type vi etc/X11/xorg.conf ,and then that page opens. Then I push the INSERT key and the word INSERT appears at the bottom of the page.
Where the cursor (or the black rectangle) is at the top of the page I typed this:
---- xorg.conf ----
Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "nVidia Corporation C51 PCI Express Bridge"
##fehlender cursor, hwcursor off rhb#182517
Option "HWCursor" "off"
EndSection

(I indented some of the paths above but it doesn't show anything indented in this message after I submit it)

So then I push the Shift key (for the plus sign) and type +:wq! which is supposed to save the changes that have been done? (so i've been told).
I did that and then when i open the File column to Save and then Close the program to reboot the pc, there is no SAVE option in it, it only has CLOSE, so how do you know if the changes that were made in the Terminal program have been SAVED or not, because everytime I reboot the PC I still never get a pointer (cursor) when it gets to the desktop so it doesn't look like it has accepted the changes that I have made.
Please tell me if i'm doing this correctly or not. PLEASE show me exactly what I need to type and if the spacing between words and symbols is correct because I know that everything has to be typed EXACTLY right or the program won't accept it.
I appreciate your help,
Thanks, Jim

burntfuse 06-24-2006 08:48 PM

I don't know what's wrong with your cursor, but I do know that you don't have to save the changes you've made in the terminal - it would be like saving the changes you've made in the GUI before rebooting. ;)

terracotta 06-25-2006 03:11 AM

I don't know why your cursor is invisible either, but a couple of suggestions.

There's a utility in the GUI to change the cursor-pointer, and you can get to it without having to use the mouse. I have no idea whether changing the pointer will get you a visible one, but it's worth a try. Alt-F1 will drop down the applications menu. Slide along to System with the arrow keys, then down to Preferences, and thence to Mouse. Open the Mouse Window with ENTER. Select the Pointers tab with the right arrow key, and select a pointer. Close the window with Alt-C and reboot.

If you need to edit config files you might find gedit to be an easier text editor to use than vi. Hardened Linux users might sneer at gedit, but it's a helluva lot more user-friendly and more than adequate for straightforward edit jobs. Although it's a GUI app it can be launched from a terminal, and although the lack of a mouse pointer will be awkward, you can do everything from the drop-down menus with the usual keyboard shortcuts.

Oh yes, and if you've saved your changes in vi or gedit, there's nothing more to save when you exit the terminal. ;)

Edit: The $ prompt you quote suggests that you are not in a root terminal. You will not be able to save your changes unless you have su'd to root. Then you get a # prompt. I have little experience of vi, so maybe it's not telling you in an obvious way that it's not saving your changes.

And just found the invisible pointer thread. So I don't think my first suggestion will help, but I'll leave it in anyway.

BobNutfield 06-25-2006 05:38 AM

Hi

I suspect there is a bug (or possibly a corrupt install) as suggested by the following link:

http://forums.fedoraforum.org/showth...565#post486565

This same link also suggests a fix, which apparently worked in this case.

Hope this helps

Bob

burntfuse 06-25-2006 02:13 PM

If vi can't save a file because of permissions, it should print an error message instead of just exiting, but I'd suggest trying it again as root anyways.


All times are GMT -5. The time now is 07:01 PM.