LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-11-2007, 01:02 PM   #1
benjithegreat98
Senior Member
 
Registered: Dec 2003
Location: Shelbyville, TN, USA
Distribution: Fedora Core, CentOS
Posts: 1,019

Rep: Reputation: 45
Pulse Audio problem in Fedora8


Hello all,

I'm having difficulty with sound in Fedora 8. I installed a few days ago and couldn't get sound to work at all. Tried for hours and nothing. When I did the install I installed a lot of extra fluff. So I eventually gave up and reinstalled last night before I went to bed.

When I woke up this morning, I rebooted and the sound was working with my new install. I was excited and thought the worst was behind me. So I went through my new system routine, installing rpms, removing rpms, personalizing and I rebooted to test if something I did worked. When I did, I found my sound no longer worked again.

I have a log of everything I did as far as installing and removing under yum below.

I tried to uninstall it and see if the system would revert back to alsa, but it didn't so I installed it back.

Does anybody see anything I might have done, rpm wise, that would have borked my sound?

Also, I should not that I can go to the Sound Card Detection program and here sound there, but that is the only place that will play anything. There is an x through my volume control and it won't even let me into it. Pulse audio volume control crashes as soon as I open it.

And besides the option of fixing Pulse, is it possible to revert back to alsa?

Code:
Nov 11 07:59:04 balthasar yum: Erased: libbtctl
Nov 11 07:59:06 balthasar yum: Erased: gnome-bluetooth-libs
Nov 11 07:59:07 balthasar yum: Erased: bluez-libs
Nov 11 07:59:17 balthasar yum: Erased: gnome-phone-manager
Nov 11 07:59:21 balthasar yum: Erased: kdepim-devel
Nov 11 07:59:27 balthasar yum: Erased: kdevelop
Nov 11 08:00:04 balthasar yum: Erased: gnome-bluetooth
Nov 11 08:00:09 balthasar yum: Erased: bluez-utils-alsa
Nov 11 08:00:11 balthasar yum: Erased: gnome-vfs2-obexftp
Nov 11 08:00:15 balthasar yum: Erased: kdepim
Nov 11 08:00:52 balthasar yum: Erased: bluez-utils
Nov 11 08:00:54 balthasar yum: Erased: bluez-utils-cups
Nov 11 08:00:54 balthasar yum: Erased: kdesdk-libs
Nov 11 08:00:56 balthasar yum: Erased: kdesdk
Nov 11 08:01:13 balthasar yum: Erased: bluez-gnome
Nov 11 08:01:17 balthasar yum: Erased: kdepim-libs
Nov 11 08:01:24 balthasar yum: Erased: kdevelop-libs
Nov 11 08:01:27 balthasar yum: Erased: gnokii
Nov 11 08:13:39 balthasar yum: Updated: glib2 - 2.14.3-1.fc8.i386
Nov 11 08:13:48 balthasar yum: Updated: mono-core - 1.2.5.1-3.fc8.i386
Nov 11 08:13:48 balthasar yum: Updated: libattr - 2.4.38-2.fc8.i386
Nov 11 08:13:49 balthasar yum: Updated: libacl - 2.2.39-12.fc8.i386
Nov 11 08:13:50 balthasar yum: Updated: openldap - 2.3.39-1.fc8.i386
Nov 11 08:13:51 balthasar yum: Updated: gimp-libs - 2:2.4.1-1.fc8.i386
Nov 11 08:14:01 balthasar yum: Updated: ruby-libs - 1.8.6.111-1.fc8.i386
Nov 11 08:14:02 balthasar yum: Updated: cups-libs - 1:1.3.4-2.fc8.i386
Nov 11 08:14:04 balthasar yum: Updated: ruby - 1.8.6.111-1.fc8.i386
Nov 11 08:14:05 balthasar yum: Installed: libsexy - 0.1.11-3.fc8.i386
Nov 11 08:14:05 balthasar yum: Installed: python-sexy - 0.1.9-3.fc7.i386
Nov 11 08:14:08 balthasar yum: Updated: nas - 1.9a-3.fc8.i386
Nov 11 08:14:08 balthasar yum: Updated: ustr - 1.0.2-3.fc8.i386
Nov 11 08:14:09 balthasar yum: Updated: libtirpc - 0.1.7-13.fc8.i386
Nov 11 08:14:10 balthasar yum: Updated: jack-audio-connection-kit - 0.103.0-5.fc8.i386
Nov 11 08:14:21 balthasar yum: Updated: cups - 1:1.3.4-2.fc8.i386
Nov 11 08:14:47 balthasar yum: Updated: gimp - 2:2.4.1-1.fc8.i386
Nov 11 08:14:48 balthasar yum: Updated: openldap-clients - 2.3.39-1.fc8.i386
Nov 11 08:14:50 balthasar yum: Updated: tar - 2:1.17-4.fc8.i386
Nov 11 08:14:50 balthasar yum: Updated: acl - 2.2.39-12.fc8.i386
Nov 11 08:14:51 balthasar yum: Updated: attr - 2.4.38-2.fc8.i386
Nov 11 08:14:53 balthasar yum: Updated: nspluginwrapper - 0.9.91.5-12.fc8.i386
Nov 11 08:14:57 balthasar yum: Updated: glib2-devel - 2.14.3-1.fc8.i386
Nov 11 08:14:58 balthasar yum: Updated: cpio - 2.9-5.fc8.i386
Nov 11 08:15:30 balthasar yum: Installed: kernel - 2.6.23.1-49.fc8.i686
Nov 11 08:15:32 balthasar yum: Updated: slrn - 0.9.8.1pl1-5.20070716cvs.fc8.i386
Nov 11 08:15:34 balthasar yum: Updated: mono-data - 1.2.5.1-3.fc8.i386
Nov 11 08:15:35 balthasar yum: Updated: libattr-devel - 2.4.38-2.fc8.i386
Nov 11 08:15:36 balthasar yum: Updated: fedorainfinity-kdm-theme - 1.0.4-1.fc8.noarch
Nov 11 08:15:39 balthasar yum: Updated: selinux-policy - 3.0.8-47.fc8.noarch
Nov 11 08:16:32 balthasar yum: Updated: selinux-policy-targeted - 3.0.8-47.fc8.noarch
Nov 11 08:16:39 balthasar yum: Updated: kde-settings-kdm - 3.5-35.fc8.noarch
Nov 11 08:16:44 balthasar yum: Updated: libacl-devel - 2.2.39-12.fc8.i386
Nov 11 08:16:48 balthasar yum: Updated: mono-data-sqlite - 1.2.5.1-3.fc8.i386
Nov 11 08:16:52 balthasar yum: Updated: codeina - 0.10.1-6.fc8.noarch
Nov 11 08:17:04 balthasar yum: Updated: openldap-devel - 2.3.39-1.fc8.i386
Nov 11 08:17:15 balthasar yum: Updated: tzdata-java - 2007i-1.fc8.noarch
Nov 11 08:17:32 balthasar yum: Updated: fedora-release-notes - 8.0.1-1.noarch
Nov 11 08:17:35 balthasar yum: Updated: kde-settings - 3.5-35.fc8.noarch
Nov 11 08:17:45 balthasar yum: Updated: kernel-headers - 2.6.23.1-49.fc8.i386
Nov 11 08:18:04 balthasar yum: Installed: kernel-devel - 2.6.23.1-49.fc8.i686
Nov 11 08:18:08 balthasar yum: Updated: tzdata - 2007i-1.fc8.noarch
Nov 11 08:18:10 balthasar yum: Installed: kdegraphics-libs - 7:3.5.8-7.fc8.i386
Nov 11 08:18:12 balthasar yum: Updated: mono-winforms - 1.2.5.1-3.fc8.i386
Nov 11 08:18:14 balthasar yum: Updated: mono-web - 1.2.5.1-3.fc8.i386
Nov 11 08:18:35 balthasar yum: Updated: kdegraphics-extras - 7:3.5.8-7.fc8.i386
Nov 11 08:18:47 balthasar yum: Updated: kdegraphics - 7:3.5.8-7.fc8.i386
Nov 11 08:18:50 balthasar yum: Updated: kdegraphics-devel - 7:3.5.8-7.fc8.i386
Nov 11 08:23:14 balthasar yum: Installed: libdvdnav - 0.1.10-4.20070503.lvn8.i386
Nov 11 08:23:15 balthasar yum: Installed: libmp4v2 - 1.5.0.1-5.fc8.i386
Nov 11 08:23:15 balthasar yum: Installed: faac - 1.25-4.lvn8.i386
Nov 11 08:23:16 balthasar yum: Installed: libmad - 0.15.1b-5.lvn8.i386
Nov 11 08:23:17 balthasar yum: Installed: lame-libs - 3.97-6.lvn8.i386
Nov 11 08:23:18 balthasar yum: Installed: imlib2 - 1.4.0-3.fc8.i386
Nov 11 08:23:19 balthasar yum: Installed: a52dec - 0.7.4-11.lvn8.i386
Nov 11 08:23:19 balthasar yum: Installed: libdca - 0.0.5-2.lvn8.i386
Nov 11 08:23:22 balthasar yum: Installed: libvisual-plugins - 0.4.0-4.fc8.i386
Nov 11 08:23:22 balthasar yum: Installed: x264 - 0-0.10.20070819.lvn8.i386
Nov 11 08:23:23 balthasar yum: Installed: xvidcore - 1.1.3-1.lvn8.i386
Nov 11 08:23:24 balthasar yum: Installed: vcdimager - 0.7.23-3.lvn6.i386
Nov 11 08:23:25 balthasar yum: Installed: faad2 - 1:2.0-21.20050131.lvn8.i386
Nov 11 08:23:26 balthasar yum: Installed: ffmpeg-libs - 0.4.9-0.41.20071011.lvn8.i386
Nov 11 08:23:27 balthasar yum: Installed: xine-lib-extras-nonfree - 1.1.8-4.lvn8.i386
Nov 11 08:23:28 balthasar yum: Installed: amarok-visualisation - 1.4.7-7.fc8.i386
Nov 11 08:23:30 balthasar yum: Installed: amarokFS - 0.5-1.fc7.i386
Nov 11 08:23:30 balthasar yum: Installed: amarok-extras-nonfree - 1.4.4-1.lvn7.i386
Nov 11 08:27:09 balthasar yum: Installed: yumex - 2.0.2-1.fc8.noarch
Nov 11 08:32:38 balthasar yum: Installed: compat-gcc-34 - 3.4.6-8.i386
Nov 11 08:32:42 balthasar yum: Installed: compat-libstdc++-33 - 3.2.3-62.i386
Nov 11 08:32:50 balthasar yum: Installed: compat-gcc-34-c++ - 3.4.6-8.i386
Nov 11 08:32:51 balthasar yum: Installed: compat-libstdc++-296 - 2.96-139.i386
Nov 11 08:52:06 balthasar yum: Installed: thunderbird - 2.0.0.6-6.fc8.i386
Nov 11 08:52:19 balthasar yum: Installed: mail-notification - 4.1-4.1.i386
Nov 11 12:36:43 balthasar yum: Erased: pulseaudio-esound-compat
Nov 11 12:36:45 balthasar yum: Erased: pulseaudio-module-x11
Nov 11 12:36:47 balthasar yum: Erased: pulseaudio-utils
Nov 11 12:36:49 balthasar yum: Erased: pulseaudio-module-gconf
Nov 11 12:36:50 balthasar yum: Erased: pulseaudio
Nov 11 12:43:59 balthasar yum: Installed: pulseaudio - 0.9.7-0.17.svn20071017.fc8.i386
Nov 11 12:44:00 balthasar yum: Installed: pavumeter - 0.9.3-0.2.svn20070925.fc8.i386
Nov 11 12:44:00 balthasar yum: Installed: pulseaudio-utils - 0.9.7-0.17.svn20071017.fc8.i386
Nov 11 12:46:43 balthasar yum: Installed: pulseaudio-esound-compat - 0.9.7-0.17.svn20071017.fc8.i386
Nov 11 12:46:44 balthasar yum: Installed: pulseaudio-module-x11 - 0.9.7-0.17.svn20071017.fc8.i386
Nov 11 12:46:45 balthasar yum: Installed: pulseaudio-module-gconf - 0.9.7-0.17.svn20071017.fc8.i386

Last edited by benjithegreat98; 11-11-2007 at 01:03 PM.
 
Old 11-11-2007, 02:28 PM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi.

I ended up pulling PulseAudio out. The two apps I use most aren't supported (MPlayer and Audacity).

To revert to ALSA, you'll have to move a file:
Code:
mv /etc/alsa/pulse-default.conf /etc/alsa/pulse-default.conf.bak
That should remove the PulseAudio backend from the ALSA chain, and let ALSAlib apps work again.

Dave
 
Old 11-11-2007, 09:38 PM   #3
Bully_on_Linux
LQ Newbie
 
Registered: Jul 2006
Posts: 1

Rep: Reputation: 0
I had the same problem this afternoon!

Everything worked (!!!) & I updated and configured my machine to where I was REALLY feeling pleased and all was right with the world.

THEN, I checked to see if there was any more updates and there now was an updated kernel. Previously there had been a new kmod-nvidia update from the Livna repository but the matching kernel, kernel-i686-2.6.23.1-49.fc8 had not shown up yet. Now both were available and I performed the update and rebooted.

IMMEDIATELY, I had artsd running at 100% CPU utilization and an error about the sound system causing a cpu overload and arts aborted.

I spent some time reverting to the previous kernel and getting things to work again. I am leery of doing updates now.

Fedora 8 works, it's great -- this dumb old country boy is gonna leave it alone, except for security updates. I'm still learning but learning while in "panic mode" is no fun.
 
Old 11-12-2007, 12:05 AM   #4
benjithegreat98
Senior Member
 
Registered: Dec 2003
Location: Shelbyville, TN, USA
Distribution: Fedora Core, CentOS
Posts: 1,019

Original Poster
Rep: Reputation: 45
Hey guys, I found out what I had done to kill my sound. I was disabling certain services and one of them was the 'ConsoleKit' service. Turns out it's really important for this to be running for the sound to work.

I started it, logged out and back in and the sound was working once again. Hope this helps somebody else. I found it in another forum.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
upgrade fedora7 to fedora8 seighalani Fedora 8 11-11-2007 03:14 PM
LXer: Olswang keeps finger on tech pulse with dedicated open source division LXer Syndicated Linux News 0 10-01-2007 09:10 AM
probléme with pulse dialing djnux Linux - Networking 1 04-07-2005 01:21 PM
Kppp refuse to dial pulse Yogurth Mandriva 1 03-05-2004 01:27 PM
Pulse Dialing chrisharkness Linux - General 2 11-18-2002 08:59 AM


All times are GMT -5. The time now is 05:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration