-   Fedora (
-   -   Public Key Not Installed (

scorpioofthewoods 07-28-2006 01:03 PM

Public Key Not Installed
For some reason yum is having problems the past day. Every time I try to install something with yum I keep getting an error like:

Transaction Summary
Install 8 Package(s)
Update 0 Package(s)
Remove 0 Package(s)
Total download size: 1.1 M
Downloading Packages:
(1/8): lame-3.96.1-5.fc5. 100% |=========================| 399 kB 01:17
(2/8): libid3tag-0.15.1b- 100% |=========================| 43 kB 00:07
(3/8): amrnb-0.0.1-2.fc5. 100% |=========================| 133 kB 00:24
(4/8): libdvdread-0.9.5-2 100% |=========================| 65 kB 00:15
(5/8): a52dec-0.7.4-8.fc5 100% |=========================| 51 kB 00:09
(6/8): libsidplay-1.36.59 100% |=========================| 71 kB 00:13
(7/8): mpeg2dec-0.4.0-8b. 100% |=========================| 100 kB 00:17
(8/8): gstreamer-plugins- 100% |=========================| 216 kB 00:37
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 1aa78495

Public key for libid3tag-0.15.1b-3.fc5.rf.i386.rpm is not installed

Edit: I meant to add that if I try to get a key I get this:

[root@localhost ~]# rpm --import
warning: cannot get exclusive lock on /var/lib/rpm/Packages

anomie 07-28-2006 10:40 PM

You have an unfinished rpm update hanging out there, perhaps?


ps -ef | egrep 'rpm|yum' | grep -v 'grep'

scorpioofthewoods 07-30-2006 11:22 AM

Well that seems to have worked. I am not getting the no key error when yum tries to install things now. Thank you very much!

HowitZer 06-06-2007 11:48 AM

getting public keys
I'm trying to install linneighborhood and when I do a yum install I get this message:

Public key for linneighborhood-0.6.5-3.2.fc6.rf.x86_64.rpm is not installed

How do I get a public key for this?

pweltz 01-28-2008 01:29 PM

In case someone hit this thread like I did:

The provider of your .rpm signed it with its private key to proove it is a genuine file from them.
We can verify it with the public key (but not sign, see wikipedia RSA PKI about public/private keys FYI)

Practically that means you need to find the public key and import it
in my case it was a file named: RPM-GPG-KEY ( from Red HAt distro)

suggestion: find / -name "*GPG*"

then import the public key with: rpm --import *GPG*
and it should be ok.

In my case:
Public key for is not installed
[root@taz isoCDs]# rpm --import /mounted_RHEL4.6-i386-ES-disc4/RPM-GPG-KEY
[root@taz isoCDs]# yum install


intermod 10-04-2008 03:39 PM


Originally Posted by anomie (Post 2356071)
You have an unfinished rpm update hanging out there, perhaps?


ps -ef | egrep 'rpm|yum' | grep -v 'grep'

When I tried this I got:

root 2663 1 0 Aug12 ? 04:26:58 /usr/bin/python /usr/sbin/yum-updatesd

Tried yum update python and got:

Could not find update match for python
No Packages marked for Update/Obsoletion

Instead of originally installing the regular rpm package, I then installed the source RPM package according to:

and the application installed and ran great. I am really appreciating the ease of Debian/Ubuntu updates....I am giving up on redhat/centos and the RPM stuff soon.


MacTommy 10-24-2008 08:22 AM

Thanks a million pweltz.
I hit this thread and I was completely stuck. Your contribution really helped!

rogerdpack 02-24-2009 10:58 AM


Originally Posted by pweltz (Post 3037866)

In my case:
Public key for is not installed
[root@taz isoCDs]# rpm --import /mounted_RHEL4.6-i386-ES-disc4/RPM-GPG-KEY
[root@taz isoCDs]# yum install

In my case one of these keys worked:
sh-3.2# rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta
sh-3.2# rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-auxiliary
sh-3.2# rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

gstav 01-29-2010 08:10 PM

There are oter option to install RPMforge
If you dont have installed the GPG Key, you will go to "Dag RPM Repository FAQ page" ( and see the section "How to configure to use RPMforge" you can use rpm command into list of the GPG keys by Linux distribution.

crackmac 01-27-2012 04:34 PM

You can sometimes add the --nogpgcheck flag and skip the key verification.


yum install --nogpgcheck yum-downloadonly

aman078 03-07-2013 02:03 PM

you can disable the check by editing /etc/yum.repos.d/your_file.d and writting gpgcheck=0

All times are GMT -5. The time now is 07:33 AM.