LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 12-20-2007, 08:25 PM   #1
iro_number1
Member
 
Registered: Jan 2007
Location: Shirley, NY
Distribution: Gentoo
Posts: 128
Blog Entries: 1

Rep: Reputation: 15
Question Problems installing ati driver 8.443.1 on Fedora 7.


I'm trying to install the driver so fglrx and all that good stuff works (hoping for games and beryl) but everytime i try doing it this way:

http://news.softpedia.com/news/How-t...-7-59919.shtml

And yes i changed the driver version so it is same as the file and gives me an error at creating a specific fedora package
Code:
[root@localhost ~]# '/home/irek/Desktop/ati-driver-installer-8.443.1-x86.x86_64.run' --buildpkg Fedora/F7 
Created directory fglrx-install.EN6234
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.443.1.......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
 ATI Technologies Linux Driver Installer/Packager 
==================================================
Generating package: Fedora/F7
Package build failed!
Package build utility output:
Building target platforms: i386
Building for target i386
Executing(%prep): /bin/sh -e /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/rpm-tmp.32580
+ umask 022
+ cd /tmp/ATI-fglrx-8.443.1-1-6310-root/BUILD
+ cd /tmp/ATI-fglrx-8.443.1-1-6310-root/BUILD
+ cd ATI-fglrx-8.443.1
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/rpm-tmp.32580
+ umask 022
+ cd /tmp/ATI-fglrx-8.443.1-1-6310-root/BUILD
+ cd ATI-fglrx-8.443.1
+ exit 0
Executing(%install): /bin/sh -e /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/rpm-tmp.32580
+ umask 022
+ cd /tmp/ATI-fglrx-8.443.1-1-6310-root/BUILD
+ cd ATI-fglrx-8.443.1
+ rm -rf /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root
+ '[' -d /etc/ld.so.conf.d ']'
+ mkdir -p /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/etc/ld.so.conf.d
+ pushd /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/etc/ld.so.conf.d
/tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/etc/ld.so.conf.d /tmp/ATI-fglrx-8.443.1-1-6310-root/BUILD/ATI-fglrx-8.443.1
+ cat
+ popd
/tmp/ATI-fglrx-8.443.1-1-6310-root/BUILD/ATI-fglrx-8.443.1
+ mkdir -p /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/usr/share/applications
+ pushd /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/usr/share/applications
/tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/usr/share/applications /tmp/ATI-fglrx-8.443.1-1-6310-root/BUILD/ATI-fglrx-8.443.1
+ cat
+ popd
/tmp/ATI-fglrx-8.443.1-1-6310-root/BUILD/ATI-fglrx-8.443.1
+ cp -pR /tmp/ATI-fglrx-8.443.1-1-6310-root/BUILD/ATI-fglrx-8.443.1/etc /tmp/ATI-fglrx-8.443.1-1-6310-root/BUILD/ATI-fglrx-8.443.1/lib /tmp/ATI-fglrx-8.443.1-1-6310-root/BUILD/ATI-fglrx-8.443.1/usr /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root
+ find /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/usr/share/doc -type f -perm 0555 -exec chmod 0644 '{}' ';'
+ find /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root -type f -perm 0555 -exec chmod 0755 '{}' ';'
+ export AS_USER=y
+ AS_USER=y
+ pushd /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/lib/modules/fglrx/build_mod
/tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/lib/modules/fglrx/build_mod /tmp/ATI-fglrx-8.443.1-1-6310-root/BUILD/ATI-fglrx-8.443.1
+ bash make.sh verbose
ATI module generator V 2.0
==========================
initializing...
make.sh: line 537: [: =: unary operator expected
OsRelease=2.6.23.8-34.fc7
major=2
minor=6
patch=23
extra=.8-34.fc7
SMP=1
smp=-SMP
iii=
AGP=1
CC=gcc
cc_version=
cleaning...
patching 'highmem.h'...
assuming new VMA API since we do have kernel 2.6.x...
 Assuming default VMAP API
 Assuming default munmap API
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.23.8-34.fc7/build SUBDIRS=/tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/kernels/2.6.23.8-34.fc7-i686'
  CC [M]  /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_check_pci':
/tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1953: warning: 'pci_find_slot' is deprecated (declared at include/linux/pci.h:481)
/tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_pci_find_slot':
/tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2842: warning: 'pci_find_slot' is deprecated (declared at include/linux/pci.h:481)
  LD [M]  /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/fglrx.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
  LD [M]  /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
make[1]: Leaving directory `/usr/src/kernels/2.6.23.8-34.fc7-i686'
build succeeded with return value 0
duplicating results into driver repository...
done.
==============================
You must change your working directory to /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/lib/modules/fglrx
and then call ./make_install.sh in order to install the built module.
==============================
+ mkdir -p /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/lib/modules/2.6.23.8-34.fc7/extra
+ install -D -m 0644 fglrx.ko /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/lib/modules/2.6.23.8-34.fc7/extra/fglrx/fglrx.ko
+ rm -rf /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root/lib/modules/fglrx
+ popd
/tmp/ATI-fglrx-8.443.1-1-6310-root/BUILD/ATI-fglrx-8.443.1
+ /usr/lib/rpm/brp-compress
+ /usr/lib/rpm/brp-strip
+ /usr/lib/rpm/brp-strip-static-archive
+ /usr/lib/rpm/brp-strip-comment-note
Processing files: ATI-fglrx-8.443.1-1.f7
Provides: config(ATI-fglrx) = 8.443.1-1.f7 fglrx_dri.so fglrx_drv.so glesx.so libGL.so.1 libfglrx_dm.so.1.0 libfglrx_gamma.so.1 libfglrx_pp.so.1.0 libfglrx_tvout.so.1 libfglrxdrm.so
Requires(interp): /bin/sh /bin/sh /bin/sh
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires(post): /bin/sh /sbin/chkconfig /sbin/ldconfig
Requires(preun): /bin/sh /sbin/chkconfig /sbin/service
Requires(postun): /bin/sh /sbin/ldconfig /sbin/service
Requires: /bin/bash /bin/sh config(ATI-fglrx) = 8.443.1-1.f7 kernel-module-ATI-fglrx-2.6.23.8-34.fc7 = 8.443.1-1.f7 libGL.so.1 libX11.so.6 libXext.so.6 libXrandr.so.2 libXrender.so.1 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2) libc.so.6(GLIBC_2.2.3) libdl.so.2 libdl.so.2(GLIBC_2.0) libdl.so.2(GLIBC_2.1) libfglrx_dm.so.1.0 libfglrx_gamma.so.1 libfglrx_pp.so.1.0 libfglrx_tvout.so.1 libgcc_s.so.1 libgcc_s.so.1(GCC_3.0) libm.so.6 libm.so.6(GLIBC_2.0) libpthread.so.0 libpthread.so.0(GLIBC_2.0) libpthread.so.0(GLIBC_2.1) libpthread.so.0(GLIBC_2.2) librt.so.1 librt.so.1(GLIBC_2.2) system-config-display
Conflicts: fglrx fglrx-glc22 fglrx_4_3_0 fglrx_6_8_0 kernel-module-fglrx ati-fglrx ati-fglrx-devel kmod-fglrx xorg-x11-drv-fglrx xorg-x11-drv-fglrx-devel nvidia-glx nvidia-glx-legacy xorg-x11-drv-nvidia xorg-x11-drv-nvidia-legacy
Processing files: ATI-fglrx-control-center-8.443.1-1.f7
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: ATI-fglrx = 8.443.1-1.f7 libGL.so.1 libICE.so.6 libSM.so.6 libX11.so.6 libXcursor.so.1 libXext.so.6 libXi.so.6 libXrandr.so.2 libXrender.so.1 libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.2) libdl.so.2 libdl.so.2(GLIBC_2.0) libdl.so.2(GLIBC_2.1) libfontconfig.so.1 libfreetype.so.6 libgcc_s.so.1 libgcc_s.so.1(GCC_3.0) libgcc_s.so.1(GLIBC_2.0) libm.so.6 libm.so.6(GLIBC_2.0) libm.so.6(GLIBC_2.1) libm.so.6(GLIBC_2.2) libpthread.so.0 libpthread.so.0(GLIBC_2.0) libpthread.so.0(GLIBC_2.1) libpthread.so.0(GLIBC_2.2) libstdc++.so.5 libstdc++.so.5(CXXABI_1.2) libstdc++.so.5(GLIBCPP_3.2)
Processing files: ATI-fglrx-devel-8.443.1-1.f7
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: /usr/include/GL ATI-fglrx = 8.443.1-1.f7 libGL.so.1
Processing files: kernel-module-ATI-fglrx-2.6.23.8-34.fc7-8.443.1-1.f7
Requires(interp): /bin/sh /bin/sh
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires(post): /bin/sh
Requires(postun): /bin/sh
Checking for unpackaged file(s): /usr/lib/rpm/check-files /tmp/ATI-fglrx-8.443.1-1-6310-root/tmp/ATI-fglrx-8.443.1-1.f7-root-root
error: Installed (but unpackaged) file(s) found:
   /etc/ati/amdpcsdb.default


RPM build errors:
    Installed (but unpackaged) file(s) found:
   /etc/ati/amdpcsdb.default
Removing temporary directory: fglrx-install.EN6234
Any idea on what's up?
 
Old 12-20-2007, 11:00 PM   #2
yadimka
LQ Newbie
 
Registered: Dec 2007
Posts: 2

Rep: Reputation: 0
Fix

su -
echo "%_unpackaged_files_terminate_build 0" >> ~/.rpmmacros
then try again.
 
Old 12-25-2007, 05:03 PM   #3
iro_number1
Member
 
Registered: Jan 2007
Location: Shirley, NY
Distribution: Gentoo
Posts: 128
Blog Entries: 1

Original Poster
Rep: Reputation: 15
didn't help

I tried again this is the process:
Install Livna REP

Code:
su -
yum install kmod-fglrx
aticonfig --initial
the aticonfig --initial didn't work so i typed again it says "nothing to do terminating.....

i restarted

Code:
glxgears
looks nice for few seconds then its choppy again

Code:
glxinfo | grep direct
comes out Negative....

What am i doing wrong here?
 
Old 12-31-2007, 01:32 AM   #4
yadimka
LQ Newbie
 
Registered: Dec 2007
Posts: 2

Rep: Reputation: 0
It appears that at first you were trying to build your own ATI rpm, then you went and installed the one from Livna. Please post your /etc/X11/xorg.conf file as well as the output of fglrxinfo and lsmod.

Thanks.
 
Old 12-31-2007, 02:30 PM   #5
iro_number1
Member
 
Registered: Jan 2007
Location: Shirley, NY
Distribution: Gentoo
Posts: 128
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Sorry but i switched OS to Mandriva 2008 and still have a similar problem:

http://www.linuxquestions.org/questi...roject-608443/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems installing ati driver in fc6 raim1312 Linux - Hardware 2 11-20-2006 12:04 AM
Fedora 5 problems with gnome and ati video driver Melciah Fedora 1 04-24-2006 12:08 PM
Problems installing ATI driver Scorper Linux - Software 1 03-04-2005 01:02 PM
Problems installing ATI Video Driver on FC3 JulianoF Fedora 0 01-19-2005 08:38 PM
Fedora Core 2 test and ATI driver problems IgD Linux - Hardware 1 03-14-2004 05:00 AM


All times are GMT -5. The time now is 11:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration