LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 08-03-2005, 08:38 AM   #1
rconan
Member
 
Registered: Jun 2005
Distribution: Debian Unstable (Sid)
Posts: 63

Rep: Reputation: 15
problem with failing mount at boot time


So heres the problem. I deleted one of my logical volumes using the LVM graphical config tool in GNOME but the entry in fstab wasnt removed.

This means that at boot time it fails to mount giving me the option of entering root password for maintainance or pressing ctrl+d to restart.

So the simple solution you would say would be drop into maintainance mode and edit fstab but unfortunately maintainance mode only mounts root readonly and i cant unmount it to mount it readwrite because it is the root.

So how do I get out of this?

Is there a way to 'remount' the root partition in readwrite mode from maintainance mode?
Is there a way to bypass the mounting of filesystems on startup?
 
Old 08-03-2005, 08:43 AM   #2
okmyx
Member
 
Registered: May 2004
Location: Cornwall, UK
Distribution: Ubuntu 8.04
Posts: 464

Rep: Reputation: 31
The simplist solution would be to use the rescue option of a distros install disk or Knoppix to boot the machine, mount the partition and edit the file.
 
Old 08-03-2005, 08:44 AM   #3
rconan
Member
 
Registered: Jun 2005
Distribution: Debian Unstable (Sid)
Posts: 63

Original Poster
Rep: Reputation: 15
the rescue cd doesnt seem to boot (which i presume is a separate problem) and i didnt think knoppox supported LVM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to mount WinXP drive at boot-time? voly Linux - General 10 07-16-2005 08:13 AM
Drive mount at boot time problems pete123 Suse/Novell 4 03-13-2005 03:17 PM
eth1 failing on boot, IEEE firewire card driver failing, help jackuss_169 Linux - Laptop and Netbook 5 03-05-2005 08:34 AM
USB Keyboard Failing at USB Filesystem Mount Time ciaran_skye Fedora 0 08-06-2004 03:09 AM
LILO install failing, Boot failing, but Installation fine. sramelyk Slackware 9 08-23-2003 03:37 PM


All times are GMT -5. The time now is 07:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration