LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 12-30-2007, 12:33 PM   #1
stratcat
Member
 
Registered: Jun 2006
Location: L.I.N.Y
Distribution: Ubuntu 10.04
Posts: 78

Rep: Reputation: 16
Problem With Audigy SE Sound Card


I could use some help configuring my new sound card. I just replaced my FC5 with FC8 recently and decided to upgrade my scratchy on-board C-Media sound card with a Sound Baster Audigy SE card. The card was recognized and I switched the settings in Sound Card Detection. I get sound perfectly with the sound test but not in any of my players (Totem-Xine, Mplayer and Xine. XMMS seems to work ok. I've also noticed there is no sound in You-Tube. I could really use some help sorting this out.

Last edited by stratcat; 12-30-2007 at 08:05 PM.
 
Old 12-31-2007, 06:07 AM   #2
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
firstly make sure that your onboard mothercard sound is disabled in the bios pls.

2) Sound is a combination of settings depending on what you have
a)
KDE and its sound server could still be holding it, if you run KDE go into control center and slide setting in sounds system to auto suspend for a very short time....say 2 seconds

b) your midi device in hardware is finding your s/card in kde control center

c) then mixer controls ensure no needed ones are muted or low volume
kmix is kde mixer...alsamixer is the alsa mixer gosh and dunno what gnomes is

d) I only use mplayer of those mentioned...ensure you have the codecs for the audio at the site....maybe F8 does not have them?

e) you have not mentioned browser...but in opera settings you need to enable sound maybe the same is true of ffox?
 
Old 12-31-2007, 08:35 AM   #3
buzzbiker
Member
 
Registered: Jul 2002
Location: Oregon
Distribution: Fedora Core 7 - vista
Posts: 38

Rep: Reputation: 15
In KDE

In KDE click K then multimedia then KMix-Sound Mixer then click tab switches unclick Audigy/Analog/Digital outputjack.

That workes for me. Hope that helps
 
Old 12-31-2007, 03:50 PM   #4
stratcat
Member
 
Registered: Jun 2006
Location: L.I.N.Y
Distribution: Ubuntu 10.04
Posts: 78

Original Poster
Rep: Reputation: 16
Ok, after I posted this thread I stayed with it for quite a while searching Google. I found that messing with the settings mostly in gui I got most all of my players working. It really took some time. It just seemed to me that if XMMS worked that it must have been individual settings in each of the players. It turns out to be a little bit of both with sound card and player settings. I am using Gnome desktop in Core 8 on this machine. After reading your post I went to setup and shut down the onboard device which I forgot to do in the first place. Also I am using Firefox. Alsamixer is the correct command for the mixer in Gnome. Only the analog controls in alsamixer actually controlled the volume. I also cannot bring this mixer up in GUI.

I am now still having a problem with sound on youtube type applications. I would bet that it's a flash related issue. Is there a way I can configure this? Thank you for your replies
 
Old 12-31-2007, 08:10 PM   #5
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
/home/(yourname)/.macromedia/Flash_Player/#SharedObjects/HF4V8MHV

ignore that the last string will differ for you....navigate to the hidden folder and see if you have this?

2) flashplayer needs 2 files

flashplayer.xpt and libflashplayer.so.....these should exist in your mozilla plugins folder

I do not use ffox I use opera so do a search to find if they are in your plugins folder with
commands

su (and root passwd)
find / -name flashplayer.xpt.....response will be each pathway detected on system
ditto replace libflashplayer.so for flashplayer and see pathway
 
Old 01-01-2008, 01:24 AM   #6
stratcat
Member
 
Registered: Jun 2006
Location: L.I.N.Y
Distribution: Ubuntu 10.04
Posts: 78

Original Poster
Rep: Reputation: 16
Quote:
su (and root passwd)
find / -name flashplayer.xpt.....response will be each pathway detected on system
ditto replace libflashplayer.so for flashplayer and see pathway
Here are my 'find' results:

Quote:
[bob@localhost ~]$ su
Password:
[root@localhost bob]# find / -name flashplayer.xpt
/media/windows/Program Files/Mozilla Firefox/components/flashplayer.xpt
/media/windows/Program Files/Mozilla Firefox/plugins/flashplayer.xpt
[root@localhost bob]# find / -name libflashplayer.so
/usr/lib/flash-plugin/libflashplayer.so
/usr/lib/mozilla/plugins/libflashplayer.so
/usr/lib/firefox-2.0.0.10/plugins/libflashplayer.so
[root@localhost bob]#
Where do I go from here?
 
Old 01-01-2008, 04:34 AM   #7
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
I do not use ffox but it looks like your fox looks for plugins here'
/usr/lib/mozilla/plugins/libflashplayer.so

but it does not have the other plugin.

I am guessing media windows means you have a windows version of firefox and its plugin?

2) if so, you are unlikely to succeed with a copy of windows flashplayer.xpt being put into /usr/lib/mozilla/plugins/

3) try it if you like but you may be better off going for a new install...

http://www.adobe.com/shockwave/downl...ShockwaveFlash

I am suggesting that you d/load the tar.gz as you get more control.....you can copy the extracted named 2 files to each browser plugin folder....in case you run more than one browser....and try /usr/lib/mozilla/plugins/ first.

4) In opera preferences you can see the plugins pathway....hopefully ffox has a similar option....but there is no harm sticking those 2 files in each linux plugin folder you can find....but make a backup of the current linux ones and keep them in /home/name/download for now until you know you have success

good luck
 
Old 01-01-2008, 12:09 PM   #8
stratcat
Member
 
Registered: Jun 2006
Location: L.I.N.Y
Distribution: Ubuntu 10.04
Posts: 78

Original Poster
Rep: Reputation: 16
No Sound With Youtube-flashplayer

Quote:
I do not use ffox but it looks like your fox looks for plugins here'
/usr/lib/mozilla/plugins/libflashplayer.so

but it does not have the other plugin.

I am guessing media windows means you have a windows version of firefox and its plugin?

2) if so, you are unlikely to succeed with a copy of windows flashplayer.xpt being put into /usr/lib/mozilla/plugins/

3) try it if you like but you may be better off going for a new install...

http://www.adobe.com/shockwave/downl...ShockwaveFlash
I think 'find' just found the files on my Windows partition. I don't believe that Fedora is using them. I does however have both files in it.
It's also possible that FFX is looking in /usr/lib/firefox-2.0.0.10/plugins/libflashplayer.so also so I will
make sure I put flashplater.xpt in both folders (ie mozilla and firefox-2.0.0.10)

I don't believe that I mentioned that the onboard C-Media worked with flashplayer.
I also already did a reinstall of flashplayer unless you were refering to a total reinstall. The thought crossed my mind but I'm trying to get this without doing a complete reinstall.

I am going to get the tar.gz file and install the flashplayer.xpt.
I'll let you know if this works, Bob
 
Old 01-01-2008, 12:46 PM   #9
stratcat
Member
 
Registered: Jun 2006
Location: L.I.N.Y
Distribution: Ubuntu 10.04
Posts: 78

Original Poster
Rep: Reputation: 16
Quote:
[bob@localhost install_flash_player_9_linux]$ ls
flashplayer-installer libflashplayer.so
I downloaded and unpacked the tar.gz and looked for the flashplayer.xpt file. It's not to be found.
Question(s): 1- Why would Windows use it and not Linux? Is it just missing or not used anymore?
2- I searched for the file flashpayer.xpt and it's available. Should I use it?
 
Old 01-01-2008, 02:27 PM   #10
stratcat
Member
 
Registered: Jun 2006
Location: L.I.N.Y
Distribution: Ubuntu 10.04
Posts: 78

Original Poster
Rep: Reputation: 16
Well I spoke too soon. I can't find the file flashpayer.xpt. I also tried other installation applications (ie rpm, yum and tar.gz). Non of which contains the .xpt file. I searched google and it seems it's not used anymore. I checked my other PC's using ubuntu 7.04 and FC7 and they also don't have this file in /usr/lib/mozilla/components/. I thought we were on to something here but I guess not. I'll keep trying
 
Old 01-01-2008, 06:41 PM   #11
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
oops you are right....I am using an old version and assumed the new one was similar I have just d/l new one and it only has the one file. damn.

2) can we go back to my suggestion on the macromedia folder, do you have such a beast?
 
Old 01-01-2008, 09:01 PM   #12
stratcat
Member
 
Registered: Jun 2006
Location: L.I.N.Y
Distribution: Ubuntu 10.04
Posts: 78

Original Poster
Rep: Reputation: 16
Yes the .macromedia folder is in hidden file in /home/bob/.macromedia
 
Old 01-02-2008, 02:59 AM   #13
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
my bad....I mean do you have the folder and a string like mine above ...the string is random but the string must exist not just the hidden point folder post 5
 
Old 01-02-2008, 07:52 PM   #14
stratcat
Member
 
Registered: Jun 2006
Location: L.I.N.Y
Distribution: Ubuntu 10.04
Posts: 78

Original Poster
Rep: Reputation: 16
I apologize, I misinterpreted your question. Yes the whole string is there.

I was playing around with the settings and flash videos and I noticed that when I plugged the speaker plug to the onboard soundcard output jack that the flash video has sound even though it is turned off in setup. I think I screwed things up when I installed the new card without disabling the other one first. I'm close to a total reinstall with just the Audigy enabled. If I thought it would definitely solve my problem I would have already done so. I also can't get the system sounds to work either so there's alot going on here.
 
Old 01-02-2008, 08:20 PM   #15
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
that is it....disable onboard sound probably ac97 then check your /var/log/dmesg to see your sound card is detected then reconfig sound.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound coming from my sound blaster audigy 2 ZS platinum sound card msab Linux - Hardware 9 12-05-2010 06:10 AM
Virtual surround sound (Audigy SE Sound Card) alan1s Linux - Newbie 3 08-09-2009 07:00 PM
Ubuntu Breezy No Sound on Audigy Sound Card rjcmi Ubuntu 14 03-11-2009 12:19 AM
Audigy sound card trackrat Mandriva 16 07-25-2004 01:38 AM
Can't get sound from Mandrake 9.1 with SoundBlaster Audigy 2 Sound Card... shortyzms Linux - Newbie 3 12-08-2003 06:36 PM


All times are GMT -5. The time now is 01:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration