LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   preferred apps in FC3 (http://www.linuxquestions.org/questions/fedora-35/preferred-apps-in-fc3-313631/)

snafu 04-15-2005 03:09 PM

preferred apps in FC3
 
I remember FC2 letting you choose programs to always use for certain types of files. For example, I remember selecting XMMS for wav, mp3 and ogg files. So when I double clicked one of those, xmms would start playing it.

Now with FC3, when I double-click an audio file, it always starts up Helix Player. I don't see any way to say "always use Audio Player for this type of file". And Preferred Apps in the Menu only lets you choose Web Browser, Mail Reader, Text Editor, and Terminal preferences...

I don't want to see Helix Player ever again. It just says "unsupported format" when I click on mp3s anyway. I did do the xmms mp3 installation, so xmms plays them fine. However, I want xmms to be the app that opens automatically when I click on audio files.

I've been using FC2 exclusively for about 8 months now, and I generrally liked it. A couple weeks ago, I decided to do a clean install of FC3 over my prior FC2 install. So far I like FC3, but I'm having a few issues with rinky-dink crap, like the one mentioned above.

I see where to select "audio player" for mp3 files, but it still doesn't automatically start playing if I double-click an mp3. XMMS will come up, but I have to drag & drop the mp3 file onto it for it to start playing. FC2 would start playing automatically after a double-click.

thanks

red_over_blue 04-16-2005 10:52 AM

Are you using gnome? If so, try opening nautilus, and right clicking on the file, and going to "properties" or something like that. I'm not using gnome right now, but somewhere in there, there is the option to change the app that opens that type of file.

jlawren7 04-16-2005 11:06 AM

Right click a mp3 file

choose properties

click the "opens with" tab

see if audio player is listed

make sure it is the only one there

double click the file, XMMS should open and click play

I think you want XMMS to play the file automaticaaly for you correct?

browse around the xmms preferences and see if there is a option for this, if not file a bug
with http://bugs.xmms.org/

snafu 04-16-2005 01:35 PM

Quote:

Are you using gnome? If so, try opening nautilus, and right clicking on the file, and going to "properties" or something like that.
Yes, gnome, and that is the first thing I did. However, although that DOES make xmms open up when I double-click an mp3, it does not start playing automatically. I have to drag & drop the mp3 file on top of the xmms player. This is not a big deal, but I just like how it worked under FC2 better (double-click audio file and xmms starts playing it.


All times are GMT -5. The time now is 04:30 AM.