LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   "Places" menu (Gnome) starts Rythmbox instead of opening respective folder (http://www.linuxquestions.org/questions/fedora-35/places-menu-gnome-starts-rythmbox-instead-of-opening-respective-folder-871496/)

Neyzan 03-28-2011 11:40 AM

"Places" menu (Gnome) starts Rythmbox instead of opening respective folder
 
For about a week or two when I try to open a folder from the menu "Places" of Gnome 2.32.0 (with Fedora 14 OS) the program Rythmbox starts instead. This happens even when I try to access a connected harddrive which requires entry of a code. After entering the code again Rythmbox opens! This doesn't happen only with "Computer", "Network" and "Connect to Server" of "Places". I can't think of anything that I did (apart from using Rythmbox quite often recently) that could have caused this, so I assume that it is a bug of Gnome. Have other people encountered this problem? (I assume that it is not Fedora specific, but rather a general problem of Gnome) If so, does anyone know how to report or solve this?

DavidMcCann 03-28-2011 12:36 PM

Look at ~/.local/share/applications/mimeapps.list and see if you have a line reading
inode/directory=rhythmbox.desktop;
If you have, just delete it.

Neyzan 03-28-2011 07:30 PM

I can't find the .local/ folder, where could it be?

DavidMcCann 03-29-2011 11:05 AM

Start the file manager Nautilus. Press 'Control h' to show the hidden files and folders, and you should see .local

Neyzan 04-04-2011 08:37 AM

Thank you! Since yesterday when I clicked something in the "Places" menu Brasero opened instead of Rythmbox. I opened the mimeappslist and I found the line "inode/directory=brasero; rhythmbox-device.desktop; (continuing with Nautilus)". I deleted "brasero; rhythmbox-device.desktop;" and the problem was solved. I have come to the conclusion that this line was created when I followed this procedure: right-click on a folder -> Open With -> Other Application -> selecting the application (Rythmbox first and Brasero yesterday) but forgetting to uncheck "remember this application for "folder" files" before I clicked Open.

spatil05 01-27-2013 12:03 PM

@DavidMcCann
Thanks removing that line fixed the issue.


All times are GMT -5. The time now is 09:05 AM.