LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 10-04-2007, 02:51 AM   #1
violettheconqueror
Member
 
Registered: Sep 2005
Location: California
Distribution: Fedora 7
Posts: 44

Rep: Reputation: 15
pirut not loading in Fedora 7


Alright, so I just installed Fedora 7 on my computer. Ive been runing fedora core 6 for a while now and am quite pleased with it, especially with the livna repos.

My problem is that after installing the updates and various other packages (inlcuding livna and some stuff from there ie. kmod-nvidia and mplayer) When I click on "add/remove software" or click on the update packages icon or type "pirut" in the consol as root nothing happens for at least fifteen minutes...more like half an hour.

After quite some time I get an error box that says "config error unable to start due to a configuration error" when I click on "details" it says "none". With the typing pirut from command way it says "Loading "fedorakmod" plugin" and hangs.

I went with an interesting harddrive setup when I installed and used a 15gig partition formatted in reiserfs for root (mounted at / ) and a 250 gig partition formatted in xfs mounted at /home, then 20 gigs left over for a pcbsd install (which didnt work prolly a bad cd though). I dont know if this is a problem.

The problem first presented after installing all the major updates, then rebooting, then installing livna and the nvidia drivers and mplayer. installing the flash yum package. installing opera from an rpm. and messing with add-ons for firefox. That is seriously all that ive done from the fresh install. The problem was when 15 new updates appeared about an hour or two after the first update, my only guess is that were with livna.

Any ideas anyone?

Last edited by violettheconqueror; 10-04-2007 at 02:55 AM.
 
Old 10-04-2007, 05:45 AM   #2
decrepit
Member
 
Registered: May 2006
Distribution: Ubuntu10.04, < fedora12
Posts: 347

Rep: Reputation: 34
I have a similar problem with fedora7, after most of the latest updates, no yum related gui works, ie piruit, "software add remove" and yumex, but yum still works at the command line. I'm in core6 at the moment I'll boot into fedora7 later on and post the exact details and error messages.

OK I'm now in Fedora7
When I click on "add remove software" I get the request for root password then nothing, same for "software updater" and yumex.

In terminal.----

[root@fedora7 mike]# pirut
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Unable to import modules. Maybe you're not running under X?
[root@fedora7 mike]#

------
[root@fedora7 mike]# pup
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Traceback (most recent call last):
File "/usr/sbin/pup", line 31, in <module>
import gtk
File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 76, in <module>
_init()
File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 64, in _init
_gtk.init_check()
RuntimeError: could not open display
[root@fedora7 mike]#


-------------------
[root@fedora7 mike]# yumex
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Traceback (most recent call last):
File "/usr/share/yumex/yumex.py", line 29, in <module>
import gtk,gobject
File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 76, in <module>
_init()
File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 64, in _init
_gtk.init_check()
RuntimeError: could not open display
[root@fedora7 mike]#

-------
Not sure if this is the same problem, do you get a similar thing with pup??

Have you tried yumex??

Last edited by decrepit; 10-04-2007 at 08:05 AM. Reason: added data from fedora7
 
Old 10-04-2007, 09:52 AM   #3
wmakowski
Member
 
Registered: Oct 2003
Location: Ohio
Distribution: Fedora 18, 19, RHL 5.2
Posts: 546

Rep: Reputation: 43
I too am experiencing the config error box and have been running Fedora 7 since it first came out. It appears to be a common problem and a bug report has been generated. Keep an eye on Bugzilla Bug 318241: pirut/pup startup error. There is also a thread in FedoraForum called Problem with pup and pirut that is reference in the bug report. Guess we'll have to wait for the fix.

yum seems to be working fine. You can still use yum update from the command line to retrieve the latest updates.

Bill
 
Old 10-04-2007, 04:23 PM   #4
shafty023
Member
 
Registered: Oct 2007
Distribution: OSX
Posts: 248

Rep: Reputation: 31
Looks like they've fixed the issue as Pirut is working again. Must have been server-side issues
 
Old 10-04-2007, 04:46 PM   #5
mickeyboa
Senior Member
 
Registered: May 2004
Location: Indianapolis, Indiana
Distribution: FC-KDE, 32 and 64 bit
Posts: 1,398

Rep: Reputation: 55
Yes I'm back on to.

Thanks Guys
 
Old 10-04-2007, 04:56 PM   #6
violettheconqueror
Member
 
Registered: Sep 2005
Location: California
Distribution: Fedora 7
Posts: 44

Original Poster
Rep: Reputation: 15
Would ya look at that....Mine too! Well thats good...overall I've been very pleased with Fedora 7...Have any of you noticed a substantial boot time improvement? im not sure if it has to do with using reiserfs or Fedora 7 being better.

They sure fixed this problem quickly though! Kudos++ to the Fedora team. Thanks for helping everyone.
 
Old 10-04-2007, 05:08 PM   #7
shafty023
Member
 
Registered: Oct 2007
Distribution: OSX
Posts: 248

Rep: Reputation: 31
Ya I've noticed Fedora 7 boots a lot faster than previous Fedora releases.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
yum/pirut problem on fedora core 6 eugen.serban Linux - Newbie 5 05-07-2007 05:03 AM
pirut problem eugen.serban Fedora 2 04-27-2007 03:16 AM
Pirut/Add Remove Packages problem in Fedora core 6 me4linux Fedora 3 04-02-2007 08:47 AM
Fedora 5 pirut fails, apparently due to xwindows speter98 Linux - Newbie 2 05-24-2006 05:49 PM


All times are GMT -5. The time now is 01:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration