LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 07-25-2005, 01:04 AM   #1
trempel
Member
 
Registered: Jan 2005
Location: B.C, Canada
Distribution: SuSE 10 Eval
Posts: 130

Rep: Reputation: 15
permissions reset on reboot


I've noticed that permissions reset themselves when my computer is turned off. Each time I log on, i must alter the permissions of /dev/hdd (cd-rom) so that i can listen to a CD. I wanted to now if this is normal, and if there is something I can do so that when I later the permissions, they will still be the way I want them after I've rebooted.

thanks for any help.
 
Old 07-25-2005, 01:14 AM   #2
johnson_steve
Senior Member
 
Registered: Apr 2005
Location: BrewCity, USA (Milwaukee, WI)
Distribution: Xubuntu 9.10, Gentoo 2.6.27 (AMD64), Darwin 9.0.0 (arm)
Posts: 1,152

Rep: Reputation: 46
This is because you are using udev. when using udev nothing in /dev is actualy on your hard drive like it was with devfs so it goes away when you shut down and is created dynamacly at boot. you can ether go back to using devfs or set up some udev rules so your permissions are set corectly at boot.

this might help:
http://www.redhat.com/magazine/002dec04/features/udev/
 
Old 07-25-2005, 01:16 AM   #3
pembo13
Member
 
Registered: May 2003
Location: Caribbean
Distribution: Fedora Core2
Posts: 403

Rep: Reputation: 30
This sounds like a bug. I would suggest you upgrade to FC4.
 
Old 07-25-2005, 04:11 PM   #4
linux-rulz
Member
 
Registered: Dec 2004
Distribution: Windows XP Home, Ubuntu Hoary
Posts: 584

Rep: Reputation: 30
Quote:
This sounds like a bug. I would suggest you upgrade to FC4.
No, this isnt a bug, it is how udev works. Edit /etc/udev/permissions.d/udev.permissions to change the permissions permanently.
 
Old 07-25-2005, 05:20 PM   #5
pembo13
Member
 
Registered: May 2003
Location: Caribbean
Distribution: Fedora Core2
Posts: 403

Rep: Reputation: 30
Quote:
Originally posted by linux-rulz
No, this isnt a bug, it is how udev works. Edit /etc/udev/permissions.d/udev.permissions to change the permissions permanently.
A user not having access to their cdrom by defaul is normal?
 
Old 07-25-2005, 06:06 PM   #6
linux-rulz
Member
 
Registered: Dec 2004
Distribution: Windows XP Home, Ubuntu Hoary
Posts: 584

Rep: Reputation: 30
Quote:
A user not having access to their cdrom by defaul is normal?
No, it isn't. But I think upgrading the entire Operating System is a little drastic when editing a text file will probably suffice. There is most likely an error in the file, not in the software. Changing the permissions in that file will cause it to set those permissions on every boot. Probably easier to edit a line in a text file than redo the entire system Hell, entering a command to change the permissions manually on every boot is still easier than redoing the entire system.

udev on CentOS (and most likely RHEL) causes users not to be able to access a scanner device by default. I edited the file but I didn't change or upgrade the distro over this error.

If my suggestion doesn't work, just add the command you always enter to change the permissions to whatever you want to /etc/rc.local and this command will be run on every boot.
 
Old 07-26-2005, 06:00 PM   #7
silentboob
LQ Newbie
 
Registered: Jul 2005
Posts: 3

Rep: Reputation: 0
heh I had problems playing audio cd's, annd some problems with open gl apps, upgrading udev fixed that problem.
 
Old 07-28-2005, 08:08 PM   #8
trempel
Member
 
Registered: Jan 2005
Location: B.C, Canada
Distribution: SuSE 10 Eval
Posts: 130

Original Poster
Rep: Reputation: 15
what does that little checky-box labelled "sticky" do in the permisions dialog box?

I'm not 100% sure what you want me to do with that text file. After looking it over briefly I assume I should change the value for cdroms under "optical devices" from 0660 to 0664.
Is that correct?

Last edited by trempel; 07-28-2005 at 08:44 PM.
 
Old 07-28-2005, 09:57 PM   #9
linux-rulz
Member
 
Registered: Dec 2004
Distribution: Windows XP Home, Ubuntu Hoary
Posts: 584

Rep: Reputation: 30
Yes, that should fix the problem. And, if not, revert back to the original settings, and then take the command you issue each time you turn on the computer (eg. chmod 644 /dev/hdc) and put that command in /etc/rc.local and it will be run everytime you boot your computer.
 
Old 08-17-2005, 05:37 PM   #10
dr_zayus69
Member
 
Registered: Sep 2004
Location: western massachusetts
Distribution: fedora core 3, Suse 10
Posts: 877

Rep: Reputation: 35
hi i had the same issue. Do you need to reboot for udev to recreate the dev entries with the new permissions or is there a way to do it vai command line?
 
Old 08-18-2005, 02:12 AM   #11
linux-rulz
Member
 
Registered: Dec 2004
Distribution: Windows XP Home, Ubuntu Hoary
Posts: 584

Rep: Reputation: 30
Unplug the device and plug it back in, or else use chmod to change the permissions.
 
Old 08-18-2005, 03:24 AM   #12
spooon
Senior Member
 
Registered: Aug 2005
Posts: 1,755

Rep: Reputation: 48
I think you can give users ability to mount and access drives in /etc/fstab
In particular, I think that in the mount options (4th field), "pamconsole" does what you want.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 configuration reset after reboot ChillyWillie Linux - Networking 1 05-31-2005 10:21 PM
won't boot or reboot without reset dcfnef Linux - General 4 04-04-2005 06:33 AM
Settings get reset on reboot xymian Debian 3 02-23-2005 05:53 AM
Control Center Settings Reset when reboot bloodsample Mandriva 1 06-30-2004 09:22 PM
Routing table destroyed (reset) after reboot daveb93 Linux - Networking 1 09-23-2003 04:43 PM


All times are GMT -5. The time now is 03:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration