LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   pen drive and cd drive is not working !!!!!! (http://www.linuxquestions.org/questions/fedora-35/pen-drive-and-cd-drive-is-not-working-749527/)

abhattacharya 08-22-2009 09:45 AM

pen drive and cd drive is not working !!!!!!
 
Hello,
i have a linux machine. After installation it in not reading pen drive and cd drive. After some googling for pen drive i tried this as follows:

[root@arnab]# dmesg | tail -100

The output is as follows,

usb-storage: waiting for device to settle before scanning
Vendor: JetFlash Model: Transcend 2GB Rev: 8.07
Type: Direct-Access ANSI SCSI revision: 02
SCSI device sde: 3944448 512-byte hdwr sectors (2020 MB)
sde: Write Protect is off
sde: Mode Sense: 03 00 00 00
sde: assuming drive cache: write through
SCSI device sde: 3944448 512-byte hdwr sectors (2020 MB)
sde: Write Protect is off
sde: Mode Sense: 03 00 00 00
sde: assuming drive cache: write through
sde: sde1
sd 6:0:0:0: Attached scsi removable disk sde
sd 6:0:0:0: Attached scsi generic sg3 type 0
usb-storage: device scan complete
SELinux: initialized (dev sde1, type vfat), uses genfs_contexts
usb 1-6: USB disconnect, address 7
usb 1-6: new high speed USB device using ehci_hcd and address 8
usb 1-6: configuration #1 chosen from 1 choice
scsi7 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 8
usb-storage: waiting for device to settle before scanning
Vendor: JetFlash Model: Transcend 2GB Rev: 8.07
Type: Direct-Access ANSI SCSI revision: 02
SCSI device sdd: 3944448 512-byte hdwr sectors (2020 MB)
sdd: Write Protect is off
sdd: Mode Sense: 03 00 00 00
sdd: assuming drive cache: write through
SCSI device sdd: 3944448 512-byte hdwr sectors (2020 MB)
sdd: Write Protect is off
sdd: Mode Sense: 03 00 00 00
sdd: assuming drive cache: write through
sdd: sdd1
sd 7:0:0:0: Attached scsi removable disk sdd
sd 7:0:0:0: Attached scsi generic sg3 type 0
usb-storage: device scan complete
SELinux: initialized (dev sdd1, type vfat), uses genfs_contexts
usb 1-6: USB disconnect, address 8
usb 1-5: new high speed USB device using ehci_hcd and address 9
usb 1-5: configuration #1 chosen from 1 choice
scsi8 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 9
usb-storage: waiting for device to settle before scanning
Vendor: JetFlash Model: Transcend 2GB Rev: 8.07
Type: Direct-Access ANSI SCSI revision: 02
SCSI device sdd: 3944448 512-byte hdwr sectors (2020 MB)
sdd: Write Protect is off
sdd: Mode Sense: 03 00 00 00
sdd: assuming drive cache: write through
SCSI device sdd: 3944448 512-byte hdwr sectors (2020 MB)
sdd: Write Protect is off
sdd: Mode Sense: 03 00 00 00
sdd: assuming drive cache: write through
sdd: sdd1
sd 8:0:0:0: Attached scsi removable disk sdd
sd 8:0:0:0: Attached scsi generic sg3 type 0
usb-storage: device scan complete
SELinux: initialized (dev sdd1, type vfat), uses genfs_contexts
usb 1-5: USB disconnect, address 9
usb 1-6: new high speed USB device using ehci_hcd and address 10
usb 1-6: configuration #1 chosen from 1 choice
scsi9 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 10
usb-storage: waiting for device to settle before scanning
Vendor: JetFlash Model: Transcend 2GB Rev: 8.07
Type: Direct-Access ANSI SCSI revision: 02
SCSI device sdd: 3944448 512-byte hdwr sectors (2020 MB)
sdd: Write Protect is off
sdd: Mode Sense: 03 00 00 00
sdd: assuming drive cache: write through
SCSI device sdd: 3944448 512-byte hdwr sectors (2020 MB)
sdd: Write Protect is off
sdd: Mode Sense: 03 00 00 00
sdd: assuming drive cache: write through
sdd: sdd1
sd 9:0:0:0: Attached scsi removable disk sdd
sd 9:0:0:0: Attached scsi generic sg3 type 0
usb-storage: device scan complete
SELinux: initialized (dev sdd1, type vfat), uses genfs_contexts
usb 1-6: USB disconnect, address 10
usb 1-6: new high speed USB device using ehci_hcd and address 11
usb 1-6: configuration #1 chosen from 1 choice
scsi10 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 11
usb-storage: waiting for device to settle before scanning
Vendor: JetFlash Model: Transcend 2GB Rev: 8.07
Type: Direct-Access ANSI SCSI revision: 02
SCSI device sdd: 3944448 512-byte hdwr sectors (2020 MB)
sdd: Write Protect is off
sdd: Mode Sense: 03 00 00 00
sdd: assuming drive cache: write through
SCSI device sdd: 3944448 512-byte hdwr sectors (2020 MB)
sdd: Write Protect is off
sdd: Mode Sense: 03 00 00 00
sdd: assuming drive cache: write through
sdd: sdd1
sd 10:0:0:0: Attached scsi removable disk sdd
sd 10:0:0:0: Attached scsi generic sg3 type 0
usb-storage: device scan complete
SELinux: initialized (dev sdd1, type vfat), uses genfs_contexts













my /etc/fstab file is as follows:


/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/sdd /mnt/pen auto user,noauto,rw 0 1



i can now mount my pen drive by,
mount /dev/sdd1 /mnt/pen/
but only after using this command i can see a disk photo comes in desktop as pen drive. Each and every time i need to use this command to access the pen drive. Why it is not auto detected by the machine? Also for cd drive i am in still dark. please help me out




Thanks in advance

htnakirs 08-23-2009 03:21 AM

Depending on the version of KDE and file manager you are using, there is a simpler route to accessing drives (if they are not being automounted). In Konqueror there is a panel on the right side, a thin panel that is further to the right than the folder panel. The last button on that panel, labelled system, is useful. Click it and you will find an entry called Storage devices, which you can select and refresh (F5) and you will see all newly plugged storage devices. Double click any and they will be accessible, under media. KDE4 the dumbest desktop manager ever has castrated Konqueror in many respects, and even added an even impotent dolphin for this job, so all the above applies to Konq used in KDE3.5 or less.

More technically, automounting is controlled by the autofs service, which is probably disabled. Check for the services that are started at boot time by visiting the control panel (it is there somewhere).


All times are GMT -5. The time now is 12:25 AM.