LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 12-07-2003, 08:38 AM   #1
roskoo
LQ Newbie
 
Registered: Apr 2002
Distribution: redhat7.2
Posts: 16

Rep: Reputation: 0
Smile pb install 'alsa drivers rpms' under Fedora


from a newbie:
I want to use the alsa sound drivers under my new fresh fedora core 1-
config:
my soundcard is aureal au8810 incorporated in the new alsa releases
the kernel is linux-2.4.22-1.2115.nptl in usr/src
I installed these alsa drivers from yarrow.freshrpms.net:
-alsa-driver-1.0.0-0.rc1.1.fr.i386.rpm
+alsa-lib-1.0.0-0.rc1.1.fr.i386.rpm
+alsa-utils-1.0.0-0.rc1.1.fr.i386.rpm
+kernel-module-alsa-1.0.0-0.rc1.1.fr_2.4.22_1.2115.nptl.i386.rpm
+gnome-alsamixer-0.9.6-2.fr.i386.rpm
installation was ok-
the soundcard is recognise and configure at the following reboot under kudzu
but then I can't activate any sound :

in my soundcard detection:
"the following audio device was detected.
vendor: aureal semiconductor
model: AU8810 Vortex Digital Audio Processor
module: snd-au8810

The snd-au8810 driver could not be loaded. This soundcard may not be compatible with Red Hat Linux.

Automatic detection of the sound card did not work. Audio will not be available on the system. Please click OK to continue."

I failed to launch alsamixer:
if in a shell # alsamixer
alsamixer: function snd_ctl_open failed for default: No such device
[root@localhost roomm]#

under my volume control,this error:

"Volume control is unable to run correctly.
Unable to open audio device '/dev/mixer'.
Please check that you have permissions to open '/dev/mixer'
and that you have sound support in your kernel."

when launching the command alsaconf, I get:
#alsaconf
" ...
loading driver...
/usr/bin/alsaconf: line 615: rcalsasound: command not found
Setting default volumes...
Saving the mixer setup used for this in /etc/asound.state.
/usr/sbin/alsactl: save_state:1061: No soundcards found...
Now ALSA is ready to use.
For adjustment of volumes, use your favorite mixer. Have a lot of fun!"

what did I miss? can you help me? thanks

Last edited by roskoo; 12-08-2003 at 04:14 AM.
 
Old 12-08-2003, 10:50 PM   #2
jale2ice
Member
 
Registered: Aug 2002
Distribution: Gentoo
Posts: 49

Rep: Reputation: 15
I'm having the same problem... I'm using FC1 AMD Athlon XP 2500+ ASUS A7N8X nforce2 chipset....

Here is the errors from alsaconf:

Loading driver...
/usr/sbin/alsaconf: line 619: rcalsasound: command not found
Setting default volumes...
Saving the mixer setup used for this in /etc/asound.state.
/usr/sbin/alsactl: save_state:1061: No soundcards found...

Now, I read here http://www-ccrma.stanford.edu/planet...configurealsa, that I had to remove the OSS driver modules..... I don't know how to do that..... Please help!
 
Old 12-09-2003, 03:46 PM   #3
xquizit
Member
 
Registered: Mar 2003
Location: Canada
Distribution: Ubuntu Dapper
Posts: 68

Rep: Reputation: 15
if you use apt there is a kernel there which ALSA and other too.

xquizit
 
Old 12-09-2003, 07:24 PM   #4
jale2ice
Member
 
Registered: Aug 2002
Distribution: Gentoo
Posts: 49

Rep: Reputation: 15
That's what I'm using... apt-get.
 
Old 12-09-2003, 07:43 PM   #5
umgah
LQ Newbie
 
Registered: Dec 2003
Posts: 3

Rep: Reputation: 0
First, I have an Aureal Vortex 2 card working with ALSA in fedora (it uses the snd-au8830 module). I compiled ALSA 0.98 from source...so my advice may not apply directly from your situation.

Even after I installed ALSA properly, I could not hear sound....since all the volume controls are muted. So I had to run gnome-alsamixer to change the mixer settings (aumix should also work for this purpose). If you run gnome-alsamixer, do you see any controls (e.g. Master Volume, PCM Volume, etc.)?

Next, I had problems getting things running depending on how I compiled ALSA (I'm being vague on purpose, since it may be unnecessarily complicated in your case). I think the first step needed to help you out is to find out why the snd-au8810 module is not loading properly.

Bring up a terminal window, then do the following at the command line.

su root
(Enter your root password)
/sbin/modprobe snd-au8810

Do you get any error messages? If so, post them. Perhaps I or someone else can get you on the right track.
 
Old 12-09-2003, 07:57 PM   #6
jale2ice
Member
 
Registered: Aug 2002
Distribution: Gentoo
Posts: 49

Rep: Reputation: 15
[root@bigpimpin jale2ice]# /sbin/lsmod
Module Size Used by Tainted: P
keybdev 2624 0 (unused)
hid 23652 0 (unused)
usb-ohci 21192 0 (unused)
usbcore 77984 0 [hid usb-ohci]
snd-pcm-oss 43172 0 (autoclean)
snd-mixer-oss 15376 0 (autoclean) [snd-pcm-oss]
snd-intel8x0 23304 0 (autoclean)
snd-ac97-codec 57580 0 (autoclean) [snd-intel8x0]
snd-pcm 84320 0 (autoclean) [snd-pcm-oss snd-intel8x0]
snd-timer 19332 0 (autoclean) [snd-pcm]
gameport 3380 0 (autoclean) [snd-intel8x0]
snd-page-alloc 9300 0 (autoclean) [snd-intel8x0 snd-pcm]
snd-mpu401-uart 5104 0 (autoclean) [snd-intel8x0]
snd-rawmidi 17984 0 (autoclean) [snd-mpu401-uart]
snd-seq-device 5944 0 (autoclean) [snd-rawmidi]
snd 45732 0 (autoclean) [snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-ac97-codec snd-pcm snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 6500 4 (autoclean) [snd]
nvnet 30144 1 (autoclean)
autofs4 10932 2 (autoclean)
floppy 56348 0 (autoclean)
sg 34796 0 (autoclean)
sr_mod 17016 0 (autoclean)
ide-scsi 11856 0
scsi_mod 109384 3 [sg sr_mod ide-scsi]
ide-cd 34176 0
cdrom 33984 0 [sr_mod ide-cd]
mousedev 5204 1 (autoclean)
input 5824 0 (autoclean) [keybdev hid mousedev]
agpgart 55108 3 (autoclean)
nvidia 1764672 11 (autoclean)
ext3 70532 2
jbd 50796 2 [ext3]


Here is a /sbin/lsmod...

I guess my problem is just removing OSS????
 
Old 12-09-2003, 10:34 PM   #7
umgah
LQ Newbie
 
Registered: Dec 2003
Posts: 3

Rep: Reputation: 0
Here is part of your lsmod output:

snd 45732 0 (autoclean) [snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-ac97-codec snd-pcm snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]

Here is the relevant output from my lsmod:

snd 45060 0 (autoclean) [snd-pcm-oss snd-mixer-oss snd-au8830 snd-pcm snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device snd-ac97-codec]

It appears that you have the driver for Intel onboard sound (snd-intel8x0) loaded instead of the driver for the Aureal card (in my case it is snd-au8830 since I have an Aureal Vortex 2 card...yours should be snd-au8810). Do you have a motherboard with integrated sound? This may be a silly question, but are you sure you have a sound card with an aureal chipset?

Perhaps you should try to the following at a root prompt to remove the intel driver and install the aureal driver:

modprobe -r snd-intel8x0
modprobe snd-au8810

If you do not get any error messages, then you should be OK. Fire up gnome-alsamixer to unmute everything. Then try to play some sounds.

Hope this helps.
 
Old 12-09-2003, 11:01 PM   #8
umgah
LQ Newbie
 
Registered: Dec 2003
Posts: 3

Rep: Reputation: 0
Oops! I just realized that jale2ice is not the original poster. Well...maybe raskoo will find some of my message helpful.

jale2ice...

So, you probably do have integrated sound on your motherboard. Well, I'm not sure what the problem with your set-up is...but I did not have to remove anything related to oss in order to get ALSA working. However, I did have an application that would not give me sound until I killed 'artsd', a sound server used by KDE.
 
Old 12-10-2003, 03:55 AM   #9
jale2ice
Member
 
Registered: Aug 2002
Distribution: Gentoo
Posts: 49

Rep: Reputation: 15
Well, I found out what the problem was. I didd not have all the rpms to make this work. There is this one rpm which is probably the most important. KERNEL-ALSA ( I got it from Freshrpms)

Now, I need sound in quake3... I get this error: Could not mmap dma buffer PROT_WRITE|PROT_READ
trying mmap PROT_WRITE (with associated better compatibility / less performance code)
/dev/dsp: Input/output error
Could not mmap /dev/dsp


Does anyone know what this is?
 
Old 12-13-2003, 01:51 AM   #10
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
I got that error from ET while running alsa on my Slack box.

Mind this is a different card, and a different distro -- but here's how I fixed that.

In modules.conf I added

Code:
options snd-via82xx index=0 dxs_support=2

Try that ?

NOTE: this is also a fix for scratchy / horrible sound through alsa and the Via card / chipset.
-Shade
 
Old 12-14-2003, 05:06 AM   #11
roskoo
LQ Newbie
 
Registered: Apr 2002
Distribution: redhat7.2
Posts: 16

Original Poster
Rep: Reputation: 0
from roskoo
just to say now I've just install again the "same alsas rpms" than previously
, but more recents -from the 9th of december- from freshrpms.net -except this one : alsa-lib-devel-1.0.0-0.rc2.1.fr.i386.rpm and miracle...that's working nice just now
 
Old 01-04-2004, 01:40 AM   #12
e1000
Member
 
Registered: Oct 2003
Location: California
Distribution: Ubuntu
Posts: 582

Rep: Reputation: 30
EDIT

oops, I posted a reply to the wrong post

Last edited by e1000; 01-04-2004 at 01:57 AM.
 
Old 01-04-2004, 08:00 PM   #13
pezplaya
Member
 
Registered: Dec 2003
Distribution: Gentoo / Slackware
Posts: 92

Rep: Reputation: 15
I don't know if this is against the rules to link to another linux forum, but the whole idea of these forums are to help people, and thats what im here for.


At justlinux.com this one guy post on how to get alsa working. Good steps and works great.

http://www.justlinux.com/forum/showt...hreadid=116182
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Annoying Alsa drivers Fedora core 3 linuxmandrake Linux - Hardware 10 06-11-2005 06:33 PM
can't install RPMs under Fedora Core 2 thorax Linux - Software 8 07-01-2004 01:46 PM
Trying to install ALSA drivers gauge73 Linux - Newbie 6 02-12-2004 09:28 PM
Can't install alsa drivers Jiggy Linux - Software 12 12-27-2003 08:47 AM
Install ALSA drivers with fedora core 1 wlchapman13 Fedora 2 11-11-2003 08:45 PM


All times are GMT -5. The time now is 11:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration