LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   package installation (http://www.linuxquestions.org/questions/fedora-35/package-installation-4175485233/)

Eagle Eye 11-20-2013 04:42 AM

package installation
 
I want to install the make-4.0 package in
my fedora 18.On which there is already make-3.82 is installed
and please tell me through command line.

and I want to manually install it on my system not through yum or another
thing.And please tell me where we have to install it.

./configure --prefix=? //tell me about this destination point.I have make-4.0 tarball and extracted and cd make-4.0.

tigerton 11-20-2013 05:02 AM

Typing ./configure --help you can get all the info you need. Anyhow, if you type simply ./configure, it will configure the package for being installed in /usr/local.

tomwest 12-03-2013 04:12 AM

Hello Eagle Eye,

If you have make-3.82 installed on your system from an rpm file or from the original installation, and, you want to install make-4.0 from a tarball, then it might be a good idea to uninstall the older make with the rpm command after you have installed the new make but before you use the new make. I would do that so that when you install the newer make there are no conflicts between the two programs. Something like:
Code:

rpm -e make
should take the older one out. But, you should do this only after you have installed the new make because you will need the older make to make the newer make.

With the newer one, it will almost certainly by default install in the /usr/local/... directories such as /usr/local/bin rather than /usr/bin. This should be made clear in the INSTALL file or the README file of the tarball. You can change this default by using the prefix variable you mentioned, but it is unnecessary unless you have a particular special reason to do so. After you run:
Code:

./configure
you usually run:
Code:

make
and then become root and run:
Code:

make install
This should be described in the tarball files but sometimes it isn't. Anyway, what I have described is the common way to go to the best of my knowledge. It's worked for me.

wmakowski 12-03-2013 03:24 PM

I would have to disagree with tomwest about removing the old version of make. There will not be conflicts as long as you install the new version in /usr/local. Your $PATH statement will take care of executing the new version and not the old.

When working with packages it is better to use yum than rpm directly so that dependencies are observed and maintained. This also maintains the integrity of the Fedora release. If you install a tarball, the rpm/yum database has no clue that that package is on the system. If you try to remove the old version of make both rpm and yum will most likely complain that there is a dependency you need to consider.

Code:

$ rpm -q --whatrequires make
eclipse-cdt-8.1.2-1.fc18.i686
akmods-0.5.1-3.fc18.noarch
openssl-1.0.1e-30.fc18.i686


tomwest 12-03-2013 04:54 PM

wmakowski wrote:
Quote:

When working with packages it is better to use yum than rpm directly so that dependencies are observed and maintained.
As I read the OP he specifically wanted to install "not through yum". I guess he had his reasons which he did not state, so my reply was targeted to his question as he put it.

The advantages of yum as stated above in relation to taking care of dependencies is the case as I understand it.

In relation to the $PATH variable taking care to execute /usr/local/bin before /usr/bin, that would the be case if the executable directories are in that order in the $PATH variable, which is the default in f19. However, $PATH is configurable and the order can be changed. The OP was silent on that score, so I made no assumptions.

In relation to conflicts between the two versions of make, I take the point that it is possible to keep both versions and that they may not conflict if the $PATH variable is set at the default. However, I can't see the point of keeping a redundant program. The logic of doing that escapes me. But I suppose that my reference to conflicts comes from my experience with not deleting redundant programs in just such a case as the OP describes, where one is in the packaged system and the other is in the /usr/local system. The conflicts I had did not occur with the executables in /usr/bin and /usr/local/bin but with the libraries associated with those executables based on the differences between /usr/lib and /usr/local/lib. These were subtle problems that I had trouble working through at the time, hence my reference to conflicts and my suggestion to remove the redundant program.

As suggested above, the new make may need updated versions of its dependencies installed, so that would need to be attended to.

A further point about yum and rpm is this: if one is not on broadband, yum is not a viable option for many users of a large distribution like fedora because to keep up to date with yum involves downloading hundreds of megabytes of data at times to update programs and dependencies and this is not realistic on dial-up or other slow internet connections. For example downloading at 5 minutes a megabyte on a dial-up connection would mean about a 16 hour download for 200 megabytes, and most dial-up providers in these parts allow 4, 5 or 6 hour windows to the internet, so it's very problematical and very painful. My point is that the conventional advice of "use yum" may not actually hit the mark for all cases. In fact there are ways of dealing with "dependency hell" using rpm, but that's a different topic.

knudfl 12-03-2013 06:14 PM

1 Attachment(s)
# 1 .

I guess you want make-4.0 for the unstable development version of LFS ?

If you really want make-4, the best choice is to try with an rpm package for Fedora 18.
ftp://bo.mirror.garr.it/pub/1/unity/...-4.0-1.src.rpm
> make-4.0-1.src.rpm : Unpack the source SRC RPM with $ rpm -i make-4.0-1.src.rpm,
.. and build the new package : $ rpmbuild -bb make-4.0_fc18.spec

Example build result, 32bits (i686) : make-4.0-1.fc18.i686.rpm
https://drive.google.com/file/d/0B7S...it?usp=sharing
-

druuna 12-06-2013 07:21 AM

Quote:

Originally Posted by knudfl (Post 5074901)
I guess you want make-4.0 for the unstable development version of LFS ?

Currently, both stable and unstable LFS do not need make 4.0 to be installed on the host.

Host requirements for both are: Make-3.81


All times are GMT -5. The time now is 01:37 PM.