LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 06-25-2005, 11:07 AM   #1
andrei_t
LQ Newbie
 
Registered: Jun 2005
Location: QC, Canada
Distribution: Fedora 12
Posts: 13

Rep: Reputation: 0
Angry Obsolete version required...


Something very weird is happening. I just installed FC4. I have libstdc++.so.6 installed, and when I try to run the firefox installer it says libstdc++.so.5 not found. I believe that it is an older version... Should I downgrade, or there is a better solution?
 
Old 06-25-2005, 11:15 AM   #2
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
Fedora core comes with firefox in a default installation in 4.

if you don't have it just a "yum install firefox" will get it(or maybe it is yum install mozilla-firefox)
 
Old 06-25-2005, 11:18 AM   #3
andrei_t
LQ Newbie
 
Registered: Jun 2005
Location: QC, Canada
Distribution: Fedora 12
Posts: 13

Original Poster
Rep: Reputation: 0
Tried with yum it says it dosen't find anything.

Yes, firefox comes installed by default, but I want to update it.
 
Old 06-25-2005, 11:26 AM   #4
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
type in as root

updatedb

locate libstdc++.so.6


then post the output of that.
 
Old 06-25-2005, 11:37 AM   #5
andrei_t
LQ Newbie
 
Registered: Jun 2005
Location: QC, Canada
Distribution: Fedora 12
Posts: 13

Original Poster
Rep: Reputation: 0
There:


[root@localhost dre]# updatedb
[root@localhost dre]# locate libstdc++.so.6
/usr/lib/libstdc++.so.6
/usr/lib/libstdc++.so.6.0.4
 
Old 06-25-2005, 11:40 AM   #6
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
ok. now type as root

ln -s /usr/lib/libstdc++.so.6 /usr/lib/libstdc++.so.5

then type ldconfig and then try to install firefox
 
Old 06-25-2005, 11:47 AM   #7
andrei_t
LQ Newbie
 
Registered: Jun 2005
Location: QC, Canada
Distribution: Fedora 12
Posts: 13

Original Poster
Rep: Reputation: 0
ldconfig says command not found.

I tried the installer again.
This is what I got before: ./firefox-installer-bin: /usr/lib/libstdc++.so.5: version `GLIBCPP_3.2' not found (required by ./firefox-installer-bin)
This is what I get now: ./firefox-installer-bin: /usr/lib/libstdc++.so.5: version `CXXABI_1.2' not found (required by ./firefox-installer-bin)
 
Old 06-25-2005, 11:53 AM   #8
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
You need to install compat-libstdc++-33.
 
Old 06-25-2005, 11:57 AM   #9
andrei_t
LQ Newbie
 
Registered: Jun 2005
Location: QC, Canada
Distribution: Fedora 12
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks! It works!!
 
Old 07-07-2005, 02:19 AM   #10
magicforest
LQ Newbie
 
Registered: Jul 2005
Posts: 1

Rep: Reputation: 0
Hi, i've the same problem with my mdk...
I can't find any rpm with compat-libstdc++-33
Where did you find it ?
 
Old 07-08-2005, 05:19 AM   #11
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Quote:
Originally posted by magicforest
Hi, i've the same problem with my mdk...
I can't find any rpm with compat-libstdc++-33
Where did you find it ?
On Mandrake, try installing the libstdc++ packages.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
*** pkg-config too old; version 0.14 or better required. sfaae Linux - Newbie 2 07-11-2009 03:23 PM
php configuration erro libxml2 version 2.5.10 or higher required raninix Linux - Newbie 2 10-28-2004 10:59 AM
M$ Doz obsolete? witeshark General 11 02-07-2004 06:45 PM
Is Microsoft Obsolete? GtkUser General 24 07-24-2003 07:34 PM
What's up with iostream.h, is it obsolete? linuxlah Programming 4 02-04-2003 05:29 AM


All times are GMT -5. The time now is 11:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration