LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-15-2003, 08:25 PM   #1
capstone737
LQ Newbie
 
Registered: Dec 2002
Location: Brisbane, Australia
Distribution: Red Hat latest release
Posts: 13

Rep: Reputation: 0
nVidia video drivers under Fedora


I have an nVidia FX5600 and have just installed Fedora. Does anyone know if the
RH9 drivers can be used? I understand that Fedora has a different vervion of gcc, so this may be a problem.

Regards,
Brad
 
Old 11-15-2003, 08:32 PM   #2
lhm0155
LQ Newbie
 
Registered: Aug 2003
Posts: 6

Rep: Reputation: 0
yes they can

you just need to enter export CC=gcc32 AFTER you go to text only mode and BEFORE running the NVIDIA-Linux-x86-1.0-4496-pkg2.run file, works like a charm... there are a few issues with the XFree86-MESA-libgl drivers that you can find info on just google it, especially if your going to run things like UT2003 or anything of the sort
 
Old 11-16-2003, 03:10 AM   #3
LordMorgul
Member
 
Registered: Sep 2003
Location: Ca
Distribution: Fedora, RH 7.1-9.0
Posts: 68

Rep: Reputation: 15
Make certain that you have the "gcc32" package installed, because the kernel is built with a different compiler than most other applications.

Removing the Mesa libs is a good idea for almost everyone. The files other packages depend on are replaced by the nVidia installer, so there is rarely any problem with doing so.
rpm -e --nodeps XFree86-Mesa-libGL
 
Old 12-03-2003, 05:30 AM   #4
capstone737
LQ Newbie
 
Registered: Dec 2002
Location: Brisbane, Australia
Distribution: Red Hat latest release
Posts: 13

Original Poster
Rep: Reputation: 0
Fedora nVidea drivers

I tried you suggestions using gcc32 etc but the RH9 nVidea drivers don't appear to work with Fedora. The video driver defaulted to "nv" and when I changed it to "nvidea" the PC just locked up on boot/X restart.

Regards,
Brad
 
Old 12-03-2003, 03:48 PM   #5
LordMorgul
Member
 
Registered: Sep 2003
Location: Ca
Distribution: Fedora, RH 7.1-9.0
Posts: 68

Rep: Reputation: 15
You may have just typoed in the post, but you mention changing "nv" to "nvidea" which is incorrect spelling. It should be "nvidia".

There are Fedora RPMs available, and I suggest anyone trying to get the drivers running without using the installer provided or source directly, use these and give the packagers feedback about your success. These should handle some of the issues with Mesa as well, but naturally YMMV.

http://atrpms.physik.fu-berlin.de/di...idia-graphics/

http://www2.educ.umu.se/~peter/nvidia/

For more problems after you know its installed and configured right, try disabling apic, acpi, and apm as described in the readme from nVidia. This is a good first step in debugging blank screens and full kernel panic or lockup.

Last edited by LordMorgul; 12-03-2003 at 03:50 PM.
 
Old 12-08-2003, 03:34 PM   #6
jsmarshall85
Member
 
Registered: Aug 2003
Posts: 386

Rep: Reputation: 30
.nptli grabbed the nvidia -glx-1.0.4496-0.fdr.10.1.i686 from http://www2.educ.umu.se/~peter/nvidia/
when i ran it it said i needed kernel module nvidia driver (which i got and installed) and also xfree86 mesa libgl. when i got the mesa rpm and tried to install it, an error came back and said a newer version was already installed

my kernel is the standard with fedora core 1, 2.4.22-1.2115.nptl. the nvidia kernel driver i installed is 2.4.22-1.2129.nptl. did i screw something up?
 
Old 12-08-2003, 05:08 PM   #7
LordMorgul
Member
 
Registered: Sep 2003
Location: Ca
Distribution: Fedora, RH 7.1-9.0
Posts: 68

Rep: Reputation: 15
You have used a kernel driver version that does not match your kernel perfectly, that will not work. You need to use the 2115.nptl kernel driver if that is the kernel you are running, be precise when matching these numbers.

I do not know what RPMs are marked as dependencies in those driver RPMs since I haven't personally used any of them yet.

You can check this using the command:
Code:
rpm -qpi --requires packagename.rpm
The packages required by packagename.rpm are listed at the bottom of the output, one per line. If you have installed the packages it requires, but it still errors try reinstalling the packages, then use the --nodeps option to rpm while installing and see how it goes (keep in mind that a dependency error usually does mean things aren't quite right).

Last edited by LordMorgul; 12-08-2003 at 05:13 PM.
 
Old 12-09-2003, 04:52 AM   #8
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
Install the db only for the MESA GL by using the following cmd:

$ rpm -ivh --nodeps --justdb <rpm filename>

This will fix the RPM database inconsistency ..
 
Old 12-09-2003, 01:23 PM   #9
jsmarshall85
Member
 
Registered: Aug 2003
Posts: 386

Rep: Reputation: 30
first off thank you to all who have helped so far. i have the XFree86-Mesa-libGL-4.3.0-42 already installed from the fedora cd. did the just db thing and it said it was already installed. i have updated my kernel as well to 2.4.22-1.2129 and installed the kernel-source 2129. when i run the run file from nvidia it says no kernel source to compile and if i run the nvidia glx install rpm it says it cant fine libgl?????

maybe i should reinstall. update the kernel, make sure all deps are installed and then try again. funny how installing the nvidia driver works so well on other distros. i have installed it fine on slackware 9.1, suse 9, and mandrake (9.1 not 9.2)

any other suggestions?

thanks again!
 
Old 12-10-2003, 01:35 PM   #10
shizzy-t
Member
 
Registered: Dec 2003
Location: Maine/USA
Distribution: Fedora Core, Centos, Solaris
Posts: 34

Rep: Reputation: 15
before doing the install try
export IGNORE_CC_MISMATCH=1
as well as the CC=gcc32

worked for me
 
Old 12-11-2003, 06:29 AM   #11
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
I do think this has been discussed in detail in few other threads, but here is the step anyway:

1. Download the LATEST driver from NVidia website
2. Make sure you have gcc32 installed
3. Go to console terminal (CTL-ALT-F1) and logon as root
4. Shutdown X ($ init 3)
5. Remove XFree86-Mesa-libGL ($ rpm -e --nodeps XFree86-Mesa-libGL)
6. Set env variable CC=gcc32 ($ export CC=gcc32)
7. Run NVidia installer ($ sh NVIDIA-Linux-x86-1.0-4496-pkg2.run) and recompile module
8. Edit /etc/X11/XF86Config as per the readme
9. Install Mesa-libGL db only ($ rpm -ivh --nodeps --justdb XFree86-Mesa-libGL)
10. Restart X ($ init 5)

It works for me and hopefully it will work for you too. Good luck.
 
Old 12-11-2003, 08:15 AM   #12
jsmarshall85
Member
 
Registered: Aug 2003
Posts: 386

Rep: Reputation: 30
wiraone, that worked great! thanks for digging that up for me. im sure if i had searched a little better i might have found that, but know that i know i can pass it along the next time i see it asked

Thanks again! got my nvidia driver installed and on an updated kernel 2129!

Last edited by jsmarshall85; 12-11-2003 at 08:51 AM.
 
Old 02-05-2004, 05:33 PM   #13
greuben
LQ Newbie
 
Registered: Dec 2003
Location: Illinois
Distribution: Fedora Core 1
Posts: 3

Rep: Reputation: 0
I've tried to follow those very good instructions, but had a problem knowing how to edit the XF86Config file from the runlevel 3 command line. So I just restarted X and made the changes to the config file and then restarted system. Black screen. From the log files, it seems loading the newest nvidia driver and modules all goes fine until it (I think) tries to hand it back to the xserver, at which point the initialization fails with the message cannot locate suitable screens. Any suggestions would be appreciated.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia released new video drivers, ver 7174 today Pudge Fedora 3 04-01-2005 10:05 AM
Nvidia Drivers for Fedora 3 LemonyZ Linux - Newbie 2 01-16-2005 07:32 AM
Fedora and Nvidia Drivers lucastic Fedora 16 11-16-2003 08:58 PM
NVidia drivers with Fedora 1 jlacroix Fedora 11 11-12-2003 12:09 PM
Problems with NVIDIA Video Drivers teal Linux - Newbie 4 06-27-2003 05:26 AM


All times are GMT -5. The time now is 02:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration