LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 11-18-2012, 05:55 PM   #1
hDUQUE
Member
 
Registered: Jan 2007
Posts: 76

Rep: Reputation: 15
nVidia FC17 crashes


Hi guys,

I am geting a problem since FC14 thru FC17 with my Nvidea GT215 card. I have a Toshiba Quosmio Laptop.

Code:
 lspci|grep nVidia
01:00.0 VGA compatible controller: nVidia Corporation GT215 [GeForce GTS 360M] (rev a2)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
The computes crashes after a while working with some X applications like displaying videos or mixing music. I have reinstalled drivers, disable the nouveau driver, etc ... without solution ... the worst is that it works fine with windows vista :-( so i have to get a solution.

so far i have foundout that when using google crhome and clearing the recent history (last day) the time before crashing is longer; so i conclude that maybe this problem is asociated with a cache or swap issue
Code:
swapon -s

Filename				Type		Size	Used	Priority
/dev/mapper/vg_duke88lt17-lv_swap       partition	5177340	0	0
any ideas, you guys !!!

thanks in adance

Hector
 
Old 11-19-2012, 05:21 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,477

Rep: Reputation: 87
Can you see anything in /var/log/messages or dmesg?

As root in a terminal:

Code:
# cat /var/log/messages | more

# dmesg
Can you spot any log entries that are obviously awry?

It --could-- also be memory / hardware problems - you might want to download memtest86 and let it run (some distros' discs also have a memtest option if you boot off the disc). I had enormous problems with exactly this type of random crashing once and turned out I had a bad DRAM module - and my PC also worked well in Windows (for whatever reason) but kept crashing in Fedora.

I've also heard of this happening with an overheated / insufficiently ventilated system, the moment it had to start working hard (e. g. you mention mixing music, etc. - not that a modern processor is pushed that hard by these tasks). E. g. physically check that, for example, that all the fans that should run, do run...

If I where you I'd also log into the UEFI / BIOS and see what it thinks are the temperature and RPMs of any fans that it can see.
 
Old 11-19-2012, 10:53 PM   #3
hDUQUE
Member
 
Registered: Jan 2007
Posts: 76

Original Poster
Rep: Reputation: 15
hi rylan76; thanks for answering,

var/log looks fine:

Code:
cat /var/log/messages |tail -n 20

Nov 19 22:39:46 duke88LT17 goa[1339]: goa-daemon version 3.4.2 starting [main.c:112, main()]
Nov 19 22:39:47 duke88LT17 dbus-daemon[756]: ** Message: No devices in use, exit
Nov 19 22:40:39 duke88LT17 systemd[1]: sendmail.service operation timed out. Terminating.
Nov 19 22:40:39 duke88LT17 systemd[1]: Job sm-client.service/start failed with result 'dependency'.
Nov 19 22:40:39 duke88LT17 systemd[1]: Unit sendmail.service entered failed state.
Nov 19 22:40:39 duke88LT17 dbus-daemon[756]: Job failed. See system journal and 'systemctl status' for details.
Nov 19 22:40:39 duke88LT17 systemd[1]: Startup finished in 2s 598ms 255us (kernel) + 4s 443ms 92us (initrd) + 1min 51s 780ms 884us (userspace) = 1min 58s 822ms 231us.
Nov 19 22:43:48 duke88LT17 dbus-daemon[756]: dbus[756]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Nov 19 22:43:48 duke88LT17 dbus[756]: [system] Activating service name='net.reactivated.Fprint' (using servicehelper)
Nov 19 22:43:48 duke88LT17 dbus-daemon[756]: Launching FprintObject
Nov 19 22:43:48 duke88LT17 dbus-daemon[756]: dbus[756]: [system] Successfully activated service 'net.reactivated.Fprint'
Nov 19 22:43:48 duke88LT17 dbus[756]: [system] Successfully activated service 'net.reactivated.Fprint'
Nov 19 22:43:48 duke88LT17 dbus-daemon[756]: ** Message: D-Bus service launched with name: net.reactivated.Fprint
Nov 19 22:43:48 duke88LT17 dbus-daemon[756]: ** Message: entering main loop
Nov 19 22:44:18 duke88LT17 dbus-daemon[756]: ** Message: No devices in use, exit
however dmesg has a strange msg:

Code:
dmesg

[   27.856816] RPC: Registered named UNIX socket transport module.
[   27.856820] RPC: Registered udp transport module.
[   27.856822] RPC: Registered tcp transport module.
[   27.856823] RPC: Registered tcp NFSv4.1 backchannel transport module.
[   33.586001] NVRM: Your system is not currently configured to drive a VGA console
[   33.586010] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[   33.586039] NVRM: requires the use of a text-mode VGA console. Use of other console
[   33.586044] NVRM: drivers including, but not limited to, vesafb, may result in
[   33.586049] NVRM: corruption and stability problems, and is not supported.
[   58.783247] fuse init (API version 7.20)
[   58.817941] SELinux: initialized (dev fusectl, type fusectl), uses genfs_contexts
[   58.859058] SELinux: initialized (dev fuse, type fuse), uses genfs_contexts
what does mean "...not currently configured to drive a VGA console" ?

by the way i have increased my swap from 5GB to 15 GB, and that increase also the time between fails.

i will increase the swap space again :-(

any ideas ?
 
Old 11-20-2012, 04:50 AM   #4
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,477

Rep: Reputation: 87
Quote:
Originally Posted by hDUQUE View Post
hi rylan76; thanks for answering,

however dmesg has a strange msg:

Code:
dmesg

[   33.586001] NVRM: Your system is not currently configured to drive a VGA console
[   33.586010] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[   33.586039] NVRM: requires the use of a text-mode VGA console. Use of other console
[   33.586044] NVRM: drivers including, but not limited to, vesafb, may result in
[   33.586049] NVRM: corruption and stability problems, and is not supported.
what does mean "...not currently configured to drive a VGA console" ?
Well it clearly states above "may result in corruption and stability problems."

I've got NO idea -what- "not configured to drive a VGA console" actually means, or what you can do to solve it!

You -are- running the latest X-Windows driver for your video card? Or not?
 
Old 11-26-2012, 08:58 AM   #5
hDUQUE
Member
 
Registered: Jan 2007
Posts: 76

Original Poster
Rep: Reputation: 15
hi guys,
i hace increase swap space until 35 GB and works better, but it still crashing anfeter a half day ... :-(
it looks like a randow issue ...

thanks for comments

Hector
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
glib2-2.32.4-1.fc17.i686 crashes during installation (segfault) yacau Fedora 12 09-08-2012 06:40 AM
fc17 install nvidia drivers & modeswitch Telstra Bigpond usb modem/memory stick worzel1968 Fedora 7 07-20-2012 12:19 AM
NVIDIA XServer driver crashes! J.Beall Linux - Software 2 12-15-2010 03:22 AM
Xinerama with an ATI and an NVidia crashes Jezzirolk Linux - Software 2 01-22-2010 12:17 PM
X-crashes using gtkglext with nvidia drhougen Linux - Software 1 09-28-2003 11:13 AM


All times are GMT -5. The time now is 04:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration