LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 02-14-2007, 03:32 PM   #1
srn1
LQ Newbie
 
Registered: May 2006
Location: Washington
Distribution: Fedora 4, 5, 6
Posts: 9

Rep: Reputation: 0
nvidia driver cause Fedora 6 to hang when X windows trys to start.


My Asus motherboard has a built-in nvidia video card. I loaded FC 6 from dvd and X windows runs fine with the default driver "nv". I downloaded the nvidia driver utility from www.nvidia.com built a driver. When I start X, my machine locks up. Then I tried to get a precompiled driver from livia-repo. After sucessful installation via yum, the same thing happened.

Ideas?
 
Old 02-14-2007, 03:50 PM   #2
Penguin of Wonder
Senior Member
 
Registered: Sep 2005
Location: West Virginia
Distribution: Gentoo
Posts: 1,249

Rep: Reputation: 45
Do you have errors written to your log file for X? In /var/log. And post the relavent parts of your xorg.conf file. Perhaps it has been setup incorrectly.
 
Old 02-15-2007, 12:17 AM   #3
srn1
LQ Newbie
 
Registered: May 2006
Location: Washington
Distribution: Fedora 4, 5, 6
Posts: 9

Original Poster
Rep: Reputation: 0
From Xorg.0.log

only Warning or Error is-
...
(WW) NVIDIA(0): 32-bit ARGB GLX visuals are only supported in depth 24.
...
last line of Xorg.0.log is-
...
FreeFontPath: FPE "unix/:7100" refcount is 2, should be 1; fixing.



From xorg.conf

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"
EndSection

Section "InputDevice"


Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"

Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Unknown monitor"
HorizSync 31.5 - 60.0
VertRefresh 50.0 - 75.0
ModeLine "1024x768_82.00" 90.3 1024 1088 1200 1376 768 769 772 805 -hsync +vsync
Option "dpms"
EndSection

Section "Device"

# disable hardware mouse
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "nVidia Corporation C51 PCI Express Bridge"
Option "HWcursor" "false"
Option "RenderAccel" "1"
Option "TVStandard" "NTSC-M"
Option "ConnectedMonitor" "TV"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 02-15-2007, 01:35 AM   #4
Penguin of Wonder
Senior Member
 
Registered: Sep 2005
Location: West Virginia
Distribution: Gentoo
Posts: 1,249

Rep: Reputation: 45
If you change Driver "nvidia" to "nv" will it boot? If so you'll loose your hardware acceleration, but at least you can get back into X till you figure out whats wrong.
 
Old 02-15-2007, 01:45 AM   #5
wildar
Member
 
Registered: Jan 2007
Distribution: Mandriva 2008, Mandrake 2005, Ubuntu 8.04.1
Posts: 239

Rep: Reputation: 30
Quote:
(WW) NVIDIA(0): 32-bit ARGB GLX visuals are only supported in depth 24.
If we base our troubleshooting on this error, then we have couple of options in the xorg.conf.

1. Change DefaultDepth 16 to DefaultDepth 24, Depth 16 to Depth 24

and/or

2. Change Option "AddARGBGLXVisuals" "True" to Option "AddARGBGLXVisuals" "False"
 
Old 02-15-2007, 02:47 PM   #6
srn1
LQ Newbie
 
Registered: May 2006
Location: Washington
Distribution: Fedora 4, 5, 6
Posts: 9

Original Poster
Rep: Reputation: 0
I did change the driver to "nv" and X windows does work. My goal is to set up a Mythtv box. Therefore I really want the nvidia driver to work.

I will try the other suggestions tonight.
Quote:
1. Change DefaultDepth 16 to DefaultDepth 24, Depth 16 to Depth 24

and/or

2. Change Option "AddARGBGLXVisuals" "True" to Option "AddARGBGLXVisuals" "False"
 
Old 02-15-2007, 05:18 PM   #7
defiantone
LQ Newbie
 
Registered: Feb 2007
Location: Ottawa Canada
Distribution: Fedora Core 6
Posts: 2

Rep: Reputation: 0
Don't know if this helps, but I using my Tv in a Dualview config and it works sweet

This is my Xorg.conf file.
I have a Asus A7V8X-X Athanlon 1.3Ghz, GeForce 6200 256mb and I have my TV setup as my second monitor.


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "Multihead layout"
Screen 0 "Screen0" LeftOf "Screen1"
Screen 1 "Screen1" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "off"
Option "Clone" "off"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"

Identifier "Monitor0"
ModelName "Monitor 1280x1024"
HorizSync 31.5 - 79.0
VertRefresh 50.0 - 90.0
Option "EDID" "false"
Option "dpms"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Monitor 1024x768"
HorizSync 31.5 - 57.0
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nvidia"
VendorName "Videocard Vendor"
BoardName "nVidia Corporation NV44A [GeForce 6200]"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600"
EndSubSection
EndSection
 
Old 02-15-2007, 07:50 PM   #8
srn1
LQ Newbie
 
Registered: May 2006
Location: Washington
Distribution: Fedora 4, 5, 6
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
1. Change DefaultDepth 16 to DefaultDepth 24, Depth 16 to Depth 24

and/or

2. Change Option "AddARGBGLXVisuals" "True" to Option "AddARGBGLXVisuals" "False"
No luck with changing either of the above.

I'll try some combinations that defiantone has suggested.

Last edited by srn1; 02-15-2007 at 07:52 PM.
 
Old 02-15-2007, 08:35 PM   #9
srn1
LQ Newbie
 
Registered: May 2006
Location: Washington
Distribution: Fedora 4, 5, 6
Posts: 9

Original Poster
Rep: Reputation: 0
No luck with selected items form defiantone's xorg.conf file.

This may be interesting -
With the driver "nvidia" set, my computer would lock up if I tried to run
Code:
system-config-display
. When I changed to driver "nv" I was able to run
Code:
system-config-display
and select the "nvidia" driver. Once I tried to restart X, it locked up again.

More details about hardware:
Motherboard: Asus A8N-VM CSM
onboard graphics: NVIDIA GeForce 6150 GPU
Chipset: Northbridge

Any more ideas out there?

Last edited by srn1; 02-15-2007 at 08:38 PM.
 
Old 02-16-2007, 01:12 AM   #10
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 59
There has been allot of nvidia complaints tonight, most have been related to installing kmod-nvidia via yum which apparently installs the latest version matching last kernel update just recently released, I can't remember what the version is but you should apply all updates before issuing command:

yum install kmod-nvidia

Remove kmod-nvidia first with command:

yum remove kmod-nvidia

Then apply udates before installing kmod-nvidia via yum.

Last edited by Junior Hacker; 02-16-2007 at 01:14 AM.
 
Old 02-16-2007, 12:23 PM   #11
v00d00101
Member
 
Registered: Jun 2003
Location: UK
Distribution: Fedora 8, Centos 5.1
Posts: 480

Rep: Reputation: 30
Try using the 96xx version.

Code:
yum remove kmod-nvidia -y
yum install kmod-nvidia-96xx -y
It might help, might not, but try it.
 
Old 02-17-2007, 10:19 AM   #12
srn1
LQ Newbie
 
Registered: May 2006
Location: Washington
Distribution: Fedora 4, 5, 6
Posts: 9

Original Poster
Rep: Reputation: 0
I uninstalled kmod-nvidia and then installed kmod-nvidia-96xx.

Did a reboot, and tried to start X. Same problem: X windows attempts to start and the monitor goes blank, computer locks up. I can't even to go to a different shell (Ctrl-Alt-F2).

Thanks for the suggestion, still not very happy with this situation.

I was experiencing the same problem with FC5 and thought FC6 might help but both releases behave the same way.

Is there any way to get more error information from X? I have already used
Code:
startx -logverbose 5
to try and get more info. Is there any sort of single step mode to loading X?

All ideas are welcome.
 
Old 02-18-2007, 11:14 PM   #13
srn1
LQ Newbie
 
Registered: May 2006
Location: Washington
Distribution: Fedora 4, 5, 6
Posts: 9

Original Poster
Rep: Reputation: 0
I FIXED IT.

Turns out it was one of the options in the Device section

Code:
Option "ConnectedMonitor" "TV"
When I commented it out, X loaded just fine.

By the way, I don't have a TV connected, I have a monitor. Don't remember how that option made it into my xorg.conf file, but it's gone now.

Thanks to all that replied.
 
Old 02-25-2007, 03:25 PM   #14
todayus
LQ Newbie
 
Registered: Feb 2007
Posts: 1

Rep: Reputation: 0
The solution posted by voodoo101, below, worked for me Thanks.

yum remove kmod-nvidia -y
yum install kmod-nvidia-96xx -y
 
  


Reply

Tags
kmod, nvidia


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia graphics driver kernel compile hang siegecraft4 Linux - Hardware 3 02-27-2005 03:33 PM
Fedora won't start after installing Nvidia driver odiseo77 Linux - Hardware 3 02-11-2005 11:55 AM
Fedora doesn't start after installing Nvidia driver odiseo77 Fedora 3 02-11-2005 11:50 AM
Trouble with new nVidia driver installation...no nvidia logo and KDE no start up mdb Linux - Software 8 08-18-2004 10:45 AM
Fedora Core 2 and Nvidia drivers (5336) cause X to hang tfdml37 Fedora 11 06-04-2004 06:22 AM


All times are GMT -5. The time now is 11:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration