LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   not able to install squirrelmail (http://www.linuxquestions.org/questions/fedora-35/not-able-to-install-squirrelmail-4175480974/)

gaurav0918 10-16-2013 12:17 AM

not able to install squirrelmail
 
Hi,

I am trying to install squirrelmail. But it gives me depandency errors for the following packages:
Error: Package: squirrelmail-1.4.22-3.el6.noarch (epel)
Requires: hunspell-en
Error: Package: squirrelmail-1.4.22-3.el6.noarch (epel)
Requires: php-mbstring

I downloaded from the following link:
http://epel.mirror.net.in/epel/6/i38...6-8.noarch.rpm

See the command:
[root@gaurav-server Packages]# yum install squirrelmail -y
Loaded plugins: refresh-packagekit, rhnplugin
Repository 'gaurav' is missing name in configuration, using id
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package squirrelmail.noarch 0:1.4.22-3.el6 set to be updated
--> Processing Dependency: php-mbstring for package: squirrelmail-1.4.22-3.el6.noarch
--> Processing Dependency: php for package: squirrelmail-1.4.22-3.el6.noarch
--> Processing Dependency: hunspell-en for package: squirrelmail-1.4.22-3.el6.noarch
--> Running transaction check
---> Package php.i686 0:5.3.2-6.el6 set to be updated
--> Processing Dependency: php-cli = 5.3.2-6.el6 for package: php-5.3.2-6.el6.i686
---> Package squirrelmail.noarch 0:1.4.22-3.el6 set to be updated
--> Processing Dependency: php-mbstring for package: squirrelmail-1.4.22-3.el6.noarch
--> Processing Dependency: hunspell-en for package: squirrelmail-1.4.22-3.el6.noarch
--> Running transaction check
---> Package php-cli.i686 0:5.3.2-6.el6 set to be updated
---> Package squirrelmail.noarch 0:1.4.22-3.el6 set to be updated
--> Processing Dependency: php-mbstring for package: squirrelmail-1.4.22-3.el6.noarch
--> Processing Dependency: hunspell-en for package: squirrelmail-1.4.22-3.el6.noarch
--> Finished Dependency Resolution
Error: Package: squirrelmail-1.4.22-3.el6.noarch (epel)
Requires: hunspell-en
Error: Package: squirrelmail-1.4.22-3.el6.noarch (epel)
Requires: php-mbstring
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@gaurav-server Packages]#
Contact # 9971829658

TB0ne 10-21-2013 04:34 PM

Quote:

Originally Posted by gaurav0918 (Post 5046571)
Hi,

I am trying to install squirrelmail. But it gives me depandency errors for the following packages:
Error: Package: squirrelmail-1.4.22-3.el6.noarch (epel)
Requires: hunspell-en
Error: Package: squirrelmail-1.4.22-3.el6.noarch (epel)
Requires: php-mbstring

I downloaded from the following link:
http://epel.mirror.net.in/epel/6/i38...6-8.noarch.rpm

The errors are VERY clear...you're missing the two packages listed. Download them and install them.
Quote:

See the command:
[root@gaurav-server Packages]# yum install squirrelmail -y
Loaded plugins: refresh-packagekit, rhnplugin
Repository 'gaurav' is missing name in configuration, using id
This system is not registered with RHN.
RHN support will be disabled.
...and if you PAID FOR RHEL, you would be able to use yum to install these things. So, if this is a new installation, STOP NOW. Download and install the latest version of CentOS instead, which is 99.x% IDENTICAL, but FREE, and use yum. Otherwise, all you're going to wind up with is an unstable/insecure server, since you WILL NOT be able to get bugfixes/updates/patches. PAY FOR RED HAT ENTERPRISE, or DON'T USE IT.


All times are GMT -5. The time now is 04:42 PM.