LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 07-14-2004, 07:56 PM   #1
ferreter
Member
 
Registered: Oct 2002
Location: USA, IL
Distribution: Debian/Gentoo/Slack
Posts: 215

Rep: Reputation: 30
-nolisten tcp for X


Hello,

I installed Fedora 2 core at work and I need to know where to disable X from listening w/ the above setting. What file do I need to edit, I've edited the gdm.conf and the xdm.conf to no avail.

Thanks!
 
Old 07-14-2004, 08:19 PM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi.

Try aliasing startx (or xinit or whatever) in either your ~/.bash_profile or /etc/bashrc
e.g.
alias startx='startx -- -nolisten tcp'

Dave
 
Old 07-19-2004, 11:10 AM   #3
growler
Member
 
Registered: Apr 2002
Posts: 84

Rep: Reputation: 15
Re: -nolisten tcp for X

Quote:
Originally posted by ferreter
Hello,

I installed Fedora 2 core at work and I need to know where to disable X from listening w/ the above setting. What file do I need to edit, I've edited the gdm.conf and the xdm.conf to no avail.

Thanks!
Try '/etc/X11/xdm/Xservers':

:0 local /usr/X11R6/bin/X :0 vt7 -dpi 96 -nolisten tcp
:1 local reserve /usr/X11R6/bin/X :1 vt8 -dpi 96 -nolisten tcp
 
Old 07-19-2004, 03:38 PM   #4
ferreter
Member
 
Registered: Oct 2002
Location: USA, IL
Distribution: Debian/Gentoo/Slack
Posts: 215

Original Poster
Rep: Reputation: 30
I edited Xservers and only had this one entry (which I had added the proper flags to earlier)

:0 local /usr/X11R6/bin/X -nolisten tcp

But it still seems to be listening when I run netcat -a (unless I'm reading the results incorrectly)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
--nolisten tcp glock19 Linux - General 11 02-05-2013 04:45 PM
SuSE 9.1 eliminating -nolisten tcp jdeisenberg Linux - Software 1 06-04-2004 05:38 PM
X server - how to disable the -nolisten tcp startx default? lugoteehalt Debian 3 05-04-2004 08:12 AM
startx -nolisten tcp shanenin Slackware 2 11-12-2003 05:00 PM
-nolisten tcp Xgates Linux - Security 4 01-23-2003 05:48 AM


All times are GMT -5. The time now is 06:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration