LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 01-25-2005, 05:08 AM   #1
cyanide_2
Member
 
Registered: Jan 2005
Location: india
Distribution: Fedora Core 3
Posts: 32

Rep: Reputation: 15
No Video after installing ATi drivers in fedora core 3


I installed the new drivers for ati..., changed the XF86Config file to xorg.conf, changed the keyboard thing to kbd, now after selecting Fedora from grub, it loads for a second after which there is no video...the monitor doesnt turn off because i can still see a sort of a light from it...but nothuing else help...
 
Old 01-25-2005, 05:49 AM   #2
cascatino
LQ Newbie
 
Registered: Jan 2005
Posts: 4

Rep: Reputation: 0
Know this kind of problem. Yesterday I've messed up with xorg.conf and now the boot stalls on something like "configuring kernel module". I think I'll have to reinstall everything!

Tell me if you have news about installing the radeon on fedore core 3 64 bit.
 
Old 01-25-2005, 06:43 AM   #3
cyanide_2
Member
 
Registered: Jan 2005
Location: india
Distribution: Fedora Core 3
Posts: 32

Original Poster
Rep: Reputation: 15
nope, have an athlon, so 64bit is not for me, atleast noe
 
Old 01-25-2005, 11:35 AM   #4
patfins
LQ Newbie
 
Registered: Mar 2004
Posts: 21

Rep: Reputation: 15
Total system freeze?

First watch your "/var/log/Xorg.0.log".

Maybe an AGP problem? I use the external AGP drivers.

/etc/xorg.conf:
...
Option "UseInternalAGPGART" "no"
...
 
Old 01-25-2005, 11:15 PM   #5
cyanide_2
Member
 
Registered: Jan 2005
Location: india
Distribution: Fedora Core 3
Posts: 32

Original Poster
Rep: Reputation: 15
well, sort of...i repaired that by booting in runlevel 3 and restoring the original xorg.conf file...but are you sure i must put internalagpgart=no ???
 
Old 01-26-2005, 01:16 AM   #6
cyanide_2
Member
 
Registered: Jan 2005
Location: india
Distribution: Fedora Core 3
Posts: 32

Original Poster
Rep: Reputation: 15
i tried putting INTERNALAGPGART "no" too, stiff doesnt work man, now im starting to get pissed off...have you got the new drivers to work in FC3 WITH Hardware Acceleration, if yes, can you please mail me at hello.cyanide (at) gmail (dot) com ....please, please.....
 
Old 02-01-2005, 11:39 PM   #7
liquidqtip
LQ Newbie
 
Registered: Feb 2005
Location: trondheim
Distribution: fedora core 3 64
Posts: 1

Rep: Reputation: 0
Getting extreemly frustrated!

Have ATI Radeon 9800Pro and Fedora Core 3 64bit running on a ShuttleX SN85G4 nForce 3, and 3D acceleration? No way...
The driver install's fine with the command: rpm -Uh --force fglrx64_6_8_0-8.8.25-1.x86_64.rpm

But if I run fglrxconfig and save it as xorg.conf my screen goes pitch black...
Please!!! Anyone!!
 
Old 02-02-2005, 02:15 AM   #8
cyanide_2
Member
 
Registered: Jan 2005
Location: india
Distribution: Fedora Core 3
Posts: 32

Original Poster
Rep: Reputation: 15
i got it running with 3d acceleration ...yeah yeah baby !!!!!! i downloaded an xorg.conf file from here, modified it a bit and it works !!!! heres the link:
http://www.stanford.edu/~fenn/linux/radeon.shtml
just download the final xorg.conf file and modify it to suit your monitor and graphics card...it works...
 
Old 02-02-2005, 02:36 AM   #9
cascatino
LQ Newbie
 
Registered: Jan 2005
Posts: 4

Rep: Reputation: 0
thank you, thank you, thank you.
Tonight I'll try to do my best with the precious informations you gave us!
 
Old 02-03-2005, 06:51 AM   #10
johnnydangerous
Member
 
Registered: Jan 2005
Location: Sofia, Bulgaria
Distribution: Fedora Core 4 Rawhide
Posts: 431

Rep: Reputation: 30
Wink

cyanide_2 great job for posting the link not sure if it will work but is it making the info about the driver to show only ati stuff not that Mesa GL that seems so messed up to have any connection with the ATI I don't understand why is that hole between ATi and Nvidia when talking about linux
 
Old 02-03-2005, 07:44 AM   #11
cyanide_2
Member
 
Registered: Jan 2005
Location: india
Distribution: Fedora Core 3
Posts: 32

Original Poster
Rep: Reputation: 15
no, the xorg.conf file ive listed here is only about 180 lines and it is enough...and yes, it does not contain any of the mesa3d thing....trust me, it works...but keep a backup of the original xorg.conf file, just in case you mess up...
 
Old 02-08-2005, 06:20 AM   #12
johnnydangerous
Member
 
Registered: Jan 2005
Location: Sofia, Bulgaria
Distribution: Fedora Core 4 Rawhide
Posts: 431

Rep: Reputation: 30
http://www.stanford.edu/~fenn/linux/radeon.shtml do you know where to get those packages but with kernel module 2.6.10-760?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 3 - ATI 8.18 Drivers Scarfy Linux - Hardware 0 11-08-2005 06:00 AM
Ati drivers and fedora core 3 just_dan Fedora - Installation 3 09-16-2005 12:00 PM
New ati drivers Fedora Core 3 linkin Fedora 7 02-14-2005 06:35 PM
installing video drivers for ATI 9200 disorderly Linux - Hardware 1 06-21-2004 04:49 PM
Fedora Core 2 test2 and ATI 3.7.6 drivers TCUmax Linux - Hardware 0 03-31-2004 03:34 PM


All times are GMT -5. The time now is 03:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration